All defrost/ no dash of floor. a/c and heat - Jeep Cherokee Forum
Jeep Cherokee Forum


OEM Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here! ZJ (93-98), WJ (99-04), WK (05+)
All ZJ/WJ/WK specific tech questions asked here!
Presented by the all-new Yokohama
Presented by the all-new Yokohama

All defrost/ no dash of floor. a/c and heat

Reply
 
 
 
Thread Tools Search this Thread
Old 01-25-2009, 08:28 PM   #1
Newbie
Thread Starter
 
Join Date: Nov 2008
Posts: 9

View 68alltheway's Photo Album My Photos
Default All defrost/ no dash of floor. a/c and heat

No matter which position the switch is in all the air comes out of the defrost. It is a 2003 Grand Cherokee Laredo. Its been happening for a few months and I'd loke to have it fixed before summer. I need help. When it started acting up you could cut it to the vents and cut off the ignition and back on. When I'd start the motor back up it would blow out of the vents. But now now matter what hot or cold or floor or dash, it always blows out of the defrost vents.
68alltheway is offline   Reply With Quote
Old 01-25-2009, 09:08 PM   #2
CF Veteran
 
finneys98xj's Avatar
 
Join Date: May 2008
Location: Virginia
Posts: 2,680

View finneys98xj's Photo Album My Photos
Default

vaccum line!!!!

Check all of yoor vac line.
finneys98xj is offline   Reply With Quote
Old 01-25-2009, 09:13 PM   #3
Senior Member
 
jpdocdave's Avatar
 
Join Date: Aug 2008
Location: tan house white shutters key's under the flower pot
Posts: 971

View jpdocdave's Photo Album My Photos
Default

yup, the default position if there's no vacuum is defrost. there's a vacuum line coming out of the firewall on the passenger side where the evaporator lines come out. that vacuum line gets an engine vacuum, follow it and make sure its not broken or disconnected.
jpdocdave is offline   Reply With Quote
Old 01-28-2009, 09:42 AM   #4
Member
 
Join Date: Jul 2008
Location: Argos indiana
Posts: 210

View skiebuster's Photo Album My Photos
Default

Quote:
Originally Posted by finneys98xj View Post
vaccum line!!!!

Check all of yoor vac line.
THats what my problem was. After posting the same question i went out and my father and i started looking and the vacuum line, big hose, from underneath the intake, bottom side of the throttlebody had popped off.
skiebuster is offline   Reply With Quote
Old 02-09-2009, 01:33 PM   #5
Newbie
Thread Starter
 
Join Date: Nov 2008
Posts: 9

View 68alltheway's Photo Album My Photos
Default FIXED!!!

I found a vacuum line behind the headlight that was rotted and cracked. The a/c and heater work perfect now. But the cruise control still doesn't work. The CRUISE light on the dash comes on but it won't engage. I checked the wiring through the column and it ohmed out good. Could it be another vacuum line?
68alltheway is offline   Reply With Quote
Old 02-06-2010, 03:00 PM   #6
Newbie
 
Join Date: Feb 2010
Location: Michigan
Posts: 1

View gav70's Photo Album My Photos
Default vac line for blower

Quote:
Originally Posted by 68alltheway View Post
I found a vacuum line behind the headlight that was rotted and cracked. The a/c and heater work perfect now. But the cruise control still doesn't work. The CRUISE light on the dash comes on but it won't engage. I checked the wiring through the column and it ohmed out good. Could it be another vacuum line?
Could you please give details on where the vac line is located? I have the same problem on me 96 grand cherokee and I'm trying to find where is comes out from the firewall under the hood. You said that it was rotted and cracked behind the headlight. Was it the driver side or passenger? do you know where it comes out from the firewall and what does it look like?

Help is much appreciated.
Thanks
G
gav70 is offline   Reply With Quote
Old 06-25-2010, 10:12 PM   #7
Newbie
 
Join Date: Dec 2009
Posts: 17

View swluther's Photo Album My Photos
Default

Hi, I am having the same problem with my a/c and heater only coming from the defroster. I see you fixed yours. I found that line by the headlight too, and it was cracked just fell apart when I pulled on it. i want to get new line, but now where does it plug back into??? PLZE HELP< IT'S HOT OUTSIDE
Stormy
swluther is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
New addition to the fleet extrashaky Other Vehicles. Other Jeep models & cars and trucks of other makes 15 05-27-2017 12:33 AM
A/C problem pTacRP OEM XJ Cherokee Technical. All XJ Non-modified/stock questions go here 12 07-31-2016 08:21 PM
CPS question ra.stewart OEM XJ Cherokee Technical. All XJ Non-modified/stock questions go here 2 11-06-2015 12:10 AM
new in wyoming riparianbarbarian Introductions 3 10-23-2015 03:57 PM
Fuel consumption change after injector swap 4WD4EVER MODIFIED XJ Cherokee Tech 25 09-29-2015 12:46 PM


Tags
air conditioning, defrost, heater, problem, vents


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 07:55 AM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: