Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here! ZJ (93-98), WJ (99-04), WK (05+)
All ZJ/WJ/WK specific tech questions asked here!

1993 ZJ wont start...... (i have seached and done it all)

Old 04-14-2012, 09:00 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Feb 2011
Location: west Michigan
Posts: 81
Likes: 0
Received 0 Likes on 0 Posts
Year: 2000
Model: Cherokee
Engine: 4.7
Unhappy 1993 ZJ wont start...... (i have seached and done it all)

OK... I have searched and searched and done all the fixes..... and she won't start. Lets do the run down and then the story of what has been done so far.

1993
Grand Cherokee Limited
4.0

So I left for vacation 2.5 weeks ago with a running ZJ, only issue was that the rear CA bracket on the axle was cracked. So I parked it, pulled the battery and let it sit for my awesome vaca to San Diego and Vegas! Got home and still had some vacation cash left so I picked up a used 120v welder. Cut up some steel, made some new brackets and got the rear end all fixed up. (battery was still out) Now I was ready to drive the old pig cause I missed her. Put the battery in and try to start her up. It just crank and wont fire...... turns over for hours on end and nothing.

Here is what I have found so far.
1. No fuel pressure unless I hot wire the pump then I have pressure.
2. No spark at the top of the dist. cap
3. All my gauges work and I have fuel

My first thought was the security. I have over and over reset it with the key in the ignition and the rear hatch, still nothing.nest is the crank position sensor, replaced it with a unit that has .005 ohm on the B & C terminals and still nothing. Ok, distribute, replaced the whole thing, still no spark still no fuel.... F*CK me... now I really started looking and found some weird stuff.

1. If I put a 12v jumper to the fuel pump I have pressure.\
2. If I put a 12v jumper to the ASD relay I get spark at the Dist. cap
-With both it still wont start cause the injectors wont fire
3. The ASD and fuel pump relay are going ape **** with the key in the on position.... chattering like crazy.
4. the security light stays on
5. the check engine light comes on for a second, then goes away, until the two relays go crazy. It then blinks in rhythm with them, and stays on for about 2-3 sec. after the key is pulled then goes off

So I kept thinking security. I then found a write up on disabling the security with a purple/yellow trace wire in the door or kick panel. Did that and still all the same..............

I am at a freaking loss and ready to blow her up............. I need the heep going and don't know where to go next, and sick of throwing $$ at it


any ideas???????
old_red_limited is offline  
Old 04-15-2012, 12:34 AM
  #2  
CF Veteran
 
Bustedback's Avatar
 
Join Date: Feb 2010
Location: Oroville, CA
Posts: 12,368
Likes: 0
Received 0 Likes on 0 Posts
Year: 1995
Model: Grand Cherokee
Engine: 4.0 with all of the noise and clatter
Default

It's a good chance the ECM fried when you welded the bracket.
Bustedback is offline  
Old 04-15-2012, 08:02 AM
  #3  
CF Veteran
 
OverlandZJ's Avatar
 
Join Date: May 2008
Location: Bristol,Pa
Posts: 5,187
Likes: 0
Received 0 Likes on 0 Posts
Year: 94
Model: Cherokee
Engine: 4.0L
Default

When the relay stops chattering.. did you attempt to start?

My wife's 93 would do this.. it's a common indication of needing a new ECU.
OverlandZJ is offline  
Old 04-15-2012, 08:40 AM
  #4  
Junior Member
Thread Starter
 
Join Date: Feb 2011
Location: west Michigan
Posts: 81
Likes: 0
Received 0 Likes on 0 Posts
Year: 2000
Model: Cherokee
Engine: 4.7
Default

i have put 3 different ECU's in (I always called them PCM's)
old_red_limited is offline  
Old 04-15-2012, 08:34 PM
  #5  
Senior Member
 
1slo_camaro's Avatar
 
Join Date: Oct 2011
Location: Cape May, NJ
Posts: 729
Likes: 0
Received 0 Likes on 0 Posts
Year: 1998
Model: Grand Cherokee
Engine: 4.0
Default

Ummmm you left her for so long she got pissed and doesnt wanna work hahaha. Jp honestly man the new jeep i got ran like complete garbage for a good 2-3 days with a million codes going i charged the battery over night on the charger and it ran alot better but didnt run like normal til i replaced the pcm.... Have you called scott and see if he could throw his computer on it for you. He was a life saver with mine on more then one occasion ecspecially when we were heading to the mud pit
1slo_camaro is offline  
Old 04-15-2012, 08:37 PM
  #6  
Senior Member
 
1995XJ_Sport's Avatar
 
Join Date: Oct 2009
Location: Spring Lake, Michigan
Posts: 652
Likes: 0
Received 0 Likes on 0 Posts
Year: 1998
Model: Cherokee
Default

Scott will be busy with me either tomorrow or tuesday.... going to look at a jeep!!
1995XJ_Sport is offline  
Old 04-15-2012, 08:40 PM
  #7  
Senior Member
 
1slo_camaro's Avatar
 
Join Date: Oct 2011
Location: Cape May, NJ
Posts: 729
Likes: 0
Received 0 Likes on 0 Posts
Year: 1998
Model: Grand Cherokee
Engine: 4.0
Default

Oooo is that so? Good luck with it. Btw since both you are in here my buddy grabbed my laptop and driveshaft for me should be sent out tomorrow thanks buddys
1slo_camaro is offline  
Old 04-15-2012, 11:10 PM
  #8  
Junior Member
Thread Starter
 
Join Date: Feb 2011
Location: west Michigan
Posts: 81
Likes: 0
Received 0 Likes on 0 Posts
Year: 2000
Model: Cherokee
Engine: 4.7
Default

Originally Posted by 1995XJ_Sport View Post
Scott will be busy with me either tomorrow or tuesday.... going to look at a jeep!!
Fine then... I didn't want to go anyways!!!

and fine then to you too dave! I didn't want to send you my package!
old_red_limited is offline  
Old 04-16-2012, 05:35 AM
  #9  
Senior Member
 
1slo_camaro's Avatar
 
Join Date: Oct 2011
Location: Cape May, NJ
Posts: 729
Likes: 0
Received 0 Likes on 0 Posts
Year: 1998
Model: Grand Cherokee
Engine: 4.0
Default

Well i wanted as many people as possible to grab my shaft but he wouldnt put my shaft out there for you to grab
1slo_camaro is offline  
Old 04-16-2012, 08:06 AM
  #10  
Junior Member
Thread Starter
 
Join Date: Feb 2011
Location: west Michigan
Posts: 81
Likes: 0
Received 0 Likes on 0 Posts
Year: 2000
Model: Cherokee
Engine: 4.7
Default

Originally Posted by 1slo_camaro View Post
Well i wanted as many people as possible to grab my shaft but he wouldnt put my shaft out there for you to grab
BASTARD!!
old_red_limited is offline  
Old 04-18-2012, 05:27 PM
  #11  
Junior Member
Thread Starter
 
Join Date: Feb 2011
Location: west Michigan
Posts: 81
Likes: 0
Received 0 Likes on 0 Posts
Year: 2000
Model: Cherokee
Engine: 4.7
Default

So I put another PCM in it. Now I have a check engine light with the ignition in the on position. Still no spark and no fuel. At the Crank sensor and the cam sensor I only have 1v.......

WTF

Any ideas?
old_red_limited is offline  
Old 04-18-2012, 05:51 PM
  #12  
Senior Member
 
1995XJ_Sport's Avatar
 
Join Date: Oct 2009
Location: Spring Lake, Michigan
Posts: 652
Likes: 0
Received 0 Likes on 0 Posts
Year: 1998
Model: Cherokee
Default

buy some c4....
1995XJ_Sport is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
BossHoss25
Modified XJ Cherokee Tech
12
07-09-2019 07:19 PM
Jwheeler331
Off-Topic Discussion
12
10-08-2015 08:26 AM
Jwheeler331
Introductions
2
09-27-2015 11:10 AM
cali93zj
Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here!
0
09-18-2015 11:22 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: 1993 ZJ wont start...... (i have seached and done it all)


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: