Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here! ZJ (93-98), WJ (99-04), WK (05+)
All ZJ/WJ/WK specific tech questions asked here!

02 Grand Cherokee Crank but no start

Old 04-15-2019, 12:48 PM
  #1  
Newbie
Thread Starter
 
Join Date: Apr 2019
Location: Texas
Posts: 1
Year: 2002
Model: Grand Cherokee (WJ)
Engine: 4.7
Default 02 Grand Cherokee Crank but no start

Thank you in advance for any help and any input. I have a 2002 grand cherokee 4.7l 4wd limited that i bought. I bought it not running thinking it would be an easy fix. The jeep looks great inside and out which was the main factor. The guy said it had no spark and that it was running before he did a bunch of stuff to it to get it ready for his son. New brakes, new water pump, new gaskets on oil pan, machined the heads, new fuel pump he had reciepts for the whole thing. I get it home and look into it here is what i find. It has spark it has injector pulse, the fuel pump primes and had 45psi at the rail during cranking, i inspected the wiring for frayes or broken wires none found. I did find a ground by the passenger side exhaust that was broken fixed that, put in a new crank sensor and tested the old one but they both tested good. I ordered a new mopar crank sensor. Thinking the autozone sensor could be defective even though it tested good. The ASD i also checked and the relay works and if it was the ASD i wouldnt be having a spark or injector pulse right? And the SkIM is ok to i do not have the key with a line through it light on while its cranking. When it cranks it had a little pop to it so i thought maybe the timing was off. I disasembled the front cover and it looked good ordered a new chain and sproket set, and when i removed the old chain i realized the driver side sprocket was put in improerly. The dowel pin on the camshaft was not lined up with the opening on the sprocket ill include a picture of that. So i got another cam and redid the timing on it and turned the engine by hand to check no interferance felt good. Put it all together and still no start. Compression i have 135 dry in all cylinders and 145-150 wet. I also checked connectiins at the pcm. And it has a new battery charged and less than a month old. Also the TCM relay gets warmer than i have felt any relay get while it is turning over i tried swapping relays and the same thing happens. I am stumped at this point and not sure what else to check. Ill update when i install the new mopar crank sensor. Thanks again for any input and comments.

Heres the original cam with the dowel broken and back side of old sproket were you can see they forced it on there.
Bebophector is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Xavier LC Hall
Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here!
6
04-17-2018 05:28 PM
ChadMagruderhasaJeep
Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here!
5
10-21-2017 07:33 PM
Jeo228
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
19
10-21-2017 07:37 AM
Bigdaddyyj
Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here!
1
04-18-2014 02:01 PM
gasouthernxj
Cherokee Chat
2
12-23-2013 09:17 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: 02 Grand Cherokee Crank but no start


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: