Speedometer not working on 1999 Jeep Cherokee (XJ) Sport 2WD - Page 2 - Jeep Cherokee Forum

Go Back  Jeep Cherokee Forum > Technical Discussion > Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
Speedometer not working on 1999 Jeep Cherokee (XJ) Sport 2WD >

Speedometer not working on 1999 Jeep Cherokee (XJ) Sport 2WD

Notices
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here XJ (84-01)
All OEM related XJ specific tech. Examples, no start, general maintenance or anything that's stock.
Sponsored by:
Sponsored by:

Speedometer not working on 1999 Jeep Cherokee (XJ) Sport 2WD

Old 10-01-2014, 05:17 PM
  #16  
CF Veteran
 
CCKen's Avatar
 
Join Date: Aug 2010
Location: Canton, MI
Posts: 8,357
Year: 1999
Model: Cherokee
Engine: 4.0
Default

Originally Posted by D~C View Post
Got it all squared away - thanks!!
Don't make me come over there!!

How did you get it "Squared away"?
CCKen is offline  
Old 06-11-2016, 05:07 PM
  #17  
Junior Member
 
vincendebbie's Avatar
 
Join Date: May 2016
Posts: 31
Default

What was the outcome?
vincendebbie is offline  
Old 06-14-2016, 12:01 AM
  #18  
D~C
Newbie
Thread Starter
 
Join Date: Aug 2014
Location: Acton, California
Posts: 10
Model: Cherokee
Engine: 6-cyl 4.0L
Default

Hmm. It has been about a year and a half since this all transpired. I'm trying to remember. I was having a really hard time finding a speed sensor. Then I got really busy. So my local, trusted mechanic took a look. He found a used one, but it was missing some piece to connect it. He ended up buying a different part to cannibalize that one piece. Anyway, it all came together in the end. Next time I see him, I'll ask him if he remembers more details. Sorry! But I appreciate the support!
D~C is offline  
Old 01-09-2018, 10:34 PM
  #19  
Newbie
 
alwaysdutch's Avatar
 
Join Date: Sep 2014
Location: Marietta, GA
Posts: 26
Year: 2001
Model: Cherokee
Engine: 4.0 V6
Default

Owning a 2001 XJ 2WD

Picking up this thread again, as I have a similar issue. CEL came on with a P0500 code. I bought a new VSS at Advance Auto, put it in, still CEL. Cleared the code, and it seems to stay off. However, the speedo still doesn't work.

Having read the issues with the pinion where the VSS goes in, I was wondering if some has an image or pic of how that inner part looks like. The VSS clicked right in, but that doesn't mean I didn't break something.

Thanks
alwaysdutch is offline  
Old 07-09-2018, 02:50 PM
  #20  
Junior Member
 
Join Date: Apr 2018
Location: Florida
Posts: 62
Year: 1998
Model: Cherokee(XJ)
Engine: 4.0
Default

VSS units. Bad (L) and good (R)
If you are still having the issue, here are two VSS units. The pinion on the left is missing the teeth.
JTE Brett is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Darkside96
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
17
01-10-2019 11:52 AM
mjcxking
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
11
08-23-2015 08:55 PM
sl0flyer
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
2
08-23-2015 01:31 PM
batman43
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
2
08-20-2015 09:43 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Speedometer not working on 1999 Jeep Cherokee (XJ) Sport 2WD


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: