Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here XJ (84-01)
All OEM related XJ specific tech. Examples, no start, general maintenance or anything that's stock.

Jeep starts, but dies when foot is taken off pedal

Old 10-19-2014, 06:14 PM
  #1  
CF Veteran
Thread Starter
 
92XJGuy's Avatar
 
Join Date: Jun 2011
Location: Colorado
Posts: 2,448
Likes: 0
Received 0 Likes on 0 Posts
Year: 1992
Model: Cherokee
Engine: 4.0
Default Jeep starts, but dies when foot is taken off pedal

I recently installed my snorkel and routed in a 3'' Spectre inline filter. My Jeep has been driving fine since then, maybe a loss of performance since I had to use a small piece of 2'' PVC but fine besides that. Well this morning it wouldn't remain on. I have to pump the pedal to get it to start, then keep pushing the pedal down to keep it going.

I added some gas just in case my gauge was off, no dice. I'll be checking my TB out and see if anything there is bad. Any other ideas?
92XJGuy is offline  
Old 10-19-2014, 06:20 PM
  #2  
CF Veteran
 
SatiricalHen's Avatar
 
Join Date: Oct 2013
Location: Greenville, SC
Posts: 5,483
Likes: 0
Received 7 Likes on 6 Posts
Year: 1999
Model: Cherokee(XJ)
Engine: 4.0
Default

I used to have a bad battery that would randomly drain in the cold... Anyway it had a hard time starting the jeep so I had to give it gas to get it started, then when it started I would have to hold the pedal till it charged the battery enough to keep it alive.... Just an idea
SatiricalHen is online now  
Old 10-19-2014, 06:25 PM
  #3  
CF Veteran
Thread Starter
 
92XJGuy's Avatar
 
Join Date: Jun 2011
Location: Colorado
Posts: 2,448
Likes: 0
Received 0 Likes on 0 Posts
Year: 1992
Model: Cherokee
Engine: 4.0
Default

Well I do have a newer Red Top. My old one was great but it drained when I stored the Jeep and I couldn't get it to hold a charge and got a free replacement, which was a newer one that apparently aren't as good as the old ones. I'll check that out.
92XJGuy is offline  
Old 10-19-2014, 06:58 PM
  #4  
Junior Member
 
pimpinr's Avatar
 
Join Date: Jun 2012
Location: Milwaukee, WI
Posts: 53
Likes: 0
Received 0 Likes on 0 Posts
Year: 2001
Model: Cherokee
Engine: 4.0L
Default

Defective battery, Dirty Terminals...
pimpinr is offline  
Old 10-19-2014, 07:04 PM
  #5  
CF Veteran
 
SatiricalHen's Avatar
 
Join Date: Oct 2013
Location: Greenville, SC
Posts: 5,483
Likes: 0
Received 7 Likes on 6 Posts
Year: 1999
Model: Cherokee(XJ)
Engine: 4.0
Default

Originally Posted by pimpinr View Post
Defective battery, Dirty Terminals...
I can second that one also gone through that too.... But a new battery and clean terminals and I'm good now.
SatiricalHen is online now  
Old 10-19-2014, 07:51 PM
  #6  
Junior Member
 
Join Date: Sep 2013
Posts: 32
Likes: 0
Received 0 Likes on 0 Posts
Year: 1999
Model: Cherokee
Default

Clean battery terminals and cables.... Common problem, easy fix... Typically.
BoomStickTmo is offline  
Old 10-20-2014, 02:22 AM
  #7  
CF Veteran
 
Join Date: Apr 2012
Location: Wisconsin
Posts: 5,302
Likes: 0
Received 0 Likes on 0 Posts
Model: Cherokee
Default

Originally Posted by 92XJGuy View Post
I'll be checking my TB out and see if anything there is bad. Any other ideas?
I'd take a look at the IAC before yanking the TB. Stuck closed will cause the symptoms you describe.
Radi is offline  
Old 10-20-2014, 09:16 AM
  #8  
::CF Moderator::
 
cruiser54's Avatar
 
Join Date: Aug 2011
Location: Prescott, Az
Posts: 37,987
Received 17 Likes on 15 Posts
Year: 1990
Model: Comanche
Engine: 4.0
Default

My guess is that the vacuum line from the intake manifold to MAP sensor is busted......
cruiser54 is offline  
Old 10-20-2014, 11:09 AM
  #9  
CF Veteran
Thread Starter
 
92XJGuy's Avatar
 
Join Date: Jun 2011
Location: Colorado
Posts: 2,448
Likes: 0
Received 0 Likes on 0 Posts
Year: 1992
Model: Cherokee
Engine: 4.0
Default

Well I peeked inside my TB and it's pretty dirty. Although I'm sure it's been like that for some time now. Anyway I pulled the battery, went to Autozone only to be told their tester was broken.. I asked him his thoughts on my situation, he said it wasn't battery related, but rather fuel pump/filter related. Plausible. I went back home, put it back in, hooked my jumper cables up and the Jeep started up, ran, and I was able to even drive it a few feet.


I have brand new Optima Red Top that I got in a warranty back in April of this year. Sucks that I'm out a battery, but I never paid for the original Red Top, it came with the Jeep and I just warrantied them. I get a discount on Interstates at work, so..
92XJGuy is offline  
Old 10-20-2014, 02:34 PM
  #10  
CF Veteran
Thread Starter
 
92XJGuy's Avatar
 
Join Date: Jun 2011
Location: Colorado
Posts: 2,448
Likes: 0
Received 0 Likes on 0 Posts
Year: 1992
Model: Cherokee
Engine: 4.0
Default

A buddy said it could be my IACV or TPS. While I won't rule them out, doesn't this sound just battery related?
92XJGuy is offline  
Old 10-20-2014, 03:38 PM
  #11  
CF Veteran
 
SatiricalHen's Avatar
 
Join Date: Oct 2013
Location: Greenville, SC
Posts: 5,483
Likes: 0
Received 7 Likes on 6 Posts
Year: 1999
Model: Cherokee(XJ)
Engine: 4.0
Default

Yeah I think it's battery related. I had that problem from a bad battery and then again from bad battery terminals, but I would definitely clean the terminals and see if that fixes it. I mean why not it's free right? And also if it's just dirty terminals then you could put the battery on a charger and then clean the terminals and never have to touch it again. Never know
SatiricalHen is online now  
Old 10-20-2014, 05:53 PM
  #12  
CF Veteran
Thread Starter
 
92XJGuy's Avatar
 
Join Date: Jun 2011
Location: Colorado
Posts: 2,448
Likes: 0
Received 0 Likes on 0 Posts
Year: 1992
Model: Cherokee
Engine: 4.0
Default

Originally Posted by SatiricalHen View Post
Yeah I think it's battery related. I had that problem from a bad battery and then again from bad battery terminals, but I would definitely clean the terminals and see if that fixes it. I mean why not it's free right? And also if it's just dirty terminals then you could put the battery on a charger and then clean the terminals and never have to touch it again. Never know
I forgot to mention that the terminals are actually less than 2-3 months old, and the terminals themselves are less than 6 months old, as is the battery. I guess it's true that the new Optimas aren't made as good as they used to be.. I miss my old Red Top. I'm going to throw my ZJ battery in, see how it runs, then buy a new Interstate battery with my work discount.


I think I'll also be running my can of Mopar Combustion Chamber Cleaner through my intake..
92XJGuy is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
XJ ONLY
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
8
01-26-2019 06:30 PM
Cane
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
40
08-26-2015 12:08 AM
Gtrsrlly
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
5
08-25-2015 11:50 AM
hkb
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
4
08-21-2015 05:48 AM
14lgreer
Stock Grand Cherokee Tech. All ZJ/WJ/WK Non-modified/stock questions go here!
3
08-21-2015 01:46 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Jeep starts, but dies when foot is taken off pedal


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: