96 XJ no fire at coil - Jeep Cherokee Forum

Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here XJ (84-01)
All OEM related XJ specific tech. Examples, no start, general maintenance or anything that's stock.

96 XJ no fire at coil

Reply

 
 
 
Old 09-15-2018, 11:11 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Apr 2017
Location: Memphis, Tn
Posts: 31
Year: 1996 XJ
Model: Cherokee
Engine: 4.0
Default 96 XJ no fire at coil

96 XJ 4.0 Classic,
Just as I thought this dawg was about dependable, I try to start it an it turns over but won't start.
I checked for fuel at the rail, nothing. I cleaned all battery cables again, no change.

My Jeep buddy comes over and checks all relays, fuses, etc.
Then we check fuel again and now have fuel! Check for spark but have none, then we find we have no fire at the coil.

Haven't scanned it yet, waiting on my buddy to get to get caught up, hope that will help when we do.
I'm still going to add new grounds. I've read about so many having trouble with them on here.

One other thing I learned is it came as a throttle body. The engine has been changed and is a later model fuel injected one. I have run it quiet a bit and it runs good,when it runs, but it's just one thing after another...

Last edited by Thawolff; 09-16-2018 at 12:14 AM.
Thawolff is offline  
Reply With Quote
Old 09-16-2018, 01:25 AM
  #2  
Seasoned Member
 
peligro113's Avatar
 
Join Date: Feb 2015
Location: South Georgia
Posts: 410
Year: 1996
Model: Cherokee(XJ)
Engine: 4.0l
Default

crank no start is probably your CPS, the fuel issue no idea if their even is an issue.....
peligro113 is offline  
Reply With Quote
Old 09-17-2018, 07:32 AM
  #3  
Junior Member
Thread Starter
 
Join Date: Apr 2017
Location: Memphis, Tn
Posts: 31
Year: 1996 XJ
Model: Cherokee
Engine: 4.0
Default 96 XJ no fire at coil

Originally Posted by peligro113 View Post
crank no start is probably your CPS, the fuel issue no idea if their even is an issue.....
I've been thinking about that. Once before it wouldn't start had one put on & ran great for a while, but it was used.
I think he had to change the plug so it's a good chance...

I went out tonight an tried to jump it off, grounded it to the block an then to the frame, but no luck. I checked for fuel at the rail but now there isn't any..
I'm gonna get him to scan it an hope that will shed some light on it
Had it scanned at Autozone a while back an showed a bad oxygen sensor, still have put it on..

The speedometer, tach and fuel gauge still don't work, hope the new ground wire I'm gonna add under there will help.
I had a new fuel assembly installed but didn't help the gauge, it pegs out an the low fuel light comes on when running...
I'm afraid I'm dealing with Gremlins !!

My Dad was in the car business for 26yrs & would not touch a car if there was any sign of electrical problems now I know why...
Thanks Peligro I'll post an update as soon as I have one.
Thawolff is offline  
Reply With Quote
Old 09-29-2018, 01:30 AM
  #4  
Junior Member
Thread Starter
 
Join Date: Apr 2017
Location: Memphis, Tn
Posts: 31
Year: 1996 XJ
Model: Cherokee
Engine: 4.0
Exclamation 96 XJ no fire at coil

Originally Posted by peligro113 View Post
crank no start is probably your CPS, the fuel issue no idea if their even is an issue.....
Could a bad CPS cause a scanner to show a 'No Link error' ? It happened with two different scanners.
How do you test a CPS?

I'm having a heck of a time finding one by Mopar!

Late '96 Cherokee Classic, 4.0, W/auto trans.

Last edited by Thawolff; 09-29-2018 at 01:34 AM.
Thawolff is offline  
Reply With Quote
Old 10-06-2018, 08:47 AM
  #5  
Junior Member
Thread Starter
 
Join Date: Apr 2017
Location: Memphis, Tn
Posts: 31
Year: 1996 XJ
Model: Cherokee
Engine: 4.0
Default

Well finally got a Mopar CPS in and installed but no change. No spark no fuel no nuttin..spins over but no start..
Scanner is still showing 'no link'.
After a lot of testing my buddy thinks it's the ECU. He's trying to find one from a junkyard but not having any luck so far.
Out of the 15 he checked they were all gone.
Still checking and cleaning grounds an connections...
Thawolff is offline  
Reply With Quote
Old 10-06-2018, 11:27 AM
  #6  
Senior Member
 
JandDGreens's Avatar
 
Join Date: Jan 2013
Location: Colorado
Posts: 918
Year: 1991 2-Door
Model: Cherokee
Engine: 4.0 liter
Default

My buddy went through this several times on his 96'. There are so many areas tat contribute to the no spark. The last time he thought it was the ECU. Even bought a new one to no avail. It turned out to being one of 2 parts he replaced at the time, the throttle body sensor Napa part #ec3313 and he replaced a part that is under the battery, Napa part #bts103. I am not sure but I think it was the part under the battery that caused the issue that time.
JandDGreens is offline  
Reply With Quote
Old 10-06-2018, 01:55 PM
  #7  
Seasoned Member
 
peligro113's Avatar
 
Join Date: Feb 2015
Location: South Georgia
Posts: 410
Year: 1996
Model: Cherokee(XJ)
Engine: 4.0l
Default

Have you checked your ASD relay yet?
peligro113 is offline  
Reply With Quote
Old 10-16-2018, 03:08 PM
  #8  
Junior Member
Thread Starter
 
Join Date: Apr 2017
Location: Memphis, Tn
Posts: 31
Year: 1996 XJ
Model: Cherokee
Engine: 4.0
Exclamation 96 XJ no fire at coil

Originally Posted by JandDGreens View Post
My buddy went through this several times on his 96'. There are so many areas tat contribute to the no spark. The last time he thought it was the ECU. Even bought a new one to no avail. It turned out to being one of 2 parts he replaced at the time, the throttle body sensor Napa part #ec3313 and he replaced a part that is under the battery, Napa part #bts103. I am not sure but I think it was the part under the battery that caused the issue that time.
I ran into an old friend that's a mechanic an he gave me an ECU/ECM..he didn't remember what year Jeep it came off of but it must be close.We hooked it up tonight an it fired right...but died...Started every time but would die. I didn't think to check the fuel until I quit an came inside and to beat to go back out..
But every thing else worked, the tach, fuel gauge, amp, temp I think..
My 96 came with a throttle body but the engine in it is fuel injected. I remember seeing the switch under the battery.I'll check it today.
Thanks again and if you or anyone has any more ideas Please let me know.
Thawolff is offline  
Reply With Quote
Old 10-16-2018, 03:22 PM
  #9  
Junior Member
Thread Starter
 
Join Date: Apr 2017
Location: Memphis, Tn
Posts: 31
Year: 1996 XJ
Model: Cherokee
Engine: 4.0
Exclamation No fire at coil

Originally Posted by peligro113 View Post
Have you checked your ASD relay yet?
Yes he swapped them around and checked them an thinks they are OK.. I ordered two from RA but were the wrong ones, having trouble finding them for some reason.
We're gonna try to go to a Jeep junkyard today an I'm gonna try to find some to try before I buy any...

Thanks again peligro113 if you think of any thing else please let me know.
Thawolff is offline  
Reply With Quote
Old 10-16-2018, 11:25 PM
  #10  
Senior Member
 
Join Date: Mar 2014
Location: Eastern Long Island, NY
Posts: 631
Year: 1996
Model: Cherokee
Engine: I6 Cyl / 4L
Default

Have you checked your grounds? Battery and cables, connections?
OldTires is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
JQJ
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
7
09-20-2018 06:08 PM
jetfighterv
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
4
08-26-2018 04:20 PM
Posdeer
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
4
08-19-2018 09:50 PM
Chad Ross
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
1
07-16-2018 11:05 AM
Chad Ross
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
0
07-15-2018 11:38 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: 96 XJ no fire at coil


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: