2001 Jeep Stalling at Idle - Jeep Cherokee Forum
Jeep Cherokee Forum


OEM Cherokee Technical. All factory issues and info go here!
XJ (84-01)
All OEM related XJ Tech. Examples, no start, general maintenance or anything that's stock.
Sponsored by:
Sponsored by:

2001 Jeep Stalling at Idle

Reply
 
 
 
Thread Tools Search this Thread
Old 11-23-2011, 09:33 PM   #1
Newbie
Thread Starter
 
Join Date: Aug 2010
Posts: 4

View edhunter's Photo Album My Photos
Default 2001 Jeep Stalling at Idle

I have a 2001 Cherokee and it stalls at low idle or street lights. It also has a rough time starting. There is no engine light on so i cannot figure out what it is. I cleaned the throttle body but no luck. Jeep has 108,000 miles on it. Any thoughts on this? Thansk
edhunter is offline   Reply With Quote
Old 11-23-2011, 09:39 PM   #2
Junior Member
 
ultimate-xj's Avatar
 
Join Date: Apr 2011
Location: Nebraska
Posts: 88

View ultimate-xj's Photo Album My Photos
Default

Might check battery and alt. I know when my battery was low it did funny thinks and if the battery is dead and has to be jump started it won't stay running on it's own.
ultimate-xj is offline   Reply With Quote
Old 11-23-2011, 11:26 PM   #3
Senior Member
 
JamDeeper's Avatar
 
Join Date: Jul 2011
Location: ogden, utah
Posts: 515

View JamDeeper's Photo Album My Photos
Default

Check your cam shaft position sensor bud. i just did one the other day (mine threw a code tho) but check to see if the magnet is broken or cracked under the cap. mine was doing the exact same thing.
JamDeeper is offline   Reply With Quote
Old 11-24-2011, 12:25 PM   #4
Member
 
Countryboy 73's Avatar
 
Join Date: Nov 2011
Location: Ragley, La. Southwest La.
Posts: 205

View Countryboy 73's Photo Album My Photos
Default

I have a 96 xj 4.0 it was having the same prob. I changed the pickup coil and now it idles but it cuts out when I try to rev it up, if I can get it above 2000 rpms it'll run but cuts out. I changed the crank position sensor 2 weeks ago cause it wouldn't idle. And cut out up to 2500 rpms, above that it would run. I pulled the vac line off the fuel tank and 2 drops of gas came out of the vac line.I'm thinking it's the regulator but not for sure. There is also air getting in the fuel rail. I'm open for suggestions if anybody has one.
Countryboy 73 is offline   Reply With Quote
Old 11-24-2011, 01:09 PM   #5
Newbie
Thread Starter
 
Join Date: Aug 2010
Posts: 4

View edhunter's Photo Album My Photos
Default

I cleaned the throttle body today and also cleaned the Ismael air control and valve. It runs smoother but still having a problem starting. I need to put my foot on the pedal when starting then no problems. I will try to see if it can spit a code out. The codes come and go. Just hope its not the computer.
edhunter is offline   Reply With Quote
Old 11-24-2011, 01:16 PM   #6
CF Veteran
 
VTJeep's Avatar
 
Join Date: Jul 2010
Location: 802
Posts: 4,925

View VTJeep's Photo Album My Photos
Default

Ideas:
-TPS (IAC valve usually effects high rpm)
-plugs/wires
-cap/rotor
-o2 sensors
-get gas really low and drop tank to inspect for debris in tank and pump/filter assembly.
VTJeep is offline   Reply With Quote
Old 11-24-2011, 01:20 PM   #7
CF Veteran
 
VTJeep's Avatar
 
Join Date: Jul 2010
Location: 802
Posts: 4,925

View VTJeep's Photo Album My Photos
Default

Quote:
Originally Posted by edhunter
I cleaned the throttle body today and also cleaned the Ismael air control and valve. It runs smoother but still having a problem starting. I need to put my foot on the pedal when starting then no problems. I will try to see if it can spit a code out. The codes come and go. Just hope its not the computer.
Could be PCM. I think mine is still faulty. I had a hesitation issue that turned out to be crud in has tank that was clogging fuel filter. But I had gone from front to back so it was literally the last thing I checked... But still my cel stayed on and it seems like my gas milage is a little less than it should be... Friggin PCM is like 300+
VTJeep is offline   Reply With Quote
Old 11-24-2011, 02:08 PM   #8
Senior Member
 
JamDeeper's Avatar
 
Join Date: Jul 2011
Location: ogden, utah
Posts: 515

View JamDeeper's Photo Album My Photos
Default

Quote:
Originally Posted by VTJeep
Ideas:
-TPS (IAC valve usually effects high rpm)
-plugs/wires
-cap/rotor
-o2 sensors
-get gas really low and drop tank to inspect for debris in tank and pump/filter assembly.
I believe 2k1 is distributorless.
JamDeeper is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
New XJ From Portland, OR jwolfuo Introductions 10 10-02-2015 05:14 AM
Idle issues OGCollard OEM Cherokee Technical. All factory issues and info go here! 21 08-27-2015 08:11 AM
Steam coming off hood lhpdiver OEM Cherokee Technical. All factory issues and info go here! 17 08-23-2015 01:53 PM
Electrical problems 95 xj petejeep95 OEM Cherokee Technical. All factory issues and info go here! 4 08-22-2015 11:39 AM
Read gearbox leak lhpdiver OEM Cherokee Technical. All factory issues and info go here! 0 08-22-2015 10:33 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 05:34 AM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send