01 cherokee sport starting problem - Jeep Cherokee Forum

Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here XJ (84-01)
All OEM related XJ specific tech. Examples, no start, general maintenance or anything that's stock.

01 cherokee sport starting problem

Reply

 
 
 
Old 08-01-2009, 07:17 AM
  #1  
Newbie
Thread Starter
 
Join Date: Aug 2009
Posts: 9
Model: Cherokee
Red face 01 cherokee sport starting problem

2001 Sport 4.0. 100K I've been chasing a starting problem and need help before I end up at the dealer.
On cold start I have to turn the engine over at least twice before it starts (3-4 revolutions, stop, start again and it will run). It then misses for 10/20 seconds. After revving the engine the miss will clear and it seems to run fine and will start okay until it has cooled down completely. I still have to use a two-step starting procedure though. Turn it over for 3 or 4 revolutions, stop, then turn it over again before it goes.
I've gotten a check engine code of " PO301-misfire on # 1 cylinder" about 5/6 times and one code of " PO340-crankshaft position sensor malfunction".
I changed the Crankshaft sensor with no change in starting.
I replaced the Coil Rail with no change in starting.
I replaced the plugs twice.
Can anyone direct me to a fix before the dealer gets me.
Thanks

Last edited by red rider; 08-01-2009 at 11:38 AM.
red rider is offline  
Reply With Quote
Old 08-01-2009, 08:40 AM
  #2  
Senior Member
 
jd4x426's Avatar
 
Join Date: Jan 2009
Posts: 920
Year: 1996
Model: Cherokee
Engine: 4.0
Default

make sure that the plug for the cps is plugged in good and the terminals are clean when it doesnt start have you checked to see if it has fuel and spark its missing one or the other and that will help diagnose your problem better
jd4x426 is offline  
Reply With Quote
Old 08-01-2009, 11:31 AM
  #3  
Newbie
Thread Starter
 
Join Date: Aug 2009
Posts: 9
Model: Cherokee
Default

I replaced the CPS and cleaned the connection, applied dielc. grease. I'll check the fuel pressure. Filter is in the tank, so if pressure in off I guess the next step is pull the tank and change the pump/filter.
Anyone else cared to chime-in, would appreciate it.
red rider is offline  
Reply With Quote
Old 08-01-2009, 11:54 AM
  #4  
Newbie
Thread Starter
 
Join Date: Aug 2009
Posts: 9
Model: Cherokee
Default

Okay, checked fuel pressure while running at injector rail. 45 psi. Sound right?
red rider is offline  
Reply With Quote
Old 08-01-2009, 12:11 PM
  #5  
CF Veteran
 
JeepCoMJ's Avatar
 
Join Date: Nov 2008
Posts: 2,003
Year: 1987
Model: Cherokee
Engine: 4.0
Default

thats good.

remember...just because parts are new doesnt mean they're good
JeepCoMJ is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Darkside96
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
16
12-21-2016 01:32 AM
John T
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
18
08-31-2015 12:41 PM
zhunt728
Stock XJ Cherokee Tech. All XJ Non-modified/stock questions go here
0
08-20-2015 12:37 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: 01 cherokee sport starting problem


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description: