Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > Grand Cherokee Tech
Register Forgot Password?
Search

Welcome to Cherokee Forum!
Welcome to Cherokee Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 03-12-2010, 04:33 PM   #1
Newbie
 
Join Date: Aug 2009
Posts: 6

View waywardson's Photo Album My Photos
Cherokee
Default My Cherokee wont stay running

Hey all,

I have a 93 Grand Cherokee with the 4.0L that will not stay running. The Jeep sat for over a year.

The motor will crank and start, but it dies immediately after 1 or 2 seconds. Giving it gas doesn't help, either.

I drained the tank and put in 1/2 a tank of fresh gas and tested the fuel pump while it was out. There is 40 psi at the rail.

The battery, cap/rotor, cam and crank sensors, TPS, idle control valve, plugs, wires, air and fuel filters were replaced with new parts. The fuel pump relay and fuses have been verified to be good. Also, there are no exhaust restrictions.

I even changed the PCM, but the problem is still there.

I have narrowed it down to a fault of the injector circuit. Using noid lights in the injector harness, when the engine is turning over, the injectors fire. As soon as the motor catches, the injectors STOP firing. Is there a sensor that controls the injectors once the engine has started? Or could this be something related to the ASD relay? Is it possible the PCM is bad? I've heard the PCM controls the grounding of the injectors once the motor is running, but I have not been able to verify this, as I don't have a Factory Service Manual. All help is appreciated, as I don't know what else to suspect. Thanks for all replies!
waywardson is offline   Reply With Quote
Old 03-12-2010, 04:40 PM   #2
CF Veteran
 
OverlandZJ's Avatar
 
Join Date: May 2008
Location: Bristol,Pa
Posts: 4,889

View OverlandZJ's Photo Album My Photos
94 Cherokee
Default

Welcome to CF.

Where did you source your PCM? New, reconditioned or used?

Did the PCM you replaced have the same last 4 digits? Or was it verified through a dealer as a new part number that supercedes your original?

Do you have a factory security system?
OverlandZJ is offline   Reply With Quote
Old 03-12-2010, 11:17 PM   #3
Newbie
 
Join Date: Aug 2009
Posts: 6

View waywardson's Photo Album My Photos
Cherokee
Default

About the PCM,
Unfortunately, I bought the PCM from Ebay. I say unfortunately because the computer I got didn't have the factory sticker with the number on it. It had a different label in a different location (maybe rebuilt?).

I only bought it because the ad stated it would be compatible with Jeep PCM's #56005694, #56027803, #56027762, and #56029009. Other websites I researched stated PCMs with these numbers were compatible.

The original one that came out of the Jeep had the number 56029009; I suspected it was bad because not only would the car not even try to start, but the tach would go haywire with the key on, the Check Engine light worked intermittently and it would not put out trouble codes. The one I bought was supposedly compatible, as long as the drivetrain was a 1993 4.0L/AW4 with no factory security system.

The Check Engine light now works properly, there are no codes, and like I stated in my previous post, the engine actually starts and runs, but loses the injector signal upon ignition and kills the party.

Do you think the computer is at fault? Is there a possibilty of anything else being at fault?
waywardson is offline   Reply With Quote
Old 03-13-2010, 01:36 AM   #4
CF Veteran
 
OverlandZJ's Avatar
 
Join Date: May 2008
Location: Bristol,Pa
Posts: 4,889

View OverlandZJ's Photo Album My Photos
94 Cherokee
Default

I bought one for a 93 ZJ as well, mine was for a 5.2/Auto with security. I also bought it from ebay through ICQ? dismantlers... pretty good presence and rep on ebay. Maybe worth a call to whoever you bought it from and see about an exchange with one that still has the sticker and is compatible?

From the research i did i knew i needed an exact match or a number that superceded. I got the superceded numbers from a bud who is a parts manager at a dealership.

From what i learned iirc the security system will do excactly what your describing.. run and shut down. Either you have a PCU without security or your security system is going off. Are you experiencing blinking headlights when you turn the key?

I apologise if your familiar with the security system and you already knew this.. but i figure it's worth mentioning. To shut off the security system without a remote simply lock and unlock the passenger door or hatch twice.
OverlandZJ is offline   Reply With Quote
Old 03-15-2010, 12:22 AM   #5
Newbie
 
Join Date: Aug 2009
Posts: 6

View waywardson's Photo Album My Photos
Cherokee
Default

Thanks for the reply.

My Jeep didn't come with a factory security system, and the computer was supposedly for a car without a factory security system.

I didn't know about disarming the system with the passenger door lock. I will try it.

If the PCM I installed is for a car WITH a security system, is there some way to bypass it?




waywardson is offline   Reply With Quote
Old 03-16-2010, 12:44 PM   #6
Seasoned Member
 
ToyComa's Avatar
 
Join Date: Sep 2009
Posts: 314

View ToyComa's Photo Album My Photos
Cherokee
Default

Quote:
Originally Posted by OverlandXJ View Post

I apologise if your familiar with the security system and you already knew this.. but i figure it's worth mentioning. To shut off the security system without a remote simply lock and unlock the passenger door or hatch twice.
lol, thank you for posting this. I just pulled my battery to change my head light bulb and then the truck wouldnt start when I put the battery back in and the lights were blinking and security was blinking on the dash and I was like WTF!?!?!? ran in and did a search and bam. problem fixed.
ToyComa is offline   Reply With Quote
Old 06-29-2010, 11:59 PM   #7
Newbie
 
Join Date: Aug 2009
Posts: 6

View waywardson's Photo Album My Photos
Cherokee
Default Problem solved!

Hey everyone,The problem is finally fixed. It turned out to be the PCM. The security feature was activated (somehow), and would kill the injector ground circuit. That's why the motor could start off the primer of gas it got from turning the key on, but when that little bit of fuel ran out, no more would be supplied.Now all is well. Thanks to all who replied. This forum is awesome!
waywardson is offline   Reply With Quote
Old 06-29-2010, 11:59 PM
 
 
 
submit to reddit
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
1999 Grand Cherokee Wont Start - Fuel Pump Won't Run/Stay Running RHStorm11 Grand Cherokee Tech 27 09-18-2014 07:37 PM
98 Gr Cherokee wont stay running SkinnyVinny Grand Cherokee Tech 4 02-27-2010 04:31 PM
93 xj not wont stay running.. 00xj-classic Cherokee Chat 0 01-11-2010 02:17 PM
xj wont stay running xjroller OEM Cherokee Tech 5 11-05-2009 11:08 AM
wont stay running jeeper92 OEM Cherokee Tech 7 09-09-2009 04:09 PM

Go Back   Jeep Cherokee Forum > Technical Discussion > Grand Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 01:57 PM.


This site is in no way affiliated with Jeep or Chrysler.

Emails Backup