HELP,99 Jeep grand cherokee laredo, has rough idle, and dies - Jeep Cherokee Forum
Jeep Cherokee Forum


HELP,99 Jeep grand cherokee laredo, has rough idle, and dies

Reply
 
 
 
Thread Tools Search this Thread
Old 04-22-2012, 12:26 PM   #1
Newbie
Thread Starter
 
Join Date: Apr 2012
Location: lancaster,oh
Posts: 4

View jman2199jeep's Photo Album My Photos
Question HELP,99 Jeep grand cherokee laredo, has rough idle, and dies

I have a 99 jeep grand Cherokee laredo 4.0 6 cylinder, I start the engine, the idle jumps up and down, reving up, then down over and over, then I put it into drive and it dies. When I do get it started and start driving, in about 15 seconds, the idle begins the go up and down. Almost seems like its not recognizing what gear its in.
I have already changed the crank shaft sensor, cam shaft sensor, ignition coil pack, and new platinum spark plugs. I'm still getting the check engine reading of p0353 and 1391, one is for the crank/cam shaft position sensor and the other is ignition coil malfunction , I have replaced all of these and they have not solved the problem. Can anyone please help me. This is my only vehicle and need to get it running. Please help!
jman2199jeep is offline   Reply With Quote
Old 04-22-2012, 03:45 PM   #2
Newbie
 
Join Date: Mar 2012
Location: Virginia Beach
Posts: 2

View MrCox757's Photo Album My Photos
Default

I was having similar issues with my 95. I found some damaged wires going to the ignition coil. It was causing the signal to fade in and out. I repaired the wires and now she runs like a dream.
MrCox757 is offline   Reply With Quote
Old 04-22-2012, 06:32 PM   #3
Newbie
Thread Starter
 
Join Date: Apr 2012
Location: lancaster,oh
Posts: 4

View jman2199jeep's Photo Album My Photos
Question

Where does the wire from the ignition coil pack go from there? To the powertrain control module? Or where to get a replacement wire? I haven't had luck with anything else. Thanks for the help.
jman2199jeep is offline   Reply With Quote
Old 04-23-2012, 04:32 AM   #4
Newbie
 
Join Date: Mar 2012
Location: Virginia Beach
Posts: 2

View MrCox757's Photo Album My Photos
Default

I started right at the coil and followed them back. The do go to the pcm. I actually just cut the damaged pieces out and soldered them back together. The damaged section was vary close the the coil its self.
MrCox757 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Rough Idle in gear while stopped - P0432 w/ FF data Blackcherokee290 OEM Cherokee Technical. All factory issues and info go here! 22 05-15-2016 01:48 PM
Water pump question. Tompop Grand Cherokee Tech 16 08-25-2015 04:35 PM
Newbie from Texas txwj66 Introductions 5 08-25-2015 04:21 PM
97 Laredo Neutral Starter Switch 14lgreer Grand Cherokee Tech 3 08-21-2015 02:46 AM
ABS??????? Buddylove1991 Grand Cherokee Tech 2 08-20-2015 09:28 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 02:45 AM.