Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > Grand Cherokee Tech
Register Forgot Password?
Search

Welcome to Cherokee Forum!
Welcome to Cherokee Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 02-21-2010, 04:06 PM   #1
Newbie
 
Join Date: Feb 2010
Posts: 13

View tmeff429's Photo Album My Photos
Cherokee
Default 93 grand cherokee wont start

Heres what I got. Driving and the motor just dies. Try to start it the motor turns over, but wont start. The fuel pump isn't priming. I bought a new fuel pump relay and a new pump the new pump isn't priming either. I pulled the fuse to make sure it wasn't blown, and it's not. I lifted the float on the sending unit gas hand moves. What should I check next? Sometimes it will act like it's gonna start, but wont. It's got a V8 AND 4X4 if that helps. Any help would be great. Thanks

Last edited by tmeff429; 02-21-2010 at 04:59 PM.
tmeff429 is offline   Reply With Quote
Old 02-21-2010, 04:45 PM   #2
CF Veteran
 
ol"blue's Avatar
 
Join Date: Mar 2009
Location: Tenn. and Mich.
Posts: 28,056

View ol"blue's Photo Album My Photos
2004 Grand Cherokee
Default

You need 3 things to run: fuel, spark, and air. We know you're getting air. You can check for spark, and then chase down fuel issues.
But I'd remove the air horn to TB elbow and pour a little gas, or starting fluid into the TB and see if it fires. If it fires up you know it's fuel related, so look for the problem in a fuel pump fuse, relay, ground, clogged filter, or a problem with the pump/pick-up. JMO
And Welcome to CF!
Dan
__________________
Dan
'04 Grand Cherokee SE: 4.7L V8 w/235 HP, 4X4
'04 Saturn Vue: 3.5L V6 w/250 HP, AWD

"...Never Use Post Count as A Knowledge Gauge." Willys55

CBW Member#97

If no answer, ask here>
www.CHEROKEETECH.com


RIP Carroll Shelby
http://www.carrollshelbyfoundation.org/
http://carrollshelbyfoundation.com/



If you're not breaking parts you're not making enough power!!!
"I NEED MORE TRACTION, NOT MORE BOOST"

ol"blue is offline   Reply With Quote
Old 02-21-2010, 04:57 PM   #3
Newbie
 
Join Date: Feb 2010
Posts: 13

View tmeff429's Photo Album My Photos
Cherokee
Default

I'll give it a shot. I'm assumin that the TB is the throttle body right.
tmeff429 is offline   Reply With Quote
Old 02-21-2010, 04:58 PM   #4
CF Veteran
 
ol"blue's Avatar
 
Join Date: Mar 2009
Location: Tenn. and Mich.
Posts: 28,056

View ol"blue's Photo Album My Photos
2004 Grand Cherokee
Default

Quote:
Originally Posted by tmeff429 View Post
I'll give it a shot. I'm assumin that the TB is the throttle body right.
That's correct.
Dan
__________________
Dan
'04 Grand Cherokee SE: 4.7L V8 w/235 HP, 4X4
'04 Saturn Vue: 3.5L V6 w/250 HP, AWD

"...Never Use Post Count as A Knowledge Gauge." Willys55

CBW Member#97

If no answer, ask here>
www.CHEROKEETECH.com


RIP Carroll Shelby
http://www.carrollshelbyfoundation.org/
http://carrollshelbyfoundation.com/



If you're not breaking parts you're not making enough power!!!
"I NEED MORE TRACTION, NOT MORE BOOST"

ol"blue is offline   Reply With Quote
Old 03-30-2010, 04:12 PM   #5
Newbie
 
Join Date: Feb 2010
Posts: 13

View tmeff429's Photo Album My Photos
Cherokee
Default

OK I replaced the fuel filter, the fuel pump relay, and checked the fuse. All checked good. I pulled the fuel line from the outlet of the fuel filter gas squirted every where. So I have gas that far. I pulled the plug, got spark. I squirted starter fluid in the TB still not starting.

What should I try now?
tmeff429 is offline   Reply With Quote
Old 03-31-2010, 02:15 PM   #6
Newbie
 
Join Date: Feb 2010
Posts: 13

View tmeff429's Photo Album My Photos
Cherokee
Default

Anybody got any ideas? What would keep it from starting?
tmeff429 is offline   Reply With Quote
Old 04-01-2010, 03:42 PM   #7
Senior Member
 
rivercrazy's Avatar
 
Join Date: Oct 2009
Location: Redlands, CA
Posts: 502

View rivercrazy's Photo Album My Photos
1992 Cherokee
Default

Do you hear the pump come on when you turn the key without turning the motor?

Have you tested your fuel pressure at the rail? You can rent a tester from Autozone.

Are you sure you have spark? How did you test that?
__________________
4x4 is for people who think to themselves "I'd like to drive over that!"
rivercrazy is offline   Reply With Quote
Old 04-01-2010, 08:05 PM   #8
Member
 
Join Date: Mar 2010
Posts: 219

View trucker's Photo Album My Photos
Cherokee
Default

Actually there is 4 "things" you need to start: fuel, air, spark and compression.
The timing my be off. If you have compression gauge then check all cylinders. It should not have less that 100 lbs and no more that 20lbs difference. If the spark plugs are black then you have too much fuel going in. Check the oil cap for signs of oil - blown head gasket. Milky oil. There is more that just fuel,air and spark to have engine running and you have those three basics.
Time to "dig in". Mark the 1st cylinder plug and have firing order ready. Pull plugs and spin engine. With some carton at cylinder hole look for signs of water or oil. Then check compression. Did you overheat the engine?. The electrical gauges are not correct and when the temp shows high or engine lights come on most of the time it is too late. I have manual gauges added.
trucker is offline   Reply With Quote
Old 04-01-2010, 09:20 PM   #9
Caracticus Potts The Mod
 
Willys55's Avatar
 
Join Date: Jul 2009
Location: Greenville, NY
Posts: 4,058

View Willys55's Photo Album My Photos
96,95,94,93 Grand Cherokee
Cool

There is one thing you can try. Don't laugh because this was an issue for 93-95 GC. The rear tailgate latch completes the circuit for the vehicle security system and when it fails it sometimes causes the seurity system to arm, when it arms with the driver door unlocked you end up having no injector pulse and a weak spark at the coil because the ignition circuit has a voltage drop while cranking. (about 6 volts) Check to see if you have a good blue spark from the distributor cap to the plugs and using a test light you can see if you have injector pulse while cranking. If not try locking and unlocking the car from the drivers side using the key not the transponder
__________________
Brian Perrine will be in my memory Forever.....Good Bye My Friend

NEVER said I was perfect.....just helpful.... Never Use Post Count as A Knowledge Gauge

My name is Russ, my friends call me "Doc"
Willys55 is offline   Reply With Quote
Old 04-03-2010, 06:39 AM   #10
Junior Member
 
Join Date: Mar 2010
Location: toms river, new jersey
Posts: 94

View jeepfan93's Photo Album My Photos
Cherokee
Default

Interesting, how to check that rear latch circuit is good?
jeepfan93 is offline   Reply With Quote
Old 04-03-2010, 07:27 AM   #11
Member
 
Join Date: Mar 2010
Posts: 219

View trucker's Photo Album My Photos
Cherokee
Default

If the dome lights go out then the latch is closed. My will start with the back door open. You have fuel, spark and air. Check if the firing order is correct. Distributor my be loose and out of time. Does the engine spin very fast?
trucker is offline   Reply With Quote
Old 04-05-2010, 02:53 PM   #12
Newbie
 
Join Date: Feb 2010
Posts: 13

View tmeff429's Photo Album My Photos
Cherokee
Default

yeah the engine spins good. the spark does look weak though.if the security relay is bad would it cause similar problems.
tmeff429 is offline   Reply With Quote
Old 04-07-2010, 09:24 PM   #13
Newbie
 
Join Date: Feb 2010
Posts: 13

View tmeff429's Photo Album My Photos
Cherokee
Default

Can you by-pass the tailgate circiut for the security system? If so how? Also the fuel pump is priming, but it is not as loud as it used to be. You can barely hear it priming.
tmeff429 is offline   Reply With Quote
Old 04-08-2010, 07:47 AM   #14
Member
 
Join Date: Mar 2010
Posts: 219

View trucker's Photo Album My Photos
Cherokee
Default

The reason I asked about engine spinning fast is that you my not have compression. I would check the compression.
trucker is offline   Reply With Quote
Old 04-08-2010, 12:08 PM   #15
Newbie
 
Join Date: Feb 2010
Posts: 13

View tmeff429's Photo Album My Photos
Cherokee
Default

Engine is turning over fast. It just wont start up. The battery is starting to drain. I'm gonna charge it back up, but other than that. IDK?
tmeff429 is offline   Reply With Quote
Old 04-08-2010, 12:08 PM
 
 
 
submit to reddit
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
96 Grand Cherokee wont start or run when jumped ozz7284 Grand Cherokee Tech 2 12-30-2009 01:16 PM
1996 Grand Cherokee wont start after running out of gas Terike Grand Cherokee Tech 4 12-07-2009 01:21 AM
1998 Grand Cherokee 2.5 Turbo Diesel Ltd. wont start GRANDECHEROKEE Grand Cherokee Tech 4 11-25-2009 06:49 PM
94 Cherokee Grand 5.2 wont start Backlash OEM Cherokee Tech 2 07-06-2009 05:42 PM
99' grand cherokee wont start psycho_bill Grand Cherokee Tech 0 11-02-2008 10:38 PM

Go Back   Jeep Cherokee Forum > Technical Discussion > Grand Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:45 PM.


This site is in no way affiliated with Jeep or Chrysler.

Emails Backup