Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech
Register Forgot Password?
Register Photos FAQ Members List Social Groups Search Today's Posts Mark Forums Read GarageVendor DirectoryvBLive
Search

Welcome to Cherokee Forum!
Welcome to Cherokee Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 01-07-2014, 09:35 AM   #1
Member
 
MarkJRust's Avatar
 
Join Date: May 2011
Location: Michigan
Posts: 135

View MarkJRust's Photo Album My Photos
2001 Cherokee
Send a message via AIM to MarkJRust
Default Windshield Wipers stopped working, again..

A week or two ago I went to start up my Jeep and turn on the wipers to remove some snow, they didn't work. The sprayer did though. Checked the fuses anyway and they were fine. First thought there was a short or the motor was dead and I started researching for parts. Come back an hour or so later, and they work again.

They work flawlessly up until this morning. Start up the Jeep and let it run, come back to turn on the windshield wipers to clear the defrosted snow and ice and they're dead again.

I'm going to let it sit, wiggle the wipers a bit and see if they go. But I'd like to know if anyone else has experienced this or what it may be. It's concerning me that I may need them and randomly they'll be dead.

It is the switch? A controller? I'm not too good with wiring but if someone knows for sure what the cause for sure, I can figure out how to replace it.

EDIT 1: Would this be this "circuit breaker" or "controller module"? Where are these located?
__________________
'01, 173k+ miles, 2in add-a-leafs + 2in pucks, 245 75 16 Goodyear MT/Rs.

Looking to get an SYE, Roof Rack.

Last edited by MarkJRust; 01-07-2014 at 09:40 AM.
MarkJRust is offline   Reply With Quote
Old 01-07-2014, 09:51 AM   #2
CF Veteran

 
freegdr's Avatar
 
Join Date: Mar 2010
Location: Taking slum lord to court soon ....
Posts: 31,086

View freegdr's Photo Album My Photos
1989 xj sport 2dr Cherokee
Default

You got delay option ?
__________________
its all in your altitude,horn broke watch for fingerWhen asking for help here and not listening to test procedures why ask.
freegdr is offline   Reply With Quote
Old 01-07-2014, 10:03 AM   #3
Member
 
MarkJRust's Avatar
 
Join Date: May 2011
Location: Michigan
Posts: 135

View MarkJRust's Photo Album My Photos
2001 Cherokee
Send a message via AIM to MarkJRust
Default

Yeah, I have intermittent/delay, low, and high speeds. None of them work.
__________________
'01, 173k+ miles, 2in add-a-leafs + 2in pucks, 245 75 16 Goodyear MT/Rs.

Looking to get an SYE, Roof Rack.
MarkJRust is offline   Reply With Quote
Old 01-07-2014, 10:27 AM   #4
CF Veteran
 
CCKen's Avatar
 
Join Date: Aug 2010
Location: Canton, MI
Posts: 3,934

View CCKen's Photo Album My Photos
1999 Cherokee
Default

Quote:
Originally Posted by MarkJRust View Post
A week or two ago I went to start up my Jeep and turn on the wipers to remove some snow, they didn't work. The sprayer did though. Checked the fuses anyway and they were fine. First thought there was a short or the motor was dead and I started researching for parts. Come back an hour or so later, and they work again.

They work flawlessly up until this morning. Start up the Jeep and let it run, come back to turn on the windshield wipers to clear the defrosted snow and ice and they're dead again.

I'm going to let it sit, wiggle the wipers a bit and see if they go. But I'd like to know if anyone else has experienced this or what it may be. It's concerning me that I may need them and randomly they'll be dead.

It is the switch? A controller? I'm not too good with wiring but if someone knows for sure what the cause for sure, I can figure out how to replace it.

EDIT 1: Would this be this "circuit breaker" or "controller module"? Where are these located?
There's a 20 Amp circuit breaker in the Juntion Block (passenger footwell). CB #30. See JB layout pic below. You'll have to remove the cover off the JB to get at the CB.

Generally speaking, if a fuse or CB pops there's something in its circuit that exceeds the fuse/CB rating due to short circuit, etc. You can try replacing the CB and see if the problem persists. The Wipe/Wash switch on the steering column contains a relay that powers the front wiper motor. This relay could be acting up. The wiper motor itself could be going bad.

FYI: The ground for the front wiper motor is on the left inner fender, near the PCM. There's two screws there and several wires which are the grounds for other circuits.

Click the image to open in full size.
__________________
If we have data, letís look at data. If all we have are opinions, letís go with mine.
Trust but verify.
CCKen is offline   Reply With Quote
Old 01-07-2014, 10:31 AM   #5
CF Veteran

 
freegdr's Avatar
 
Join Date: Mar 2010
Location: Taking slum lord to court soon ....
Posts: 31,086

View freegdr's Photo Album My Photos
1989 xj sport 2dr Cherokee
Default

Quote:
Originally Posted by MarkJRust View Post
Yeah, I have intermittent/delay, low, and high speeds. None of them work.
Theres a module behind the lower dash panel right in front of your left knee. Its just velcrowed there unplug it from both connectors then plug the two connectors together see if wipers work if they do Id replace the module...
__________________
its all in your altitude,horn broke watch for fingerWhen asking for help here and not listening to test procedures why ask.
freegdr is offline   Reply With Quote
Old 01-07-2014, 10:36 AM   #6
CF Veteran

 
freegdr's Avatar
 
Join Date: Mar 2010
Location: Taking slum lord to court soon ....
Posts: 31,086

View freegdr's Photo Album My Photos
1989 xj sport 2dr Cherokee
Default Module

This...
Attached Images
 
__________________
its all in your altitude,horn broke watch for fingerWhen asking for help here and not listening to test procedures why ask.
freegdr is offline   Reply With Quote
Old 01-07-2014, 11:06 AM   #7
CF Veteran
 
CCKen's Avatar
 
Join Date: Aug 2010
Location: Canton, MI
Posts: 3,934

View CCKen's Photo Album My Photos
1999 Cherokee
Default

Quote:
Originally Posted by freegdr View Post
Theres a module behind the lower dash panel right in front of your left knee. Its just velcrowed there unplug it from both connectors then plug the two connectors together see if wipers work if they do Id replace the module...
Does the 2001 XJ have this module? I couldn't find it in the wiring diagrams.
__________________
If we have data, letís look at data. If all we have are opinions, letís go with mine.
Trust but verify.
CCKen is offline   Reply With Quote
Old 01-07-2014, 11:33 AM   #8
CF Veteran

 
freegdr's Avatar
 
Join Date: Mar 2010
Location: Taking slum lord to court soon ....
Posts: 31,086

View freegdr's Photo Album My Photos
1989 xj sport 2dr Cherokee
Default

Quote:
Originally Posted by CCKen View Post
Does the 2001 XJ have this module? I couldn't find it in the wiring diagrams.
Not sure was waiting on op find...
__________________
its all in your altitude,horn broke watch for fingerWhen asking for help here and not listening to test procedures why ask.
freegdr is offline   Reply With Quote
Old 01-07-2014, 11:37 AM   #9
Member
 
MarkJRust's Avatar
 
Join Date: May 2011
Location: Michigan
Posts: 135

View MarkJRust's Photo Album My Photos
2001 Cherokee
Send a message via AIM to MarkJRust
Default

I'll go take a look for that module.
__________________
'01, 173k+ miles, 2in add-a-leafs + 2in pucks, 245 75 16 Goodyear MT/Rs.

Looking to get an SYE, Roof Rack.
MarkJRust is offline   Reply With Quote
Old 01-07-2014, 11:52 AM   #10
Member
 
MarkJRust's Avatar
 
Join Date: May 2011
Location: Michigan
Posts: 135

View MarkJRust's Photo Album My Photos
2001 Cherokee
Send a message via AIM to MarkJRust
Default

Just stuck my head under there, didn't see anything south of the headlight switch on the left side of the dash. Only until it got near the bottom or flat part of the underside did I see anymore wires.
__________________
'01, 173k+ miles, 2in add-a-leafs + 2in pucks, 245 75 16 Goodyear MT/Rs.

Looking to get an SYE, Roof Rack.
MarkJRust is offline   Reply With Quote
Old 01-07-2014, 12:05 PM   #11
Member
 
MarkJRust's Avatar
 
Join Date: May 2011
Location: Michigan
Posts: 135

View MarkJRust's Photo Album My Photos
2001 Cherokee
Send a message via AIM to MarkJRust
Default

Click the image to open in full size.

Here's a pic of the underside of the dash, left side. (Sorry about the quality) The piece with the yellow sticker is the headlight switch for reference.
__________________
'01, 173k+ miles, 2in add-a-leafs + 2in pucks, 245 75 16 Goodyear MT/Rs.

Looking to get an SYE, Roof Rack.
MarkJRust is offline   Reply With Quote
Old 01-07-2014, 12:16 PM   #12
CF Veteran

 
freegdr's Avatar
 
Join Date: Mar 2010
Location: Taking slum lord to court soon ....
Posts: 31,086

View freegdr's Photo Album My Photos
1989 xj sport 2dr Cherokee
Default

Its on the panel right under steering column just to the left of column.
Attached Images
 
__________________
its all in your altitude,horn broke watch for fingerWhen asking for help here and not listening to test procedures why ask.
freegdr is offline   Reply With Quote
Old 01-07-2014, 12:20 PM   #13
CF Veteran

 
freegdr's Avatar
 
Join Date: Mar 2010
Location: Taking slum lord to court soon ....
Posts: 31,086

View freegdr's Photo Album My Photos
1989 xj sport 2dr Cherokee
Default

Here if your year has it
Attached Images
 
__________________
its all in your altitude,horn broke watch for fingerWhen asking for help here and not listening to test procedures why ask.
freegdr is offline   Reply With Quote
Old 01-07-2014, 12:26 PM   #14
Member
 
MarkJRust's Avatar
 
Join Date: May 2011
Location: Michigan
Posts: 135

View MarkJRust's Photo Album My Photos
2001 Cherokee
Send a message via AIM to MarkJRust
Default

Quote:
Originally Posted by freegdr View Post
Its on the panel right under steering column just to the left of column.
I just looked in there again. On the underside of the dash there is nothing near my left knee as shown in the picture.

The only harnesses I see near the steering column are all the way up near where the wheel itself attaches.
__________________
'01, 173k+ miles, 2in add-a-leafs + 2in pucks, 245 75 16 Goodyear MT/Rs.

Looking to get an SYE, Roof Rack.
MarkJRust is offline   Reply With Quote
Old 01-07-2014, 12:35 PM   #15
CF Veteran

 
freegdr's Avatar
 
Join Date: Mar 2010
Location: Taking slum lord to court soon ....
Posts: 31,086

View freegdr's Photo Album My Photos
1989 xj sport 2dr Cherokee
Default

Quote:
Originally Posted by MarkJRust View Post
I just looked in there again. On the underside of the dash there is nothing near my left knee as shown in the picture.

The only harnesses I see near the steering column are all the way up near where the wheel itself attaches.
Then app you do not have it...
__________________
its all in your altitude,horn broke watch for fingerWhen asking for help here and not listening to test procedures why ask.
freegdr is offline   Reply With Quote
Old 01-07-2014, 12:35 PM
 
 
 
submit to reddit
Reply

Tags
broken, dead, windshield, wipers
Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 12:45 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.5.2
This site is in no way affiliated with Jeep or Chrysler.

Emails Backup