Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech
Register Forgot Password?
Search

Welcome to Cherokee Forum!
Welcome to Cherokee Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 08-06-2011, 07:22 AM   #1
Newbie
 
anomoli's Avatar
 
Join Date: Dec 2009
Location: Florida
Posts: 23

View anomoli's Photo Album My Photos
1997 Cherokee
Default Signs of a weak oil pump?

I have '97 with 153,000 miles. Lately I have noticed a low end knock when I start up, usually when cold, but also more recently when it has been sitting awhile. It is the same sound I hear after an oil change on this and other high mileage vehicles.

My theory is that the pump may not be holding a prime, and there is some slippage until started. My idiot light (no gauges) comes on for a sec after it starts and everything is fine, no knocking when running, except for a slight lifter sound.

Is it time for an oil pump replacement or kit, or is there something else going on?

Thanx for any help
anomoli is offline   Reply With Quote
Old 08-06-2011, 08:29 AM   #2
Seasoned Member
 
Join Date: Jul 2011
Location: Richmond, Va
Posts: 323

View thakmfb's Photo Album My Photos
1992 Cherokee
Default

What kind of oil filter are you running? I would suggest running a mopar oil filter to see if this corrects your problem. A lot of lower end oil filters have sub par drain back valves
thakmfb is offline   Reply With Quote
Old 08-06-2011, 08:57 PM   #3
Newbie
 
anomoli's Avatar
 
Join Date: Dec 2009
Location: Florida
Posts: 23

View anomoli's Photo Album My Photos
1997 Cherokee
Default

Right now its a Fram oil filter from Advanced Auto, I will give it a try, thanx.
anomoli is offline   Reply With Quote
Old 08-07-2011, 08:05 PM   #4
aj6
Seasoned Member
 
aj6's Avatar
 
Join Date: Oct 2009
Location: chi
Posts: 269

View aj6's Photo Album My Photos
2001 Cherokee
Default

i got the same thing going on with my 2001.. not when its cold but after ive drivin for some time and let it sit for more then 10 mins... there a 1/2 sec of low end knock when i restart, then it goes away... i dont think it enof to do damge, but still it shouldint be happenin... mopar fillter i will try as well
__________________
Quote:
Your jeep looks like it's going to eat someone. That's just plain evil-looking. Pretty cool.
aj6 is offline   Reply With Quote
Old 08-07-2011, 08:05 PM
 
 
 
submit to reddit
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Signs of a dying renix ecm? goneboating06 OEM Cherokee Tech 28 03-29-2014 03:02 PM
anyone with jeep signs? trailsend.lake Cherokee Chat 5 07-08-2011 01:59 PM
signs of a bad steering stabilizer? Phatwitaph OEM Cherokee Tech 3 02-16-2011 08:21 PM
signs of bad wheel bearings?? LeRoy90laredo OEM Cherokee Tech 9 10-04-2010 07:12 PM
Signs Gas line is messed up? 98CherokeeLimit4x4 OEM Cherokee Tech 5 04-08-2010 05:20 PM

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:21 AM.


This site is in no way affiliated with Jeep or Chrysler.

Emails Backup