Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech
Register Forgot Password?
Register Photos FAQ Members List Social Groups Search Today's Posts Mark Forums Read GarageVendor DirectoryvBLive
Search

Welcome to Cherokee Forum!
Welcome to Cherokee Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 10-28-2009, 10:09 PM   #1
Junior Member
 
broncokid1984's Avatar
 
Join Date: Sep 2009
Posts: 44

View broncokid1984's Photo Album My Photos
1997 Cherokee
Default runs hot

got a 1990 cherokee that runs hot quick i took the therm.out, flushed it out, done a compression test and no water in my oil. about 5 to 10 min. after idleing it starts going back into my ress. with a stream as big as the hole. was wondering what yall thoughts r bot it. thanks in advance.
p.s. it starts bubbling out the ress.
broncokid1984 is offline   Reply With Quote
Old 10-29-2009, 12:24 AM   #2
Seasoned Member
 
Jeep85's Avatar
 
Join Date: Sep 2009
Location: 60193 IL
Posts: 493

View Jeep85's Photo Album My Photos
1994 Cherokee
Default

head can be not good is there knock in the vale cover
Jeep85 is offline   Reply With Quote
Old 10-29-2009, 01:30 AM   #3
Member
 
Camrynz's Avatar
 
Join Date: Aug 2009
Posts: 213

View Camrynz's Photo Album My Photos
1987 Cherokee
Default

radiator clogged?
__________________
1987 Jeep Cherokee Laredo Limited
Camrynz is offline   Reply With Quote
Old 10-29-2009, 01:49 AM   #4
Seasoned Member
 
Jeep85's Avatar
 
Join Date: Sep 2009
Location: 60193 IL
Posts: 493

View Jeep85's Photo Album My Photos
1994 Cherokee
Default

did you do a fluid change
__________________
If needed of stock XJ parts I'm the man for you great prices Area 60193 IL
Build sheet
http://www.cherokeeforum.com/f46/94-xj-2dr-29015/
Upgrade injectors works from 91-2001

http://www.cherokeeforum.com/f11/neo...rs-sale-40261/

http://www.cherokeeforum.com/f11/91-xj-part-out-39318/
Jeep85 is offline   Reply With Quote
Old 10-29-2009, 05:41 AM   #5
CF Veteran
 
NewXJaddict's Avatar
 
Join Date: Sep 2009
Location: NC
Posts: 5,368

View NewXJaddict's Photo Album My Photos
1987 Cherokee
Default

1990 isnt that renix with the closed pressure system? Did you burp it well after taking the t-stat out etc?
NewXJaddict is offline   Reply With Quote
Old 10-29-2009, 05:49 AM   #6
Seasoned Member
 
Jeep85's Avatar
 
Join Date: Sep 2009
Location: 60193 IL
Posts: 493

View Jeep85's Photo Album My Photos
1994 Cherokee
Default

it can be water pump
__________________
If needed of stock XJ parts I'm the man for you great prices Area 60193 IL
Build sheet
http://www.cherokeeforum.com/f46/94-xj-2dr-29015/
Upgrade injectors works from 91-2001

http://www.cherokeeforum.com/f11/neo...rs-sale-40261/

http://www.cherokeeforum.com/f11/91-xj-part-out-39318/
Jeep85 is offline   Reply With Quote
Old 10-29-2009, 12:45 PM   #7
Member
 
Camrynz's Avatar
 
Join Date: Aug 2009
Posts: 213

View Camrynz's Photo Album My Photos
1987 Cherokee
Default

Mine ran hot because my coolant bottle was leaking.Fix it and now it dont get hot anymore.
__________________
1987 Jeep Cherokee Laredo Limited
Camrynz is offline   Reply With Quote
Old 10-29-2009, 12:50 PM   #8
Newbie
 
Join Date: Sep 2009
Posts: 15

View tboss619's Photo Album My Photos
Cherokee
Default

check the pump remove and inspect it ,,mine run hot and the blades on the impellar were gone I guess they just rusted away ,,new pump from the zone and prob. was solved its abt a 2 hour job...
tboss619 is offline   Reply With Quote
Old 10-29-2009, 12:52 PM   #9
Member
 
Camrynz's Avatar
 
Join Date: Aug 2009
Posts: 213

View Camrynz's Photo Album My Photos
1987 Cherokee
Default

Aint there like a weeping hole on the water pump that when it starts to go bad it will leak?
__________________
1987 Jeep Cherokee Laredo Limited
Camrynz is offline   Reply With Quote
Old 10-29-2009, 01:15 PM   #10
Seasoned Member
 
Geck_87Laredo's Avatar
 
Join Date: Sep 2009
Location: So Cal
Posts: 360

View Geck_87Laredo's Photo Album My Photos
87 Cherokee
Default

jeep85
is this the knock your talking about?
Mine does this and gets hot like 220-230 after 15min of driving
Geck_87Laredo is offline   Reply With Quote
Old 10-29-2009, 01:15 PM
 
 
 
submit to reddit
Reply
Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
XJ still runs after key is off WAD357 OEM Cherokee Tech 7 10-28-2009 08:15 PM
runs, but like crap skiebuster Grand Cherokee Tech 4 08-13-2009 08:53 PM
88 runs rough wet_willy OEM Cherokee Tech 0 07-03-2009 02:01 PM
92 runs like crap! Jeep4life OEM Cherokee Tech 12 04-22-2009 09:06 AM
89 xj runs rough 89Xjchris OEM Cherokee Tech 5 02-19-2009 12:48 AM


All times are GMT -5. The time now is 02:07 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.5.2
This site is in no way affiliated with Jeep or Chrysler.

Emails Backup