Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech
Register Forgot Password?
Search

Welcome to Cherokee Forum!
Welcome to Cherokee Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 09-12-2008, 10:23 PM   #1
Newbie
 
Join Date: Aug 2008
Posts: 6

View forbyer's Photo Album My Photos
1990 Cherokee
Question Running Rough

1990 cherokee laredo, 4.0

between 800-1800 it runs rough and backfires but above 1800 it runs perfect.
i dont know what it could be, I think it could be the throttle position sensor or something. HELP me out guys. Thanks
forbyer is offline   Reply With Quote
Old 09-12-2008, 10:25 PM   #2
Renix Super Guru
 
BlueXJ's Avatar
 
Join Date: Mar 2008
Location: In yourz postez fissin jurr spelinzs
Posts: 24,521

View BlueXJ's Photo Album My Photos
1990XJ/1989MJ Cherokee
Send a message via Yahoo to BlueXJ
Default

Check the intake manifold for loose or missing bolts. If that isn't the problem look for leaking vacuum lines.
__________________
JEEP I bow to its almighty power which no mortal 4x4 can match.
R.I.P. Zachman you will be missed.
CF the friendly forum
R.I.P. Brian (96_XJ) Perinne

CBW Member #69
BlueXJ is offline   Reply With Quote
Old 06-13-2009, 01:46 PM   #3
Newbie
 
JayDee's Avatar
 
Join Date: Jun 2009
Posts: 17

View JayDee's Photo Album My Photos
1996 Grand Cherokee
Default

Have you checked the sparkers, leads and distributor. It sounds similar to wat my 96 GC is up to. Let me know how it goes
JayDee is offline   Reply With Quote
Old 06-13-2009, 01:46 PM
 
 
 
submit to reddit
Reply
Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
rough idle mattypat OEM Cherokee Tech 1 12-22-2009 04:58 PM
rough day the gimp Off-Topic Discussion 11 10-31-2008 10:31 PM
Fuel Filter Replacement/Rough Running spencersausser OEM Cherokee Tech 8 10-22-2008 09:01 AM
Rough Start elementsquared OEM Cherokee Tech 49 09-01-2008 06:24 PM
motor running rough? kmanxj5050 OEM Cherokee Tech 9 05-12-2008 09:35 PM


All times are GMT -5. The time now is 08:47 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site is in no way affiliated with Jeep or Chrysler.

Emails Backup