Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech
Register Forgot Password?
Search

Welcome to Cherokee Forum!
Welcome to Cherokee Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 12-09-2010, 09:01 PM   #1
Newbie
 
Join Date: May 2010
Location: Kalamazoo, Michigan
Posts: 1

View scooterfrenzy's Photo Album My Photos
2001 Cherokee
Default Rear wiper motor not working, it just clicks

I have a 2001 jeep Cherokee sport. Over the summer the rear wiper motor quit working...all it does is click over and over. Just recently I was able to get it out to check it out. Yesterday I went to a local junk yard to get a used wiper motor for $40. Today I plugged it in and it STILL clicks! So i really have no idea whats wrong. Im hoping someone here can help me out!
__________________
Lift it, lock it, and rock it!!!
scooterfrenzy is offline   Reply With Quote
Old 12-09-2010, 09:20 PM   #2
Old Skewl CF like a Sir
 
Bustedknuckle's Avatar
 
Join Date: Feb 2008
Location: Fort Myers, FL
Posts: 4,028

View Bustedknuckle's Photo Album My Photos
1996 Cherokee
Send a message via AIM to Bustedknuckle
Default

Sounds like somethings bound up, or quite possibly the junkyard one wasn't good either.
__________________


07 JKU Sahara (with tribute to XJ badges )
3.5" lift, 35" Wrangler Duratac, Spidertrax spacers, Pro-Comp rims, disconnects, TnT Sliders, TnT front bumper, no rear, CB, TnT tramp stamp w/ antenna, LED interior, Delta headlamps, D2 Dually pillar mounted, full skid plating, RCV axle shafts, Synergy 1 ton ball joints etc.
Waiting to be installed -
4.88 front & rear, Artec axle and c gusset truss, Eaton E-Locker, Trac-Lock Rear, sPod module, BTF diff covers

Sold: 01' XJ, 96' XJ, 89' XJ, 97' ZJ, 92' YJ, 97' XJ, 02' WJ, 90' XJ, 95' XJ
Current: 07' JKU Sahara , 96' ZJ
Bustedknuckle is offline   Reply With Quote
Old 09-11-2011, 06:41 PM   #3
Newbie
 
Join Date: Sep 2011
Posts: 2

View kzoojeep's Photo Album My Photos
Cherokee
Default

I have the same problem. Just replaced the rear wiper motor assembly with a re-manufactured unit. The relay on it clicks, but the motor doesn't move the wiper arm. It would seem the switch is fine if it's getting power to the motor relay, which is making it click. Is it possible the re-manufactured is bad too or something else I'm missing? Thanks!
kzoojeep is offline   Reply With Quote
Old 09-11-2011, 06:41 PM
 
 
 
submit to reddit
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
rear windshield wiper not working jeepxj19 OEM Cherokee Tech 5 11-29-2010 10:16 PM
Rear wiper question, not working xjroller OEM Cherokee Tech 1 11-22-2010 06:18 PM
Rear windshield wiper not working properly jeepxj19 OEM Cherokee Tech 0 11-10-2010 12:26 PM
99 XJ Rear Wiper Motor frankenstein897 Wanted 2 03-11-2010 07:11 AM
rear wiper motor POLAR_JEEP_04 Wanted 0 09-07-2008 04:38 PM


Tags
rear wiper motor
Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 03:56 AM.


This site is in no way affiliated with Jeep or Chrysler.

Emails Backup