Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech
Register Forgot Password?
Search

Welcome to Cherokee Forum!
Welcome to Cherokee Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 11-29-2010, 11:32 AM   #1
CF Veteran
 
jeepxj19's Avatar
 
Join Date: Oct 2010
Location: Salem Nh
Posts: 1,752

View jeepxj19's Photo Album My Photos
1998 Cherokee
Send a message via Skype™ to jeepxj19
Default rear windshield wiper not working

I cant get my rear windshield wiper to work correctly, it works fine when i hold down the button to use the windshield washer feature but if i just put it in normal mode to allow it to go by itself it doesnt work, is the actual wiper mode and washer mode on 2 different fuses any ideas?
jeepxj19 is offline   Reply With Quote
Old 11-29-2010, 11:57 AM   #2
Newbie
 
Join Date: Oct 2009
Posts: 17

View LSkrabut's Photo Album My Photos
2000 Cherokee
Default

I would either replace the switch or tear it apart and look closely at the switch connection 2 which leads to plug pin 4.

0 = off
2 = wiper only
1 = wiper and pump

Above is internal numbering, dual side switch.


1 = ground
2 = pump (1, one side of internal switch)
3 = lamp
4 = wiper (1 and 2 on switch feed to this, other side)
5 = fused input
6 = to motor (motor is fused)

Plug numbering
__________________
LSkrabut
2000 Sport, 5-speed, Stocker -- Utah Driven
LSkrabut is offline   Reply With Quote
Old 11-29-2010, 12:25 PM   #3
Senior Member
 
dans01classic's Avatar
 
Join Date: Dec 2009
Location: North Carolina
Posts: 541

View dans01classic's Photo Album My Photos
2001 Cherokee
Default

pritty sure they are on the same fuze. but i never use mine any ways. I actually have my wiper fluid hose rigged up so it shoots out backwards for pesty tailgaters. They are lucky i dont fill it up with anything else! lol
dans01classic is offline   Reply With Quote
Old 11-29-2010, 02:28 PM   #4
Member
 
MickDime's Avatar
 
Join Date: Oct 2010
Location: Minnesota
Posts: 247

View MickDime's Photo Album My Photos
99 Cherokee
Default

So the blade moves when you press down, but not when you click it in the first position?
MickDime is offline   Reply With Quote
Old 11-29-2010, 06:53 PM   #5
CF Veteran
 
jeepxj19's Avatar
 
Join Date: Oct 2010
Location: Salem Nh
Posts: 1,752

View jeepxj19's Photo Album My Photos
1998 Cherokee
Send a message via Skype™ to jeepxj19
Default

Quote:
Originally Posted by MickDime View Post
So the blade moves when you press down, but not when you click it in the first position?
yea it works when i press it all the way down but not when i turn it on to work just the wiper, its weird all i remember happening is i washed my rig one day and then it stoped working.
jeepxj19 is offline   Reply With Quote
Old 11-29-2010, 10:16 PM   #6
Member
 
MickDime's Avatar
 
Join Date: Oct 2010
Location: Minnesota
Posts: 247

View MickDime's Photo Album My Photos
99 Cherokee
Default

My best guess it is something with the switch then

it is not a fuse or the motor itself

you can get OEM spares for like $15
MickDime is offline   Reply With Quote
Old 11-29-2010, 10:16 PM
 
 
 
submit to reddit
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with rear windshield wiper removal chiefcherokee OEM Cherokee Tech 9 11-11-2012 10:42 AM
Front windshield washer and wiper stoped working xj92 OEM Cherokee Tech 5 01-11-2011 09:51 PM
Rear windshield wiper not working properly jeepxj19 OEM Cherokee Tech 0 11-10-2010 12:26 PM
Rear windshield wiper arm juicy_j OEM Cherokee Tech 13 10-13-2009 11:50 AM
front and rear windshield wiper issues on a 99 sport easy_roller OEM Cherokee Tech 0 01-20-2009 09:41 AM

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 01:10 PM.


This site is in no way affiliated with Jeep or Chrysler.

Emails Backup