Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech
Register Forgot Password?
Search

Welcome to Cherokee Forum!
Welcome to Cherokee Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 12-31-2008, 08:56 AM   #1
Member
 
XJersey's Avatar
 
Join Date: Nov 2008
Location: New Jersey
Posts: 133

View XJersey's Photo Album My Photos
2001 Cherokee
Default Rear Defroster

Anyone ever have problems with their rear defroster not working? I checked the fuse and that seems to be ok.. Are the black relays next to the fusebox easily replaced? I should probably test the connection at the hatch to see if I'm getting any kind of reading..
XJersey is offline   Reply With Quote
Old 12-31-2008, 05:38 PM   #2
Junior Member
 
cherokeeguy64's Avatar
 
Join Date: Aug 2008
Location: NKY and EKU
Posts: 75

View cherokeeguy64's Photo Album My Photos
2001 Cherokee
Default

same thing happened to me I know this is crazy but unplug it and plug it back in...worked for me try it out!!!
cherokeeguy64 is offline   Reply With Quote
Old 12-31-2008, 06:00 PM   #3
CF Veteran
 
prerunner1982's Avatar
 
Join Date: May 2008
Location: Edmond, OK
Posts: 2,433

View prerunner1982's Photo Album My Photos
1993 Cherokee
Default

Rear defroster?...let me guess.. you have power windows and locks too.. I dont even have a rear wiper and didnt have rear speakers...
You'll are high class..
Just razzin ya.. The way I see it.. it is one less thing to go wrong.

When it rains though.. my back window gets covered in road grime and dirt and I cant see.. Since the wiring is already back there I have thought about putting a rear wiper in. Didn't know they ever came with rear defrosters though. I guess that is what I get for owning a "classic".
__________________
Jon
1993 XJ, 2dr, 4x4. Stock.

Red Dirt Jeeps

Jeep Cherokee Podcast

I would rather be wheeling pondering God, than in church pondering wheeling.
prerunner1982 is offline   Reply With Quote
Old 12-31-2008, 06:13 PM   #4
Member
 
athenscj5's Avatar
 
Join Date: Nov 2008
Location: Dixon, MO
Posts: 205

View athenscj5's Photo Album My Photos
1998 Cherokee
Default

Mine isn't working now. I have tried to trouble shoot, I just haven't been able to figure it out yet. I think it is the grid on mine that has gone bad. All of my glass needs to be replaced and I am think the rear windshield might be the first.

My rear wiper doesn't work either, I am not sure if this is related yet.
athenscj5 is offline   Reply With Quote
Old 12-31-2008, 06:28 PM   #5
CF SO-CAL CHEROKEES
 
xj jason's Avatar
 
Join Date: Apr 2008
Location: san bernardino, ca
Posts: 248

View xj jason's Photo Album My Photos
1988, 1999 Cherokee
Send a message via Yahoo to xj jason
Default

why dont you try to resolder the connection
__________________
1999 Jeep Cherokee SE 2wd, Auto
2DR, 4.0L, Dana 35
(STOCKER TO THE BONE)

1988 Jeep Cherokee 4wd, Auto
4dr Limited
Front Axel: Dana 30 (no vacuum)
Transfercase: NP242
Rear Axel: Dana 35
Suspension: Stock (soon)
Wheels: 29X8.50 Superswampers TSL
Tires: American Racing Wheels 15X8 Black
xj jason is offline   Reply With Quote
Old 01-01-2009, 01:17 AM   #6
Seasoned Member
 
TXstiGuy's Avatar
 
Join Date: Dec 2008
Location: Burleson, TX
Posts: 311

View TXstiGuy's Photo Album My Photos
1995 Cherokee
Smile

check the grid lines look for any breaks or scratched lines if you do find them its an easy fix. Auto parts stores carry a grid repair kit you just paint it on
TXstiGuy is offline   Reply With Quote
Old 01-01-2009, 08:42 AM   #7
Member
 
athenscj5's Avatar
 
Join Date: Nov 2008
Location: Dixon, MO
Posts: 205

View athenscj5's Photo Album My Photos
1998 Cherokee
Default

Mine seems to be coveres by some type of "something". The lines have causes this lining to bubble in some places. So in order to get to them I have to remove what might actually be some type of tint film. It is really hard to explain what it is.
athenscj5 is offline   Reply With Quote
Old 01-01-2009, 09:05 AM   #8
Renix Super Guru
 
BlueXJ's Avatar
 
Join Date: Mar 2008
Location: In yourz postez fissin jurr spelinzs
Posts: 24,521

View BlueXJ's Photo Album My Photos
1990XJ/1989MJ Cherokee
Send a message via Yahoo to BlueXJ
Default

Try the unplug and replug thing mentioned above. Most electrical problems on Cherokees are corrosion related.
__________________
JEEP I bow to its almighty power which no mortal 4x4 can match.
R.I.P. Zachman you will be missed.
CF the friendly forum
R.I.P. Brian (96_XJ) Perinne

CBW Member #69
BlueXJ is offline   Reply With Quote
Old 02-19-2010, 01:12 PM   #9
Newbie
 
Join Date: Feb 2010
Posts: 5

View Lokdrok's Photo Album My Photos
Cherokee
Default

My rear defroster hasnt worked as long as ive had my jeep and i cant get it to work. and i dont know why but for some reason when i press the button for the trunk lights the brake lights and license plate lights come on too. so the whole wiring back there is messed up. dont know if thats part of the problem.. but all my fuses look fine too
Lokdrok is offline   Reply With Quote
Old 02-19-2010, 02:37 PM   #10
Senior Member
 
DagBMX's Avatar
 
Join Date: Jan 2010
Location: Lake Orion, MI
Posts: 685

View DagBMX's Photo Album My Photos
2008 Grand Cherokee
Default

Quote:
Originally Posted by TXstiGuy View Post
check the grid lines look for any breaks or scratched lines if you do find them its an easy fix. Auto parts stores carry a grid repair kit you just paint it on
lol, yeah, i think we all know about that issue...

second line form the top on mine doesn't work. the rest of it does the job, but that one leaves a good amount of fog or snow surrounding it.
__________________
It's got a turbo? BRRRRRUUUUUUVVVVVV-PISH-CHOO-CHOO-CHOO-CHOO!
DagBMX is offline   Reply With Quote
Old 02-19-2010, 02:37 PM
 
 
 
submit to reddit
Reply
Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Defroster problem toolman0114 OEM Cherokee Tech 9 12-09-2009 05:56 PM
rear rubicon express 4.5 rear leaf springs moses OEM Cherokee Tech 6 09-11-2008 11:03 AM


All times are GMT -5. The time now is 04:29 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site is in no way affiliated with Jeep or Chrysler.

Emails Backup