Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech
Register Forgot Password?
Search

Welcome to Cherokee Forum!
Welcome to Cherokee Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 01-07-2012, 09:02 PM   #1
Junior Member
 
1998CherokeeXJ's Avatar
 
Join Date: Jul 2011
Location: Greensburg, Pennsylvania
Posts: 86

View 1998CherokeeXJ's Photo Album My Photos
1998 Cherokee
Exclamation Radio works, but No sound.

I have a 1998 Cherokee Limited with the two factory speakers in the door and i replaced the rear with two 6.5" Alpine Type R 2-Way Coaxial speakers. Up front i put in an Alpine CDE-123 Headunit. It worked properly for 2 weeks and now when i start my car the radio plays and i have sound but after about 5-10min of driving the radio keeps playing and functioning properly but i have no sound from any of the speakers. Ive tried disconnecting the car battery and shutting the car off and nothing fixes it. It only works again for bout 10min when i let the car sit for awhile like overnight. Do you think this could be the wiring job done on the rear speakers or is it just a lose connection behind the headunit? The guy who installed my rear speakers said that the negative and positive connections from the car to the rear speakers didnt matter like what wire went to positive and what wire went to negative and i dont know anything about speaker wiring and he does so i didnt question it.
Help would be greatley appreciated, it sucks not having any music when driving
1998CherokeeXJ is offline   Reply With Quote
Old 01-07-2012, 09:32 PM   #2
CF Veteran
 
PatriotGT's Avatar
 
Join Date: Nov 2009
Location: Dallas, GA 30157
Posts: 1,432

View PatriotGT's Photo Album My Photos
1999 Grand Cherokee
Default

go back and check your speaker wires and the speakers for a short.
If any are shorted, the radio will go into a "safe" mode and not have any sound
going to the speakers. You can try disconnecting one speaker at a time, either
at the head unit or at the speaker themselves. I had my drivers door speaker cause this.
__________________
Age has it's advantages. Now if I can just remember what ----- Semper Fi - Nam Vet
99 Grand Cherokee Laredo
88 Chevy Truck
2009 Acadia
2000 S10

Last edited by PatriotGT; 01-07-2012 at 09:34 PM.
PatriotGT is offline   Reply With Quote
Old 01-07-2012, 10:13 PM   #3
Member
 
Join Date: May 2011
Location: Georgia
Posts: 100

View dylan91xj's Photo Album My Photos
1991 Cherokee
Default

Theres a difference in the positive and negative with aftermarket speakers. It could blow the speakers and cause them to catch fire.
__________________
6.5 lift, 35s, locked with Aussie, and Ready to wheel!!
dylan91xj is offline   Reply With Quote
Old 01-07-2012, 10:17 PM   #4
CF Veteran
 
Zack92MJ's Avatar
 
Join Date: Jun 2011
Location: Dayton, Ohio
Posts: 2,454

View Zack92MJ's Photo Album My Photos
1992 Comanche
Default

Quote:
Originally Posted by dylan91xj
Theres a difference in the positive and negative with aftermarket speakers. It could blow the speakers and cause them to catch fire.
Hahahaha unlikely. But that would be one funny story to hear. "Yeah my speakers blew up and burnt down my Jeep. " haha

Edit: and this positive negative thing..none of the speakers I've ran into have this..got an example?
__________________
The above is not intended to offend, insult, or ridicule in any way, shape or form.
1995 YJ build: http://www.wranglerforum.com/f330/finally-got-one-810409.html - Current
1998 XJ build:
http://www.cherokeeforum.com/f46/project-money-pit-114586/ - Given to my little brother
1992 Mj build: http://comancheclub.com/topic/37879-my-newest-money-pit/ - Sold
تفخر الكافر -Proud Infidel


Zack92MJ is offline   Reply With Quote
Old 01-07-2012, 10:31 PM   #5
Member
 
Join Date: May 2011
Location: Georgia
Posts: 100

View dylan91xj's Photo Album My Photos
1991 Cherokee
Default

well let me correct myself... the quality of the sound does have a difference.
__________________
6.5 lift, 35s, locked with Aussie, and Ready to wheel!!
dylan91xj is offline   Reply With Quote
Old 01-07-2012, 10:31 PM   #6
CF Veteran
 
Zack92MJ's Avatar
 
Join Date: Jun 2011
Location: Dayton, Ohio
Posts: 2,454

View Zack92MJ's Photo Album My Photos
1992 Comanche
Default

Quote:
Originally Posted by dylan91xj
well let me correct myself... the quality of the sound does have a difference.
Oh! Yes that is does. I thought you meant it wouldn't work or something. My bad.
__________________
The above is not intended to offend, insult, or ridicule in any way, shape or form.
1995 YJ build: http://www.wranglerforum.com/f330/finally-got-one-810409.html - Current
1998 XJ build:
http://www.cherokeeforum.com/f46/project-money-pit-114586/ - Given to my little brother
1992 Mj build: http://comancheclub.com/topic/37879-my-newest-money-pit/ - Sold
تفخر الكافر -Proud Infidel


Zack92MJ is offline   Reply With Quote
Old 01-07-2012, 10:38 PM   #7
Member
 
Join Date: May 2011
Location: Georgia
Posts: 100

View dylan91xj's Photo Album My Photos
1991 Cherokee
Default

Haha its cool man i was thinking "what a *******" but then i read it and it did really make sense
__________________
6.5 lift, 35s, locked with Aussie, and Ready to wheel!!
dylan91xj is offline   Reply With Quote
Old 01-08-2012, 12:06 AM   #8
Junior Member
 
1998CherokeeXJ's Avatar
 
Join Date: Jul 2011
Location: Greensburg, Pennsylvania
Posts: 86

View 1998CherokeeXJ's Photo Album My Photos
1998 Cherokee
Default

i disconnected the speaker that had the positive wire connected to the negative tab on the speakers an vice versa, and the radio worked for about 5min and all 3 speakers played, then it quit playing sound again. How can you tell if the other 3 speakers are shorting out? They all look to be wired fine.
1998CherokeeXJ is offline   Reply With Quote
Old 01-08-2012, 07:48 AM   #9
CF Veteran
 
Zack92MJ's Avatar
 
Join Date: Jun 2011
Location: Dayton, Ohio
Posts: 2,454

View Zack92MJ's Photo Album My Photos
1992 Comanche
Default

Quote:
Originally Posted by dylan91xj
Haha its cool man i was thinking "what a *******" but then i read it and it did really make sense
It's all good, I was trying to word it without sounding like a dbag
__________________
The above is not intended to offend, insult, or ridicule in any way, shape or form.
1995 YJ build: http://www.wranglerforum.com/f330/finally-got-one-810409.html - Current
1998 XJ build:
http://www.cherokeeforum.com/f46/project-money-pit-114586/ - Given to my little brother
1992 Mj build: http://comancheclub.com/topic/37879-my-newest-money-pit/ - Sold
تفخر الكافر -Proud Infidel


Zack92MJ is offline   Reply With Quote
Old 01-08-2012, 07:51 AM   #10
CF Veteran
 
Zack92MJ's Avatar
 
Join Date: Jun 2011
Location: Dayton, Ohio
Posts: 2,454

View Zack92MJ's Photo Album My Photos
1992 Comanche
Default

Quote:
Originally Posted by 1998CherokeeXJ
i disconnected the speaker that had the positive wire connected to the negative tab on the speakers an vice versa, and the radio worked for about 5min and all 3 speakers played, then it quit playing sound again. How can you tell if the other 3 speakers are shorting out? They all look to be wired fine.
It sounds to me like the wires are touching or shorting out some where. When I took the door off of my jeep, I rewired everything to male/female connectors and from time to time they would just stop. And I finnally figured out that one of the wires would touch the door and it would ground out and not play or they'd touch. You could try and check that?
__________________
The above is not intended to offend, insult, or ridicule in any way, shape or form.
1995 YJ build: http://www.wranglerforum.com/f330/finally-got-one-810409.html - Current
1998 XJ build:
http://www.cherokeeforum.com/f46/project-money-pit-114586/ - Given to my little brother
1992 Mj build: http://comancheclub.com/topic/37879-my-newest-money-pit/ - Sold
تفخر الكافر -Proud Infidel


Zack92MJ is offline   Reply With Quote
Old 01-08-2012, 10:20 AM   #11
Junior Member
 
1998CherokeeXJ's Avatar
 
Join Date: Jul 2011
Location: Greensburg, Pennsylvania
Posts: 86

View 1998CherokeeXJ's Photo Album My Photos
1998 Cherokee
Default

Ill check those wires too, will they be like visibly crossed? and to fix it do i just seperate em using electrical tape? Someone also told me that it might be my ground wire from the radio that has a bad ground connection.
1998CherokeeXJ is offline   Reply With Quote
Old 01-08-2012, 05:56 PM   #12
Junior Member
 
1998CherokeeXJ's Avatar
 
Join Date: Jul 2011
Location: Greensburg, Pennsylvania
Posts: 86

View 1998CherokeeXJ's Photo Album My Photos
1998 Cherokee
Default

so i repositioned my ground and still the same thing. I have no idea how to check which wires are shorting out so i think im just going to take it to a car audio shop
1998CherokeeXJ is offline   Reply With Quote
Old 01-08-2012, 10:01 PM   #13
Member
 
residentg's Avatar
 
Join Date: Jul 2011
Location: NY
Posts: 186

View residentg's Photo Album My Photos
2000 Limited Cherokee
Default

You probably have the common speaker wire short in the front door boots. Do a search on speaker wire and look for a hit.

To test speaker polarity, use a AA battery and momentarily touch the wires connected to the speaker to the battery. If when you touch the wires, the cone pushes out, the + on the battery is connected to the + on the speaker. If the cone goes in, then the + of the battery is connected to the - of the speaker. The striped wire is usually (but not always) ground -.
residentg is offline   Reply With Quote
Old 05-21-2012, 11:14 PM   #14
Junior Member
 
1998CherokeeXJ's Avatar
 
Join Date: Jul 2011
Location: Greensburg, Pennsylvania
Posts: 86

View 1998CherokeeXJ's Photo Album My Photos
1998 Cherokee
Default

Sorry about takin so long to post the reply, I just forgot about this thread. But turns out it was a short caused by the wires that run up the back right side of the car behind the panel in the right side of the trunk. They had the wires tucked around a sharp edge of the sheetmetal and overtime it cut into the wires so I just taped the up pretty good with electrical tape and took all the insulation off of that panel because it seemed to be putting too much pressure on the wire thus causing the rubbing. So to anyone else who has this problem check the wiring in the back to the soundbar if you have it.
1998CherokeeXJ is offline   Reply With Quote
Old 05-21-2012, 11:14 PM
 
 
 
submit to reddit
Reply


Tags
audio wiring problems
Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 04:31 PM.


This site is in no way affiliated with Jeep or Chrysler.

Emails Backup