My jeep shuts off while driving - Jeep Cherokee Forum
Jeep Cherokee Forum


My jeep shuts off while driving

Reply
 
 
 
Thread Tools Search this Thread
Old 02-01-2010, 02:25 PM   #1
Senior Member
Thread Starter
 
Join Date: Nov 2009
Location: McCall,Idaho
Posts: 539

View goblinish15's Photo Album My Photos
Unhappy My jeep shuts off while driving

When i am just driving down the road going like 25 or 30 or in any speed my engine just STOPS its an automatic. The power stays on but the engine goes silent and then i have to turn the key over again for it to start back up! and sometimes when i start it back up it just clicks and wont start like its flooded or something. WTF!?!?! Its a cherokee laredo 91
goblinish15 is offline   Reply With Quote
Old 02-01-2010, 02:26 PM   #2
CF Veteran
 
x91j's Avatar
 
Join Date: Oct 2009
Location: Chicago IL
Posts: 5,389

View x91j's Photo Album My Photos
Default

alternator??
x91j is offline   Reply With Quote
Old 02-01-2010, 02:31 PM   #3
CF Veteran
 
x91j's Avatar
 
Join Date: Oct 2009
Location: Chicago IL
Posts: 5,389

View x91j's Photo Album My Photos
Default

i would think its ur battery or alternator. but if you get it started and then it shuts off it because ur cars not staying charged. if u cant start it and it clicks its ur battery
x91j is offline   Reply With Quote
Old 02-01-2010, 02:35 PM   #4
Senior Member
Thread Starter
 
Join Date: Nov 2009
Location: McCall,Idaho
Posts: 539

View goblinish15's Photo Album My Photos
Default

Quote:
Originally Posted by x91j View Post
i would think its ur battery or alternator. but if you get it started and then it shuts off it because ur cars not staying charged. if u cant start it and it clicks its ur battery
That might be it. When its night and i put on my brights they work super well then they just get super dim. ANd when the car shuts off and its in drive when i try to start it again it is like starting the car normaly only it wont start. It is as if it is flooded and to get it started again i had to press on the gas over and over and over and faster an faster until i finally hear the engine fire up.
goblinish15 is offline   Reply With Quote
Old 02-01-2010, 02:44 PM   #5
CF Veteran
 
x91j's Avatar
 
Join Date: Oct 2009
Location: Chicago IL
Posts: 5,389

View x91j's Photo Album My Photos
Default

if u can make it to an autozone they can run free tests on ur bat and alternator
x91j is offline   Reply With Quote
Old 02-01-2010, 03:56 PM   #6
Seasoned Member
 
Join Date: Aug 2009
Posts: 300

View je4reyk's Photo Album My Photos
Default

Can you tell us if the engine is turning over when tryin to restart the engine,or is it just clicking like a dead battery,it will help every one help you better
je4reyk is offline   Reply With Quote
Old 02-01-2010, 04:07 PM   #7
"CF Moderator"
 
TrekkerJmm's Avatar
 
Join Date: Sep 2008
Location: N.J. Shore Area
Posts: 3,045

View TrekkerJmm's Photo Album My Photos
Default

It could also be your CPS (crank position sensor) on the bellhousing, if it stalls then starts right up its probably the CPS. Do a search on this forum and you should find it.
Here is a link http://go.jeep-xj.info/HowtoCPSchange.htm

Last edited by TrekkerJmm; 02-01-2010 at 04:11 PM.
TrekkerJmm is offline   Reply With Quote
Old 02-01-2010, 04:18 PM   #8
Senior Member
Thread Starter
 
Join Date: Nov 2009
Location: McCall,Idaho
Posts: 539

View goblinish15's Photo Album My Photos
Default

Quote:
Originally Posted by je4reyk View Post
Can you tell us if the engine is turning over when tryin to restart the engine,or is it just clicking like a dead battery,it will help every one help you better
Its turning over. not clicking like the battery is dead.
goblinish15 is offline   Reply With Quote
Old 02-01-2010, 04:30 PM   #9
"CF Moderator"
 
TrekkerJmm's Avatar
 
Join Date: Sep 2008
Location: N.J. Shore Area
Posts: 3,045

View TrekkerJmm's Photo Album My Photos
Default

Quote:
Originally Posted by goblinish15 View Post
Its turning over. not clicking like the battery is dead.
Then it cant be the battery or starter...Tj
TrekkerJmm is offline   Reply With Quote
Old 02-01-2010, 04:51 PM   #10
Seasoned Member
 
Vindicator9000's Avatar
 
Join Date: Oct 2009
Location: Highland IL
Posts: 305

View Vindicator9000's Photo Album My Photos
Default

Sounds like CPS to me then. I just dealt with random stalling on my 94 that sounded very much like the symptoms you're having. Replaced CPS, and it hasn't stalled since.

It's a bit of a pain to get to though. I recommend about 14" of extensions. A swivel socket *might* help too. Then you can get to it from underneath, along the driver's side of the bellhousing.
Vindicator9000 is offline   Reply With Quote
Old 02-01-2010, 05:24 PM   #11
CF Veteran
 
Troth's Avatar
 
Join Date: Jul 2009
Posts: 1,004

View Troth's Photo Album My Photos
Default

clicking, sounds like a starter or selenoid issue caused by something else. your jeep obviously wouldnt shut off because of a starter issue after already being started, it doesnt sound like alternator because he still has power in the cab but still get it tested. I dont have experience with the CPS but those symptoms dont describe battery and alternator and starter


O Man I just thought of something, check your battery cables for corrosion, I just had to do this this past winter. mine corroded between the end of the rubber coating and the metal batter terminal adaptor on the cables. I would go to start my jeep and it would click once and I would loose all power to domes and gauges and all. I would have to pull off the adaptor off the terminal and put it back on and then try and restart it. I know these symptoms sound different but the cable corrosion creates havoc because ot leads dirrectly into the fuse block and then to the computer and it it has crappy conduction it trips different sensors for protection
Troth is offline   Reply With Quote
Old 02-12-2010, 02:24 PM   #12
Senior Member
Thread Starter
 
Join Date: Nov 2009
Location: McCall,Idaho
Posts: 539

View goblinish15's Photo Album My Photos
Default

IT WAS THE FUEL FILTER!!! imma drivin with no shut downs now! haha smooth sailin now
goblinish15 is offline   Reply With Quote
Old 02-13-2010, 10:43 AM   #13
Junior Member
 
Join Date: Feb 2010
Location: Arizona
Posts: 31

View 89cherokeeXJ's Photo Album My Photos
Default

Hey i had the same problem with my 89 i went couple blocks and it died out probly 15 times i tried to figure it out and replece parts still nothing i took it to the shop it was my throttle sensor try that clean it(or buy a new one) that should be the problem.
89cherokeeXJ is offline   Reply With Quote
Old 02-13-2010, 11:15 AM   #14
"CF Moderator"
 
TrekkerJmm's Avatar
 
Join Date: Sep 2008
Location: N.J. Shore Area
Posts: 3,045

View TrekkerJmm's Photo Album My Photos
Default

Quote:
Originally Posted by goblinish15 View Post
IT WAS THE FUEL FILTER!!! imma drivin with no shut downs now! haha smooth sailin now
KOOL ...Tj
TrekkerJmm is offline   Reply With Quote
Old 10-07-2013, 02:12 PM   #15
Newbie
 
Join Date: Oct 2013
Posts: 1

View jeeplayer's Photo Album My Photos
Default

NoNO!!. LOOK FELLOW JEEP LOVERS LIKE ME.
I HAD AN ISSUE ON MY JEEPS."JEEPS". IT USE TO SHUTT OF ON ME IDLE LOW AND TURN OFF. AT STOP LIGHTS,OR JUST COMMING TO A YIELD.. I WASTED SO MUCH MONEY TRY TO FIND THE SOLUTION.. FUSTRATED..CHANGED PLUGS SENSORS PARTS..EVERYTHING EVEN GOT IT TESTED IN A CERTIFIED JEEP DEALER.. THEY DIDNT EVEN COME TO A ANSWER..
BUT BUTT I FOUND THE SOLITION TO UR FUSTRATION I KNOW IM NOT THE ONLY ONE.ITS NOT THAT IM TRYING TO GET RICH.. JUST TRYING TO GET BACK EVERYTHING I WASTED AND SAVE U TIM AND MONEY CUZZ BELEIVE ME ITS EXPENSIVE AN TIME CONSUMING.. 100DLS AND I WILL E-MAIL U THE ANSWERTO UR PROBLEM. HAVE A GREAT DAY AND GOOD LUCK FINDING THE PROBLEM..ANYTHING THAT THEY TOLD U IT MIGHT B ITS NOT.. IVE DONE IT ALL..
jeeplayer is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
No start?? Ashs1714 OEM Cherokee Technical. All factory issues and info go here! 8 09-04-2015 11:14 PM
Rear Door Won't Close hpwrestler220 OEM Cherokee Technical. All factory issues and info go here! 4 08-31-2015 12:32 PM
98' XJ shuts off at idle jeeper albert OEM Cherokee Technical. All factory issues and info go here! 3 08-24-2015 02:17 PM
Strange behavior after overheating, please help! Ye Ol' Cherokee OEM Cherokee Technical. All factory issues and info go here! 0 08-22-2015 02:43 PM
01 cherokee deceleration issue zhunt728 OEM Cherokee Technical. All factory issues and info go here! 0 08-20-2015 01:37 PM


Tags
shuts off in drive


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 09:02 AM.