Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech
Register Forgot Password?
Search

Welcome to Cherokee Forum!
Welcome to Cherokee Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 02-13-2010, 06:01 PM   #1
Junior Member
 
JustDHutch's Avatar
 
Join Date: Feb 2010
Location: Victorville, Ca
Posts: 80

View JustDHutch's Photo Album My Photos
1992 Cherokee
Default Jeep starts, then dies! I'm stumped need help

Hi all. I use to have a 93 wrangler, and now I just picked up a 92 Cherokee 4.0l Auto with 156k miles. I've always used forums to solve my problems on my vehicles and i've searched for this problem and done most things people suggest and still no luck.

Heres my problem - The Jeep starts and immediately dies. If i give it throttle it still dies. Sometimes when I give it throttle it will rev quick before dieing. It only stays running for about 1 second and rarely stays running for up to 3 seconds. Here's what i have checked.

1.Crank position sensor (installed new one, no help, put old one back in)
2.Throttle Position Sensor (Installed new one, no help, old one back on)
3.IAC (removed and cleaned)
4.MAP Sensor (Unplugged to run on default mode)
5.Checked the 6 pin relay under passenger side dash
6.Checked the resistor on the drivers side fender by twisting the wires together to bypass the relay/resistor (whatever it is)
7.Checked fuel pressure. It reads 32psi with the key turned to the on position. when i start it, it quickly jumps to 42psi, then when the motor dies, it returns to 32psi.
8.I read somewhere the cat gets plugged so I split the exhaust before the cat but no help.
9.New Cap, rotor, plugs, wires.
10.Swapped Fuel Pump Ballast Resistor from running Jeep
11.Fuel pump relay, tried 2 others.
12. WILL STAY RUNNING ON STARTER FLUID
13. Brand new fuel pump
14. Fuel Regulator doesn't leak
Anyone else have any ideas? I'm pretty lost on this.

Last edited by JustDHutch; 02-15-2010 at 07:35 PM.
JustDHutch is offline   Reply With Quote
Old 02-13-2010, 06:03 PM   #2
Seasoned Member
 
Long Island XJ's Avatar
 
Join Date: Feb 2009
Posts: 358

View Long Island XJ's Photo Album My Photos
1993 Cherokee
Default

inspect and clean cap and rotor.
__________________
"Give me Jeep, or Give me Death"

http://www.outlawedoffroad.com/forum.php

93 XJ 190,100




Long Island XJ is offline   Reply With Quote
Old 02-13-2010, 07:28 PM   #3
Junior Member
 
JustDHutch's Avatar
 
Join Date: Feb 2010
Location: Victorville, Ca
Posts: 80

View JustDHutch's Photo Album My Photos
1992 Cherokee
Default

Quote:
Originally Posted by Long Island XJ View Post
inspect and clean cap and rotor.
Thanks for the input Long Island XJ. I just installed New Cap, rotor, plugs, and wires...No help. Any input is appreciated.
JustDHutch is offline   Reply With Quote
Old 02-13-2010, 07:43 PM   #4
Senior Member
 
jeepxj412's Avatar
 
Join Date: Jun 2009
Location: Shorewood, Il
Posts: 594

View jeepxj412's Photo Album My Photos
1998 Cherokee
Default

ok sounds weird but i had the same problem and i couldnt think of what it could be and then my friend (standing next to me with the hood up) said hey look at your battery terminals, they're corroded. so i cleaned them up good and started right up. the only difference between your problem and mine is i was able to rev it up and keep it running. but hey its worth a shot looking right?
jeepxj412 is offline   Reply With Quote
Old 02-13-2010, 08:12 PM   #5
Seasoned Member
 
Long Island XJ's Avatar
 
Join Date: Feb 2009
Posts: 358

View Long Island XJ's Photo Album My Photos
1993 Cherokee
Default

Quote:
Originally Posted by JustDHutch View Post
Thanks for the input Long Island XJ. I just installed New Cap, rotor, plugs, and wires...No help. Any input is appreciated.

haha yup looks like that was the ninth thing you did
__________________
"Give me Jeep, or Give me Death"

http://www.outlawedoffroad.com/forum.php

93 XJ 190,100




Long Island XJ is offline   Reply With Quote
Old 02-13-2010, 08:17 PM   #6
Member
 
Join Date: Jan 2010
Posts: 116

View saleen9973's Photo Album My Photos
Cherokee
Default

Does it have a factory alarm? If so unlock the passenger door and then try to start it.
saleen9973 is offline   Reply With Quote
Old 02-13-2010, 08:46 PM   #7
Junior Member
 
JustDHutch's Avatar
 
Join Date: Feb 2010
Location: Victorville, Ca
Posts: 80

View JustDHutch's Photo Album My Photos
1992 Cherokee
Default

It does not have an alarm system. But I tried it anyways. Unlocked both driver and passenger doors a few times with the key.

I've been reading that alot of times its the Fuel Pump Ballast Resistor. I included a pic at the bottom from another post. I measured the resistance and its 1.5ohms (setting was on 200). Can someone else measure the resistance on theres please so I can see if its bad?

Click the image to open in full size.

Last edited by JustDHutch; 02-13-2010 at 09:53 PM.
JustDHutch is offline   Reply With Quote
Old 02-13-2010, 09:53 PM   #8
Junior Member
 
JustDHutch's Avatar
 
Join Date: Feb 2010
Location: Victorville, Ca
Posts: 80

View JustDHutch's Photo Album My Photos
1992 Cherokee
Default

UPDATE - I sprayed some carb cleaner in the intake, and it ran for about 10 seconds which is the longest it has ran so far. So this tells me is must be a fuel related problem.

Either the pump isnt sending enough fuel after the start, or something is telling it to not send fuel after the start.
JustDHutch is offline   Reply With Quote
Old 02-13-2010, 10:24 PM   #9
Newbie
 
Join Date: Feb 2010
Posts: 10

View 658 Bucks's Photo Album My Photos
2000 Cherokee
Default

Quote:
Originally Posted by JustDHutch View Post
UPDATE - I sprayed some carb cleaner in the intake, and it ran for about 10 seconds which is the longest it has ran so far. So this tells me is must be a fuel related problem.

Either the pump isnt sending enough fuel after the start, or something is telling it to not send fuel after the start.
That does not make sense though, because your fuel pressure guage is reading 42 psi. It sounds like a cap honestly.

Could your fuel filter be clogged?
658 Bucks is offline   Reply With Quote
Old 02-13-2010, 10:29 PM   #10
Junior Member
 
JustDHutch's Avatar
 
Join Date: Feb 2010
Location: Victorville, Ca
Posts: 80

View JustDHutch's Photo Album My Photos
1992 Cherokee
Default

Quote:
Originally Posted by 658 Bucks View Post
That does not make sense though, because your fuel pressure guage is reading 42 psi. It sounds like a cap honestly.

Could your fuel filter be clogged?
True but it only hits that for a split second then right back to 32. Once the Jeep is running doesnt the ballast resistor kick the fuel pressure down?

Previous owner said that he replaced the fuel filter and problems started after he put a new stereo in. I crawled underneath and the fuel filter looks brand new so I believe him on that.
JustDHutch is offline   Reply With Quote
Old 02-13-2010, 10:34 PM   #11
Newbie
 
Join Date: Feb 2010
Posts: 10

View 658 Bucks's Photo Album My Photos
2000 Cherokee
Default

Quote:
Originally Posted by JustDHutch View Post
True but it only hits that for a split second then right back to 32. Once the Jeep is running doesnt the ballast resistor kick the fuel pressure down?

Previous owner said that he replaced the fuel filter and problems started after he put a new stereo in. I crawled underneath and the fuel filter looks brand new so I believe him on that.
Yeah I do not know the specific numbers, but I think that once the engine is on the pressure falls. 32 sounds about right, but the 42 seems a little low. I know that it is contray to reason, but when the engine is off the fuel pressure should be more, I think like in the 60s. I could be wrong, but for some reason that is what I am remembering. Dont quote me on that, because I am not for sure.
658 Bucks is offline   Reply With Quote
Old 02-13-2010, 10:39 PM   #12
Junior Member
 
JustDHutch's Avatar
 
Join Date: Feb 2010
Location: Victorville, Ca
Posts: 80

View JustDHutch's Photo Album My Photos
1992 Cherokee
Default

Quote:
Originally Posted by 658 Bucks View Post
Yeah I do not know the specific numbers, but I think that once the engine is on the pressure falls. 32 sounds about right, but the 42 seems a little low. I know that it is contray to reason, but when the engine is off the fuel pressure should be more, I think like in the 60s. I could be wrong, but for some reason that is what I am remembering. Dont quote me on that, because I am not for sure.
Yeah thats also what i've read. My Haynes Manual says 31psi when running and 39psi when you remove a vacuum from I think the fuel regulator. It doesnt say anything about when its off though, and since it wont stay running...
__________________
'97 Tj on Tons
JustDHutch is offline   Reply With Quote
Old 02-14-2010, 10:31 AM   #13
Junior Member
 
JustDHutch's Avatar
 
Join Date: Feb 2010
Location: Victorville, Ca
Posts: 80

View JustDHutch's Photo Album My Photos
1992 Cherokee
Default

Ok took a ballast resistor out of a friends running jeep and it didn't help. I'm gonna try to spray gas or starter fluid in it later to try and keep it running long enough to see what the fuel pressure does. Any other ideas?
__________________
'97 Tj on Tons
JustDHutch is offline   Reply With Quote
Old 02-14-2010, 10:36 AM   #14
Newbie
 
Join Date: Feb 2010
Posts: 10

View 658 Bucks's Photo Album My Photos
2000 Cherokee
Default

Quote:
Originally Posted by JustDHutch View Post
Ok took a ballast resistor out of a friends running jeep and it didn't help. I'm gonna try to spray gas or starter fluid in it later to try and keep it running long enough to see what the fuel pressure does. Any other ideas?

Did you find out the pressure when off? I have been thinking about this all night and can't think of anything else. I was going to suggest the map sensor, but you already did that. What about computer? I doubt that this is the issue, but at this point I would try everything. I forget, did you try the TPS?

I dont know how the 92 is different, but you might go ahead and try a new fuel pump, it is a pain in the ***, but might be worth it.
658 Bucks is offline   Reply With Quote
Old 02-14-2010, 11:05 AM   #15
CF Veteran
 
captainwoot's Avatar
 
Join Date: Aug 2009
Location: Hanover,Ont, Canada
Posts: 1,003

View captainwoot's Photo Album My Photos
1991 Cherokee
Default

you have checked fuel pressure, but have you checked flow? you can have pressure but no flow..... possible fuel pump? or not enought current flow at the pump , green fuzzy wiring? fuel pump relay, asd relay?
good luck !
__________________
Respect is earned, not given
Evil triumphs when good men do nothing.
1991 cherokee sport
2012 jeep jk Wrangler (my wife's)

captainwoot is offline   Reply With Quote
Old 02-14-2010, 11:05 AM
 
 
 
submit to reddit
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Starts then Dies Cookbrady845 OEM Cherokee Tech 14 01-16-2012 03:57 PM
4.0 starts then dies? wtf? nowayout OEM Cherokee Tech 2 01-19-2010 05:08 PM
starts fine,dies later yanky Grand Cherokee Tech 1 12-18-2009 02:58 AM
Jeep starts and dies immediately after freddiemcd OEM Cherokee Tech 5 08-21-2009 03:06 AM
engine starts and dies draw OEM Cherokee Tech 8 04-18-2009 10:26 PM

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 04:20 AM.


This site is in no way affiliated with Jeep or Chrysler.

Emails Backup