Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech
Register Forgot Password?
Search

Welcome to Cherokee Forum!
Welcome to Cherokee Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 12-18-2010, 07:03 PM   #1
Newbie
 
Join Date: Dec 2010
Location: westminster,colorado
Posts: 1

View jimmysjeep's Photo Album My Photos
1990 Cherokee
Default high idle

i have a 1990 jeep cherokee 4.0l m/t. my idle goes up around 1200-1800.
i have replaced my idle air control and my throttle pos sensor. i've checked idle air control and it's working. any sugestions or is this another jeep mystery?
jimmysjeep is offline   Reply With Quote
Old 12-19-2010, 12:52 AM   #2
Senior Member
 
darknezz's Avatar
 
Join Date: Mar 2010
Location: Eugene, OR
Posts: 754

View darknezz's Photo Album My Photos
1989 Cherokee
Default

uhm wasnt there this exact same thread a page back?

read the info there...

http://www.cherokeeforum.com/f2/high-idle-69360/
__________________
Slowly climbing the ladder...
'94 530i
- 6 spd swap, chip
'89 XJ - 4.5", 31's, ect
'94 325i - HG job, suspension

'79 Camaro - Basic 350,
restoring
darknezz is offline   Reply With Quote
Old 12-19-2010, 12:56 AM   #3
Seasoned Member
 
Kmart164's Avatar
 
Join Date: Dec 2009
Posts: 433

View Kmart164's Photo Album My Photos
Cherokee
Default

I jsut had this problem bud. It was my ECT not clipping in all the way. Replaced the clip, and now I'm good to go. Do you have a loss of coolant temp on the dash gauge?
Kmart164 is offline   Reply With Quote
Old 12-19-2010, 05:23 AM   #4
CF Veteran
 
Join Date: Nov 2010
Location: In the middle of Minnesota!
Posts: 4,713

View tjwalker's Photo Album My Photos
1999 Cherokee
Default

Vacuum leak is an extremely common cause of high idle. I would perform a "comprehensive" search for a vacuum leak if I were you...
__________________
Without data, all you have is an OPINION!

Past Jeeps: '49 Willys, '81 Scrambler, '88 Comanche

Current Jeep: 1999 XJ Sport, bone stock, daily driver.

I work on Jeeps!!
tjwalker is offline   Reply With Quote
Old 12-19-2010, 10:00 AM   #5
Seasoned Member
 
Join Date: Aug 2010
Location: east hampton new york
Posts: 287

View g19n87r's Photo Album My Photos
1996 Cherokee
Default

I have a high idle and low temp reading whats the relationship?
g19n87r is offline   Reply With Quote
Old 12-19-2010, 10:06 AM   #6
Newbie
 
Join Date: Nov 2010
Posts: 25

View mhockey9090's Photo Album My Photos
2000 Grand Cherokee
Default

Clean your throttle body. I cleaned mine and my problems went away. I did a write up on how to replace the IAC motor but then all you need to do is take out the 3 bolts holding the throttly body in there and a hose then your ready to clean.

http://www.cherokeeforum.com/f52/diy...acement-66578/
__________________
2000 Jeep Grand Cherokee Laredo 4.7L
mhockey9090 is offline   Reply With Quote
Old 12-19-2010, 11:27 AM   #7
Newbie
 
Join Date: Dec 2010
Location: Murphy, NC.
Posts: 4

View XJRobert's Photo Album My Photos
1988 Cherokee
Send a message via AIM to XJRobert
Default

i did a complete vacume house replace about 6 months ago it did not fix it, but who is to say that one peace was not missing and did not get replaced. guess i will try to clean up my TB and go from there. and my jeep only has the idiot lights. lol. so i cant check the temp change unless i put in my own.
XJRobert is offline   Reply With Quote
Old 12-19-2010, 05:52 PM   #8
Seasoned Member
 
Kmart164's Avatar
 
Join Date: Dec 2009
Posts: 433

View Kmart164's Photo Album My Photos
Cherokee
Default

Quote:
Originally Posted by g19n87r View Post
I have a high idle and low temp reading whats the relationship?
Does your XJ get up to operating temp, or does it not read at all?
Kmart164 is offline   Reply With Quote
Old 12-20-2010, 03:38 PM   #9
Seasoned Member
 
Join Date: Aug 2010
Location: east hampton new york
Posts: 287

View g19n87r's Photo Album My Photos
1996 Cherokee
Default

it stays around the 1/4 mark 155 or so and if i let it idle for a little it will get up to around 210 but never when im driving
g19n87r is offline   Reply With Quote
Old 12-20-2010, 06:33 PM   #10
CF Veteran
 
Join Date: Nov 2010
Location: In the middle of Minnesota!
Posts: 4,713

View tjwalker's Photo Album My Photos
1999 Cherokee
Default

Quote:
Originally Posted by g19n87r View Post
it stays around the 1/4 mark 155 or so and if i let it idle for a little it will get up to around 210 but never when im driving
Job #1 for you is to get your coolant temperature to CONSISTENTLY stay in the 200-210 range.

Your engine won't run right until you achieve this.

I would install a new Jeep or Stant SuperStat 195 degree thermostat. That might fix your coolant temp issue.
__________________
Without data, all you have is an OPINION!

Past Jeeps: '49 Willys, '81 Scrambler, '88 Comanche

Current Jeep: 1999 XJ Sport, bone stock, daily driver.

I work on Jeeps!!
tjwalker is offline   Reply With Quote
Old 07-09-2013, 01:22 PM   #11
Member
 
4Kevo's Avatar
 
Join Date: May 2012
Location: Columbus, Georgia
Posts: 167

View 4Kevo's Photo Album My Photos
1998 Cherokee
Default

Quote:
Originally Posted by Kmart164 View Post
I jsut had this problem bud. It was my ECT not clipping in all the way. Replaced the clip, and now I'm good to go. Do you have a loss of coolant temp on the dash gauge?
I have high idle in Park/Neutral and low coolant temp...What is the ECT?
4Kevo is offline   Reply With Quote
Old 07-09-2013, 03:21 PM   #12
::Regional Moderator::
 
cruiser54's Avatar
 
Join Date: Aug 2011
Location: Prescott, Az
Posts: 23,247

View cruiser54's Photo Album My Photos
1990 Comanche
Default

Did you adjust the new TPS?
__________________
Cruiser's Mostly Renix Tips can be found in the pink link below:

An index to over 25 helpful write-ups is in Post #1.
http://www.cherokeeforum.com/f51/cruiser54s-mostly-renix-tips-153657/

In Handy Printable pdf format:
https://docs.google.com/file/d/0Bz4d...aEE/edit?pli=1

A link to my Jeep Technical Photos:
http://www.cherokeeforum.com/g/album/1725214


Refresh*Connections*Before*Replacing*Components
cruiser54 is offline   Reply With Quote
Old 07-09-2013, 03:21 PM
 
 
 
submit to reddit
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Very High Idle DeepSky OEM Cherokee Tech 3 09-28-2012 05:22 PM
high idle XJRobert OEM Cherokee Tech 4 12-18-2010 04:33 PM
High idle issue turned to low idle after new parts installed. WTF? Hawkman OEM Cherokee Tech 6 12-13-2010 10:51 PM
No high idle at cold start.. rough idle 1000jeep OEM Cherokee Tech 5 07-31-2010 08:55 PM
High Idle 89Pioneer OEM Cherokee Tech 1 11-05-2008 12:42 PM

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 06:54 AM.


This site is in no way affiliated with Jeep or Chrysler.

Emails Backup