Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech
Register Forgot Password?
Register Photos FAQ Members List Social Groups Search Today's Posts Mark Forums Read GarageVendor DirectoryvBLive TSB & Recalls
Search

Welcome to Cherokee Forum!
Welcome to Cherokee Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 06-25-2009, 08:54 AM   #1
Member
 
Akitaman's Avatar
 
Join Date: Jun 2009
Location: Knoxville, Tn.
Posts: 103

View Akitaman's Photo Album My Photos
1996 Cherokee
Default Help! Turn signals not working!

My turn signals have stopped working, not just flashing, working at all. I have checked all fuses, all the relays that I could find, and here is the weird part. The flasher relay is not in the fuse box. I should be, but it isnt. It has been this way since I got the Jeep. However, I did find what looks like a flasher relay hanging up above the brake pedal, and it was very hot to the touch. I have included a picture or 2, maybe you guys can solve the mystery of what it is. The auto parts guys here locally think it is a flasher relay, but it isnt supposed to be on this jeep, and they dont have anything to match. Heres the pics. I have no idea where to start with this.
Click the image to open in full size.
Click the image to open in full size.
Thanks for your help guys, For reference, the first pic is on a business card, and excuse the poor quality of the pics, there from my cell phone.
Akitaman is offline   Reply With Quote
Old 06-25-2009, 09:19 AM   #2
Member
 
jeepfreak82's Avatar
 
Join Date: Oct 2008
Location: North Carolina
Posts: 199

View jeepfreak82's Photo Album My Photos
1994 Cherokee
Send a message via Yahoo to jeepfreak82
Default

Cherokees don't have a relay for the lights, just the flasher. you could have a short somewhere if it is getting that hot
__________________
jeepfreak82

'99 Dodge Ram 1500
'94 Cherokee (The Donkey Slayer!!!)

'70 Commando (the continuing project...)
jeepfreak82 is offline   Reply With Quote
Old 06-25-2009, 09:44 AM   #3
Member
 
Akitaman's Avatar
 
Join Date: Jun 2009
Location: Knoxville, Tn.
Posts: 103

View Akitaman's Photo Album My Photos
1996 Cherokee
Default

Sorry, habit to call the flasher a relay. Do you recognize the mystery part? All I know is the flasher is not in the fusebox where it is supposed to be, and this thing was hanging under the dash. The turn signals WERE working, but now they not. Help!
Akitaman is offline   Reply With Quote
Old 06-25-2009, 09:50 AM   #4
CF Veteran
 
Firestorm500's Avatar
 
Join Date: Apr 2009
Posts: 2,879

View Firestorm500's Photo Album My Photos
1987, 1992, 1997 Cherokee
Default

That could be a flasher module for the 4-way emergency flashers.

Do they work?

You might also have a problem with the turn signal switch in the steering column.
Firestorm500 is online now   Reply With Quote
Old 06-25-2009, 10:01 AM   #5
Member
 
Akitaman's Avatar
 
Join Date: Jun 2009
Location: Knoxville, Tn.
Posts: 103

View Akitaman's Photo Album My Photos
1996 Cherokee
Default

You guys know of any troubleshooting tests I can perform on the switch? I hate to just replace parts. I will check on the emergency flashers. Why would the turn signals not work and the emergency flashers work? And how can the turn signals work without the flasher installed?
Akitaman is offline   Reply With Quote
Old 06-25-2009, 10:04 AM   #6
Member
 
Akitaman's Avatar
 
Join Date: Jun 2009
Location: Knoxville, Tn.
Posts: 103

View Akitaman's Photo Album My Photos
1996 Cherokee
Default

Ok, the emergency flashers DO work without the mystery part installed, so its not the emergency flasher.
Akitaman is offline   Reply With Quote
Old 06-26-2009, 03:12 PM   #7
CF Veteran
 
Firestorm500's Avatar
 
Join Date: Apr 2009
Posts: 2,879

View Firestorm500's Photo Album My Photos
1987, 1992, 1997 Cherokee
Default

Quote:
Originally Posted by Akitaman View Post
You guys know of any troubleshooting tests I can perform on the switch? I hate to just replace parts. I will check on the emergency flashers. Why would the turn signals not work and the emergency flashers work? And how can the turn signals work without the flasher installed?
Emergency flasher has to work all the bulbs, not just one side. It has a separate flasher and some different wiring.
Firestorm500 is online now   Reply With Quote
Old 08-05-2009, 01:13 PM   #8
Newbie
 
Join Date: Aug 2009
Posts: 11

View 91CherokeeWhiteLimited's Photo Album My Photos
Cherokee
Default

Did your turn signal problem get fixed ? I have the same problem, except the radio also quit working at the same time . If so, what was the fix ?

Thanks for any info

91CherokeeWhiteLimited
91CherokeeWhiteLimited is offline   Reply With Quote
Old 09-29-2009, 11:34 AM   #9
Newbie
 
Join Date: Sep 2009
Posts: 1

View kbholat's Photo Album My Photos
Cherokee
Default Exact Same Problem to the letter

Anybody got this fixed yet? I have the exact same problem with the exact same part. My emergency flashers work with or without the part installed. Turn signals worked and then they just stopped working. Please help!
kbholat is offline   Reply With Quote
Old 10-13-2009, 08:37 PM   #10
Seasoned Member
 
Join Date: Aug 2009
Location: maine
Posts: 267

View 4wheeldrivenewbie's Photo Album My Photos
1989 Cherokee
Default theres 2 flashers in my 89

one is for the 4 way and the other is for turn i swapped the 2 when my turns werent working now everything work just the turn signals blink to slow now but they work they were steady on before after i swapped the turn signals worked idk
4wheeldrivenewbie is offline   Reply With Quote
Old 10-13-2009, 11:29 PM   #11
Seasoned Member
 
Burgy's Avatar
 
Join Date: Oct 2009
Location: Indianapolis, IN
Posts: 275

View Burgy's Photo Album My Photos
2001 Cherokee
Default

Sounds like your multifunction switch (also known as the "malfunction switch") could be bad. I had a similar problem with my wrangler and that was the problem. It should be 40 bucks at your local auto store and is pretty easy to replace. It basically runs your turn signals, hazard lights, and brake lights. It corrodes very easily especially if exposed to moisture, i.e. humid environments, windows down on a dewy morning, or sinking your rig in a creek or river. If you have a Haynes Manual just follow their directions for removal. If the copper contacts are turquoise blue then its probably bad.
__________________
"The things that will destroy America are prosperity at any price, peace at any price, safety first instead of duty first, the love of soft living and the get rich quick theory of life."
~Theodore Roosevelt
Burgy is offline   Reply With Quote
Old 06-29-2010, 08:59 PM   #12
CF Veteran
 
SWC custom's Avatar
 
Join Date: Jan 2010
Location: j-burg NY
Posts: 1,115

View SWC custom's Photo Album My Photos
1996 Cherokee
Send a message via AIM to SWC custom
Exclamation same damn problem... HELP PLEASE...

any body find out what it is cause now my jeep is doing it and its pissing me off any body have any thing that could help me?? i didn't find that flasher thing yet will look for it tomorrow but everything works but my turn signals and i have no lights in the dash for them..
__________________
JEEP= JUST EMPTY EVERY POCKET
SWC custom is offline   Reply With Quote
Old 10-01-2010, 06:47 PM   #13
Newbie
 
Join Date: Oct 2010
Posts: 7

View jakesicon's Photo Album My Photos
Cherokee
Default

that mystery part is the fuse for the light around ur key switch, i was having the same problem even had the jeep dealership scratching their heads , ive been to auto parts stores n when they look mine up they have me listed as having 2 flashers/relays under the dash,, 1 for the 4-ways,, 1 for turn,, but mine doesnt have 2 it only has 1... according the the Haynes repair manual even though my jeep is a 96 model,, i have the 97 wiring under the dash...it all depends on what month of teh year ur jeep was made to determen if u have the current year or teh following years wire set-up.. in return both 4-way and thr turn signals run off of 1 relas under the dash which is the factory blue relay, i changed that one still no turn signals..changed multifunction switch in teh steering wheel still no turn signals... everything that has to do with lights work on my jeep but the turn signals... no green arrows nothing clicks... dead, no blown fuses anywhere to be found so after a month of tracing wires and not finding 1 single burnd wired,, ive come to teh conclusion that it is done with turn signals rollin down the window adn stick the arm out,, because the dealership wants 95 dollars an hour labor charge
jakesicon is offline   Reply With Quote
Old 10-04-2010, 06:57 PM   #14
Newbie
 
Join Date: Oct 2010
Posts: 1

View Tonka toy's Photo Album My Photos
Cherokee
Default re: relay or flasher burned..

it is a ry300 relay.. I got mine at bennett auto... butyou can probably get it elsewhere... what does it do? it gets Super Hot.. it burns out.. thats it's function, since nobody and their cousin seems to know what it's for..lol
oh.. and it was $18.95... anyone else has an idea what it is, or even How I can trace it BACK???.... and yes.. it is listed as a relay... as well as listing it's application in various vehicles.. but not a dmn thing about what it controls... I noticed that I have no front marker lights.. burned.. changed the bulbs, and still have nothing... didnt improve with the changing of the relay. and no burned fuses that I could find.
Tonka toy is offline   Reply With Quote
Old 10-05-2010, 08:54 AM   #15
Newbie
 
Join Date: Oct 2010
Posts: 7

View jakesicon's Photo Album My Photos
Cherokee
Default

i have the same part.. thought it was my turnsignal problem took part to the jeep dealership turns out to be nothing but a fuse for ur light around ur keyswitch and its suppose to get hot it has 2 12+ runnin to it and 1 ground if u unplug it from its own harness it doesnt do anything but kill the light around ur keyswitch thats all that part does and theres only 1 like it under the dash
jakesicon is offline   Reply With Quote
Old 10-05-2010, 08:54 AM
 
 
 
submit to reddit
Reply
Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LED turn signals chefeagles OEM Cherokee Tech 12 12-24-2010 01:00 PM
Turn Signals not working Megirprin OEM Cherokee Tech 3 06-23-2009 08:21 AM
Turn signals acting up. XCherokeeJeepX OEM Cherokee Tech 5 05-06-2009 11:03 AM
No turn signals below freezing? moses OEM Cherokee Tech 3 04-13-2009 09:43 PM
01' xj turn signals TruckD OEM Cherokee Tech 10 07-16-2008 01:13 AM


All times are GMT -5. The time now is 01:53 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.5.2
This site is in no way affiliated with Jeep or Chrysler.

Emails Backup