Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech
Register Forgot Password?
Search

Welcome to Cherokee Forum!
Welcome to Cherokee Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 03-29-2012, 02:57 PM   #1
Newbie
 
Join Date: Mar 2012
Location: south dakota
Posts: 5

View 87xjwhite's Photo Album My Photos
87 Cherokee
Default

I have and 87 xj renix 4.0 and my tcm fuse blows out from this little cruise control disengage switch and I can't figure out why.....I also don't have overdrive I think they might be related Idk....my tps is good I checked that I've checked the ground that lil switch goes to and that's good Idk what else it could be...I'm pretty familiar with the xj but I'm stumped please any help would be great!! If I disconnect it the fuse will. Hold up but my cruise control doesn't even work anyways but my biggest concern is the overdrive isn't working. When I go 75 my rpm is between 2500 and 3000 I could be crazy but I think its suppose to lock in just under 2400 Idk is there anything else I can check? ??? This whole thing started when I decreased and power washed the motor I was in a car wash so I had to drive it right away after that it wouldn't shift right and the motor wouldn't even shut off ....well I did some wire chasing replace pretty all of the yellow wire that run from the tcm to the fuse panel and got it to shut off like its supposed to now my od doesn't work and that dam switch that keeps blowing my tcm fuse it doesn't blow if its unhooked I did that now my torque converter won't lock in goin 75 Idk .......

help tcm fuse blows and no overdrive!!!!-forumrunner_20120329_145619.jpg

Last edited by 87xjwhite; 03-29-2012 at 03:25 PM.
87xjwhite is offline   Reply With Quote
Old 03-29-2012, 03:21 PM   #2
Junior Member
 
Join Date: Jan 2012
Location: Tucson
Posts: 84

View Michael-XJ87's Photo Album My Photos
1987 Cherokee
Default

I would start looking for a short in the wiring. But as mine is a 5 speed I can say where. Sorry
Michael-XJ87 is offline   Reply With Quote
Old 03-29-2012, 04:14 PM   #3
Newbie
 
Join Date: Mar 2012
Location: south dakota
Posts: 5

View 87xjwhite's Photo Album My Photos
87 Cherokee
Default

Quote:
Originally Posted by 87xjwhite
I have and 87 xj renix 4.0 and my tcm fuse blows out from this little cruise control disengage switch and I can't figure out why.....I also don't have overdrive I think they might be related Idk....my tps is good I checked that I've checked the ground that lil switch goes to and that's good Idk what else it could be...I'm pretty familiar with the xj but I'm stumped please any help would be great!! If I disconnect it the fuse will. Hold up but my cruise control doesn't even work anyways but my biggest concern is the overdrive isn't working. When I go 75 my rpm is between 2500 and 3000 I could be crazy but I think its suppose to lock in just under 2400 Idk is there anything else I can check? ??? This whole thing started when I decreased and power washed the motor I was in a car wash so I had to drive it right away after that it wouldn't shift right and the motor wouldn't even shut off ....well I did some wire chasing replace pretty all of the yellow wire that run from the tcm to the fuse panel and got it to shut off like its supposed to now my od doesn't work and that dam switch that keeps blowing my tcm fuse it doesn't blow if its unhooked I did that now my torque converter won't lock in goin 75 Idk .......
Anything will help
87xjwhite is offline   Reply With Quote
Old 07-20-2012, 05:25 AM   #4
Newbie
 
Join Date: Jul 2012
Location: washington
Posts: 5

View 93jeeper's Photo Album My Photos
1993 Cherokee
Default Over drive problems

My brother has the same problem and the same cause got back from wheeling and went to the car wash and sprayed down his engine bay went to drive home and the over drive wouldnt work, cruiser54 told me that in the older models theres ground issues. tell him your issue and he will send you the diagram.
93jeeper is offline   Reply With Quote
Old 07-20-2012, 05:46 AM   #5
Newbie
 
Join Date: Jul 2012
Location: washington
Posts: 5

View 93jeeper's Photo Album My Photos
1993 Cherokee
Default Scratch that i found out what it is!

forget what i said above, your problem is the "torque converter clutch sylinoid" this will fix your over drive problem.
93jeeper is offline   Reply With Quote
Old 07-20-2012, 05:59 AM   #6
Newbie
 
Join Date: Jul 2012
Location: washington
Posts: 5

View 93jeeper's Photo Album My Photos
1993 Cherokee
Default

And for the Transmission control module, there should be a 15A fuse, this fuse powers more than the transmission module, let me know if it pops immediatly when you put it in. that should about sum up your problems! let me know how it goes
93jeeper is offline   Reply With Quote
Old 07-20-2012, 07:22 AM   #7
::Regional Moderator::
 
cruiser54's Avatar
 
Join Date: Aug 2011
Location: Prescott, Az
Posts: 23,175

View cruiser54's Photo Album My Photos
1990 Comanche
Default

First off, how did you check your TPS?
Verify please that the fuse up under the dash by the TCM is blowing or a fuse in the fusebox.

Keep in mind that the cruise control uses the brake light switch to disengage the cruise and if the TCM sees the brakes applied, it disengages the overdrive. See the correlation there?

Also, do us all a favor and use punctuation in your posts. That texting like crap is rough on us old guys.
__________________
Cruiser's Mostly Renix Tips can be found in the pink link below:

An index to over 25 helpful write-ups is in Post #1.
http://www.cherokeeforum.com/f51/cruiser54s-mostly-renix-tips-153657/

In Handy Printable pdf format:
https://docs.google.com/file/d/0Bz4d205LaED2SUxMOGZnY3RjaEE/edit?pli=1[/COLOR]

A link to my Jeep Technical Photos:
http://www.cherokeeforum.com/g/album/1725214


Refresh*Connections*Before*Replacing*Components
cruiser54 is offline   Reply With Quote
Old 07-21-2012, 04:06 AM   #8
Newbie
 
Join Date: Jul 2012
Location: washington
Posts: 5

View 93jeeper's Photo Album My Photos
1993 Cherokee
Default cruiser54

My bad^, my friend bought a cherokee without Over Drive and replaced the transmission converter clutch sylenoid and he said that solved his problem.
93jeeper is offline   Reply With Quote
Old 07-21-2012, 04:08 AM   #9
Newbie
 
Join Date: Jul 2012
Location: washington
Posts: 5

View 93jeeper's Photo Album My Photos
1993 Cherokee
Default cruiser54

*Torque Converter Clutch Sylenoid*
93jeeper is offline   Reply With Quote
Old 07-21-2012, 04:08 AM
 
 
 
submit to reddit
Reply

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 07:33 PM.


This site is in no way affiliated with Jeep or Chrysler.

Emails Backup