Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech
Register Forgot Password?
Search


Welcome to Cherokee Forum!
Welcome to Cherokee Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 04-18-2009, 12:45 PM   #1
Newbie
 
Join Date: Apr 2009
Posts: 3

View draw's Photo Album My Photos
Cherokee
Default engine starts and dies

I have a 2001 Cherokee, 4.0 L automatic. It starts and then dies a a couple of seconds later. I removed the battery to reset howver it still does the same thing. Is it the key? Please help!
draw is offline   Reply With Quote
Old 04-18-2009, 12:48 PM   #2
Newbie
 
Join Date: Mar 2009
Posts: 12

View baker5150's Photo Album My Photos
1991 Cherokee
Default

My 91 did the same thing. I locked and then unlocked the drivers door from the outside with the key and it cured it.
baker5150 is offline   Reply With Quote
Old 04-18-2009, 12:53 PM   #3
Seasoned Member
 
mudallday's Avatar
 
Join Date: Dec 2008
Posts: 333

View mudallday's Photo Album My Photos
Cherokee
Default

i am 90% sure its the ballist resistor. next to the air box there is a ceramic deal that has two orange and black wires going into it. unplug both of the wires and put a peice of wire connecting them, bypassing the resistor. start it up and enjoy it not dying then go to the auto parts store and buy a new one i think there like 15 bucks.
mudallday is offline   Reply With Quote
Old 04-18-2009, 12:55 PM   #4
Seasoned Member
 
mudallday's Avatar
 
Join Date: Dec 2008
Posts: 333

View mudallday's Photo Album My Photos
Cherokee
Default

didnt see its on 01 but still check it could still be the problem.
mudallday is offline   Reply With Quote
Old 04-18-2009, 01:49 PM   #5
Senior Member
 
parkerbabco's Avatar
 
Join Date: Dec 2008
Location: Punxsutawney Pennsylvania
Posts: 831

View parkerbabco's Photo Album My Photos
1988 Cherokee
Send a message via AIM to parkerbabco Send a message via Skype™ to parkerbabco
Default

yeah that sounds like the ballast resistor to me too.. does it start up and then right when its about to idle it dies?
__________________
88 cherokee 4.0 I6 renix 4.5" rough country

69 GTO-400 cubic inches of pure power
parkerbabco is offline   Reply With Quote
Old 04-18-2009, 02:21 PM   #6
CF Veteran
 
ol"blue's Avatar
 
Join Date: Mar 2009
Location: Tenn. and Mich.
Posts: 28,056

View ol"blue's Photo Album My Photos
2004 Grand Cherokee
Default

I might be wrong, but if the BR was bad it wouldn't start at all, not even briefly. It would just crank with no spark.
__________________
Dan
'04 Grand Cherokee SE: 4.7L V8 w/235 HP, 4X4
'04 Saturn Vue: 3.5L V6 w/250 HP, AWD

"...Never Use Post Count as A Knowledge Gauge." Willys55

CBW Member#97

If no answer, ask here>
www.CHEROKEETECH.com


RIP Carroll Shelby
http://www.carrollshelbyfoundation.org/
http://carrollshelbyfoundation.com/



If you're not breaking parts you're not making enough power!!!
"I NEED MORE TRACTION, NOT MORE BOOST"

ol"blue is offline   Reply With Quote
Old 04-18-2009, 03:15 PM   #7
Seasoned Member
 
mudallday's Avatar
 
Join Date: Dec 2008
Posts: 333

View mudallday's Photo Album My Photos
Cherokee
Default

a bad br will cuase it to die after a few seconds. it has something to do with the voltage to the fuel pump to make it run quieter. after a few seconds it lowers the voltage.
mudallday is offline   Reply With Quote
Old 04-18-2009, 09:05 PM   #8
Newbie
 
Join Date: Apr 2009
Posts: 3

View draw's Photo Album My Photos
Cherokee
Default

I turned on and off ignition without starting engine several times which cleared off the key code light. Voila>>>the jeep started.
draw is offline   Reply With Quote
Old 04-18-2009, 11:26 PM   #9
Newbie
 
Join Date: Feb 2009
Location: Indianapolis, IN
Posts: 14

View AEGuy87's Photo Album My Photos
1996 Cherokee
Send a message via AIM to AEGuy87 Send a message via MSN to AEGuy87 Send a message via Yahoo to AEGuy87 Send a message via Skype™ to AEGuy87
Default

Does anyone know if there is a BR on a 96 Cherokee Country 4.0L I6?
AEGuy87 is offline   Reply With Quote
Old 04-18-2009, 11:26 PM
 
 
 
submit to reddit
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Starts then Dies Cookbrady845 OEM Cherokee Tech 14 01-16-2012 04:57 PM
only starts in neutral??? Laredoman2011 OEM Cherokee Tech 4 03-07-2009 03:25 PM
1990 XJ dies zjrog OEM Cherokee Tech 4 02-23-2009 11:24 PM
engine dies after 5 seconds longtravel1 OEM Cherokee Tech 6 01-20-2009 10:09 PM
dies after 30 seconds mudallday OEM Cherokee Tech 23 01-02-2009 09:48 PM

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 07:54 AM.


This site is in no way affiliated with Jeep or Chrysler.

Emails Backup