Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech
Register Forgot Password?
Search

Welcome to Cherokee Forum!
Welcome to Cherokee Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 08-07-2011, 10:02 PM   #1
Newbie
 
cherokee-90's Avatar
 
Join Date: Jun 2010
Location: BC canada
Posts: 21

View cherokee-90's Photo Album My Photos
1990 Cherokee
Default cherokee overheated, now runs rough...

I was driving down the highway yesterday and I could smell something burning, turns out it was my engine, The temp gauge didnt read it was overheating but clearly it was. I ended up pulling over when I realized the jeep had hardly any power and I was hearing a ticking sound that got quite loud. There was coolant leaking everywhere under the jeep. So i got it towed to my parents house and looked at it. Turns out a frost plug had a small hole due to corrosion so all the water in the block had drained out. I put a rubber replacement frost plug in it and topped up the coolant. So now it runs cool and all that is ok, but the jeep runs very rough, especially at low idle and it backfires when accelerating at low rpms and pulsating when not under much loud. It also barely idles. It isnt blowing any smoke and there is no water in the oil. Tommorow I'm gonna do a compression test and see how that is. Any ideas on what may be broken??? it runs strong at the higher rpms just not good at low rpms.

any help is greatly appreciated!
cherokee-90 is offline   Reply With Quote
Old 08-07-2011, 10:04 PM   #2
Newbie
 
Join Date: Oct 2010
Location: Delaware
Posts: 25

View flav's Photo Album My Photos
88,96 Cherokee
Default

Sounds like the engine is shot. The lack of power is most likely from a crack in the block somewhere from when it over heated...
__________________
84 Cj 7 4 Banger
88 Xj Waggy
96 Xj (Wife's)
flav is offline   Reply With Quote
Old 08-07-2011, 10:17 PM   #3
Junior Member
 
Jeepnick's Avatar
 
Join Date: Jan 2011
Posts: 35

View Jeepnick's Photo Album My Photos
Cherokee
Default

When coolant is very low the highest and hottest part of the motor is at risk from heat damage. This is the cylinder head. More than likely it is cracked, normally between two valves. This small type crack will prevent the cylinder from fireing properly, hence the rough running. The proper repair is a new or reconditioned head.
Jeepnick is offline   Reply With Quote
Old 08-07-2011, 11:18 PM   #4
Newbie
 
Join Date: Aug 2011
Posts: 1

View jeep_josh's Photo Album My Photos
Cherokee
Default

hi, new guy here but long time jeep owner. had similar overheating problem about a month ago and after fixing main problem also had poor running problems. no water in oil or any leaks i could find, turned out temp sending unit was out of range and causing it to run overly rich. has been running great since and not smoking or dripping anything. hope yours is this simple too.
jeep_josh is offline   Reply With Quote
Old 08-07-2011, 11:32 PM   #5
Member
 
Johnny9Inches's Avatar
 
Join Date: Jun 2011
Location: Salamanca NY
Posts: 164

View Johnny9Inches's Photo Album My Photos
2000 Cherokee
Default

Is your coolant disappearing but not showing up in your oil? Mine was small crack it was burning off before it got to serious, also check your head gasket, dry head at high temp tend to cook these.

Does your exhaust smell sweet?
Pull your plugs, are they really clean?

If yes to either of these its either the head or head gasket, you can see it in the head by pulling the valve cover, chocolate milk color under there at all SWAP IT

Head gasket, is a bear to get to, but a good learning experience. If you have to swap the head, PM me I can help you threw some of it (as i just did mine)
__________________
Cold Air Intake, Hood Vents

U.S. Army Paratrooper Combat Veteran, 13F - Forward Observer 82nd Airborne, 2000-2009

Hood Vents http://www.cherokeeforum.com/f58/hoo...2/#post1134701
My fail injector install (LOL)http://www.cherokeeforum.com/f67/neo...7/#post1146383
Johnny9Inches is offline   Reply With Quote
Old 08-10-2011, 11:04 PM   #6
Newbie
 
cherokee-90's Avatar
 
Join Date: Jun 2010
Location: BC canada
Posts: 21

View cherokee-90's Photo Album My Photos
1990 Cherokee
Default

Well I got lucky. The spark plugs got very very hot and were in terrible shape... I changed them out along with a new cap and rotor. Jeep runs like a top again!!

also I we did a compression test and all cylinders were 150, except the number 3 cylinder was 140. but that is really good.

phewww!

Thanks for the replies,
cherokee-90 is offline   Reply With Quote
Old 08-10-2011, 11:04 PM
 
 
 
submit to reddit
Reply
Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
1995 Jeep Cherokee - Runs rough at 2000 RPM im1986 Grand Cherokee Tech 16 08-11-2011 08:03 AM
98 Jeep Cherokee 4.0 runs rough after tune up Tiny1970 OEM Cherokee Tech 2 08-01-2011 06:43 PM
Cherokee run rough after 10 minutes - wait 5 and then runs good again. RogerJW OEM Cherokee Tech 1 05-17-2011 01:04 PM
93 Cherokee runs really rough now. TheDale OEM Cherokee Tech 9 01-19-2011 06:40 PM
99 Cherokee runs rough/misses... koocher OEM Cherokee Tech 4 02-15-2010 02:56 PM


All times are GMT -5. The time now is 06:49 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site is in no way affiliated with Jeep or Chrysler.

Emails Backup