Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech
Register Forgot Password?
Search

Welcome to Cherokee Forum!
Welcome to Cherokee Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 04-02-2010, 11:56 AM   #1
Junior Member
 
Join Date: Oct 2009
Location: Newfoundland
Posts: 46

View SloPok's Photo Album My Photos
1997 Cherokee
Question Black Smoke and Running Rough...

I have a '97 XJ Country with the 4.0L, with a new cat, muffler and front pipe. the O2 sensor behind the cat is new but the one in the front pipe is off the old front pipe. For some reason the engine is running rough when it is warmed up and leaves a soot spot in the driveway/road, leaves a black cloud when i hammer the peddel and burns gas something ferice. Can anyone tell me what i may try/ what will work to fix this... i love my jeep and i am getting ready to burn it!
SloPok is offline   Reply With Quote
Old 04-02-2010, 12:03 PM   #2
CF Veteran
 
fishtaconc's Avatar
 
Join Date: Mar 2009
Location: Watha,NC
Posts: 1,208

View fishtaconc's Photo Album My Photos
Jeepless at the moment
Default

Black smoke= rich condition hence poor fuel economy, O2 sensor is good place to start. the downstream O2 tells the ECM that the cat is doing its job IIRC. Replace front O2, if that doesnt help look into a leaky injector.
fishtaconc is offline   Reply With Quote
Old 04-02-2010, 12:58 PM   #3
CF Veteran
 
offroadnut36's Avatar
 
Join Date: Aug 2008
Location: Hollidaysburg, PA
Posts: 5,603

View offroadnut36's Photo Album My Photos
1990 Cherokee
Send a message via AIM to offroadnut36 Send a message via Yahoo to offroadnut36
Default

Quote:
Originally Posted by fishtaconc View Post
Black smoke= rich condition hence poor fuel economy, O2 sensor is good place to start. the downstream O2 tells the ECM that the cat is doing its job IIRC. Replace front O2, if that doesnt help look into a leaky injector.
x2 On the o2 sensors. The rear really does nothing except make sure the cat. is doing its job.
__________________
J**P #1

90 xj laredo - Grant steering wheel, 4.5" RE Extreme Duty Long Arm kit, 33x12.5r15 Kumho Road Venture M/Ts, 15x8 Cragar D-windows, Custom JCH Front bumper. Check it out- my build Project Ghostrider
Quote:
Originally Posted by hussler737
Well cause.... Barbie drives a Wrangler. I can't be associated with that bimbo.
"No mud permitted on vehicles, Please remove mud from parking space"
Oh really? Do you have a shovel?
"No"
Neither do I!
offroadnut36 is offline   Reply With Quote
Old 04-02-2010, 04:04 PM   #4
CF Veteran
 
fishtaconc's Avatar
 
Join Date: Mar 2009
Location: Watha,NC
Posts: 1,208

View fishtaconc's Photo Album My Photos
Jeepless at the moment
Default

thats what i thought ive heard of people knocking them off wheeling with no adverse effects
fishtaconc is offline   Reply With Quote
Old 04-17-2010, 11:44 PM   #5
Newbie
 
Join Date: Mar 2010
Posts: 13

View Tactical's Photo Album My Photos
Cherokee
Default

Hey i have the same problem with my 88' 4.0, replaced the O2 and it doesn't leave black stuff on the garage floor anymore but it idles high, round 1500 rpm, and chokes out and leaves a black cloud when i mash on the exhaust... Leaky fuel injector or something else?
Tactical is offline   Reply With Quote
Old 04-18-2010, 12:01 AM   #6
Member
 
Heinz57Fox's Avatar
 
Join Date: Feb 2010
Location: Michigan
Posts: 129

View Heinz57Fox's Photo Album My Photos
1996 Cherokee
Default

C'mon everyone say it with me SeaFoam!! I have a 96 and that stuff works wonders. Although I am a newb at this stuff I would imagine that if black stuff is coming out it is probably building up carbon whereever it is coming out of. and I can almost guarantee that it will help. Good Luck!
Heinz57Fox is offline   Reply With Quote
Old 04-18-2010, 10:47 PM   #7
Newbie
 
Join Date: Mar 2010
Posts: 13

View Tactical's Photo Album My Photos
Cherokee
Default

cool alright i used that "guaranteed pass" additive thinking it would work, maybe that's the cause of the smoke?? Would it be ok to use Seafoam after i used that stuff? Seems like Seafoam is a wonder drug for jeep, well from what I've read anyways!
Tactical is offline   Reply With Quote
Old 07-28-2010, 07:21 PM   #8
Newbie
 
Join Date: Jul 2010
Posts: 1

View ttay32's Photo Album My Photos
Cherokee
Default burning black smoke and running like hell

my 99 grand cherokee is burning black smoke when i accelerate and jerks when i drive sometimes. when im going up hill i feel like im the slowest person on earth because my jeep just doesnt wanna go. whats wrong?!?!?!
ttay32 is offline   Reply With Quote
Old 07-30-2010, 09:26 PM   #9
Member
 
Heinz57Fox's Avatar
 
Join Date: Feb 2010
Location: Michigan
Posts: 129

View Heinz57Fox's Photo Album My Photos
1996 Cherokee
Default

Quote:
Originally Posted by ttay32 View Post
my 99 grand cherokee is burning black smoke when i accelerate and jerks when i drive sometimes. when im going up hill i feel like im the slowest person on earth because my jeep just doesnt wanna go. whats wrong?!?!?!
when is the last time you changed the transfer case fluid? also the black smoke could be a bad oil leak from your intake valve gasket. don't quote me on it but those are two things I would check out.
Heinz57Fox is offline   Reply With Quote
Old 07-30-2010, 09:31 PM   #10
CF Veteran
 
89Laredo's Avatar
 
Join Date: May 2009
Location: Michigan, 48657
Posts: 9,984

View 89Laredo's Photo Album My Photos
1989 Cherokee
Default

^ not trying to be a *****, but start your own thread here ----->http://www.cherokeeforum.com/newthre...=newthread&f=5
Not only will you get more help, you wont "crap up" this thread with two different problems/vehicles.


PO, I would change your first Oxygen sensor and look for a vacuum leak. If oxygen sensor doesnt do it, and no vacuum leaks, you may have a bad MAP sensor.
__________________
I no longer visit here, messages will not be responded to.
Get ahold of me on XJtalk, NAXJA *89Laredo*, Youtube, GL4x4, or My Wordpress Site
89Laredo is offline   Reply With Quote
Old 08-09-2011, 10:32 AM   #11
Newbie
 
Join Date: Feb 2011
Location: west TN
Posts: 3

View jamoore38344's Photo Album My Photos
1999 Cherokee
Default help me too

im having the same problem. burning rich, heavy black smoke, slow going up hills and accelerating. and its like its not getting constant steady feul flow when running. which o2 sensor do I replace first??
jamoore38344 is offline   Reply With Quote
Old 08-09-2011, 08:46 PM   #12
CF Veteran
 
Join Date: Mar 2010
Location: Elizabethtown, pa
Posts: 1,028

View tiwvr1's Photo Album My Photos
1994 Cherokee
Default

Everyone having this problem, replace THE FRONT 02, this has been covered a million times, it is a great place to start. SEARCH!
tiwvr1 is offline   Reply With Quote
Old 08-09-2011, 09:04 PM   #13
Junior Member
 
briansgarage's Avatar
 
Join Date: Jul 2011
Posts: 90

View briansgarage's Photo Album My Photos
Cherokee
Default

I have the same exact issues as the OP on my 99 sport.
Soot spot in driveway, smoke when I mash it, running rough and chugging..
Everything on the internet points to the O2.. Will be replacing mine this weekend. Let ya know if it solves the problem. I'm almost 80% certain it will though.
Don't let me forget and I'll post back here for anybody wanting to know.
briansgarage is offline   Reply With Quote
Old 08-29-2011, 09:56 AM   #14
Junior Member
 
briansgarage's Avatar
 
Join Date: Jul 2011
Posts: 90

View briansgarage's Photo Album My Photos
Cherokee
Default

For anyone interested, replaced the upstream O2 this morning, and took it on a test drive in the country.Floored it a few times to blow the soot out of the pipe. 1st time was dark black, second was 50% less, third time was almost gone. After that, no more black smoke, mashed it down a bunch of times, and no more smoke. No soot, no nothing, and better horse power. It's running like a champ now.. Drove 50 miles, from 65mph to in town 20mph stop and go..

So there ya go.. Replace the O2..
briansgarage is offline   Reply With Quote
Old 08-29-2011, 10:17 AM   #15
CF Veteran
 
Agent_Oragnge's Avatar
 
Join Date: Dec 2010
Location: Finger Lakes Region NY
Posts: 1,234

View Agent_Oragnge's Photo Album My Photos
1990 Cherokee
Default

That pesk old O2 sensor. gets yah every time.
__________________
You're Really messing with my Zen thing here, Man!
Agent_Oragnge is offline   Reply With Quote
Old 08-29-2011, 10:17 AM
 
 
 
submit to reddit
Reply
Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough Idle/White Smoke Deathwagon OEM Cherokee Tech 7 03-17-2010 09:53 PM
Black door handles running down white paint 2000sport OEM Cherokee Tech 13 12-11-2009 10:39 AM
running rough jeepjeep90 OEM Cherokee Tech 0 08-02-2009 11:25 PM
Running Rough forbyer OEM Cherokee Tech 2 06-13-2009 01:46 PM
96 GC 4.0l running rough JayDee Grand Cherokee Tech 10 06-07-2009 08:19 AM


All times are GMT -5. The time now is 11:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site is in no way affiliated with Jeep or Chrysler.

Emails Backup