Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech
Register Forgot Password?
Search

Welcome to Cherokee Forum!
Welcome to Cherokee Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 09-04-2011, 05:40 PM   #1
Member
 
Join Date: Apr 2011
Posts: 206

View AKinHI's Photo Album My Photos
Cherokee
Default

I've went through two alternators and my jeep still won't charge the battery.

First the alternator died a few months ago, replaced it and no issues since until last week. Alternator died again, took it in and got a new one because of the warranty and it was bad. I'm
About to take in my third one that I though was working to have it tested but wanted some opinions first.

Sometimes I'll be driving and my battery will be reading at around 14v but most of the time the gauge is bottomed out at 9v and the battery isn't being charged. While the gauge was reading 9v I got out and hooked up my multimeter to the battery and it read 11.8v.

TL: DR;

Charging system works intermittently.

Anything that could cause this besides just bad alternators, I'm tired of swapping it out.

Last edited by AKinHI; 09-04-2011 at 05:44 PM.
AKinHI is offline   Reply With Quote
Old 09-04-2011, 05:50 PM   #2
Senior Member
 
sam24th's Avatar
 
Join Date: Aug 2010
Location: NC/SC
Posts: 982

View sam24th's Photo Album My Photos
1990 Cherokee
Send a message via AIM to sam24th
Default

Check your battery connectors and make sure your charge wire from the alt is hooked to the batt. I left it off my firebird one time while doing an engine swap and I couldnt figure out the problem. Either that or the alternators you are buying are just no good. Some times those parts they sell at autozone and advance arent any good. I went through 3 fuel pumps before going back to OEM once. So dont be surprised if the alts are just bad.
__________________
Need custom Decals? PM me

NAXJA Member
http://anarchyexpeditions.blogspot.com/
sam24th is offline   Reply With Quote
Old 09-04-2011, 07:33 PM   #3
Member
 
Join Date: Apr 2011
Posts: 206

View AKinHI's Photo Album My Photos
Cherokee
Default

All the contacts are clean, just had alternator tested and it's good. I bought some contact cleaner and dielectric grease and am planning to get everything with some grease.

What's next to check? I had ordered an ECU because that's where the voltage regulator is located but then was told that the voltage regulator will not go bad since it is part of the ECU... Is this true or do I need to go pick one up?
AKinHI is offline   Reply With Quote
Old 09-04-2011, 09:27 PM   #4
Member
 
Join Date: Apr 2011
Posts: 206

View AKinHI's Photo Album My Photos
Cherokee
Default

http://cgi.ebay.com/ebaymotors/Jeep-...-/130537743501

Any idea on a part number or actual name of this harness? I found my charging issue, one of the contacts was nearly busted off and when I bolted it back onto the alt. with a healthy dose of dielectric it broke off. Now I'm hunting down this harness lol
Attached Thumbnails
Battery wont charge-image-3150185639.jpg  
AKinHI is offline   Reply With Quote
Old 09-04-2011, 10:02 PM   #5
Member
 
Join Date: Apr 2011
Posts: 206

View AKinHI's Photo Album My Photos
Cherokee
Default

Found the answer, that little black block is nothing more than an idiot proofing so you don't mix up wires on the alt. Now that mine is broke, any idea which wire goes to which tab? I need to bypass and would prefer not to guess and check with my electrical system lol
AKinHI is offline   Reply With Quote
Old 09-05-2011, 12:08 AM   #6
Seasoned Member
 
Mendax13's Avatar
 
Join Date: Jul 2011
Location: New Cumberland, PA
Posts: 488

View Mendax13's Photo Album My Photos
1995 Cherokee
Default

new battery? if not perhaps your battery is shorting out. ive had it happen and when its running it was fine but turn it off and try to turn it back on and it wont budge. of course it could happen to a new battery, just less likely probably
__________________
Mendax13 is offline   Reply With Quote
Old 09-05-2011, 12:13 AM   #7
Member
 
Join Date: Apr 2011
Posts: 206

View AKinHI's Photo Album My Photos
Cherokee
Default

Gotta love electrical problems. New ends, healthy doses of dielectric grease and countless hours later my alternator is charging again
AKinHI is offline   Reply With Quote
Old 09-05-2011, 12:13 AM
 
 
 
submit to reddit
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dumb question, trying to charge battery Fsher21 OEM Cherokee Tech 39 02-24-2011 12:18 PM
94 jeep wont charge please help! CherokeeT Grand Cherokee Tech 1 01-30-2011 07:24 PM
new alternator wont charge?! 3inchlift OEM Cherokee Tech 14 01-16-2011 09:10 AM
battery looses charge after jump claygrassmann OEM Cherokee Tech 2 05-19-2010 02:10 AM
Slowly lost charge, now the battery is dead. Bryce OEM Cherokee Tech 12 05-31-2009 10:02 AM

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 04:56 PM.


This site is in no way affiliated with Jeep or Chrysler.

Emails Backup