Battery light coming on and off.slow acceleration. - Jeep Cherokee Forum
Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech
Log In 
Search


Battery light coming on and off.slow acceleration.

Reply
 
 
 
 
Thread Tools Search this Thread
Old 07-07-2010, 05:12 PM   #1
Newbie
 
Join Date: May 2010
Location: US
Posts: 26

View Faraonico's Photo Album My Photos
1999 Cherokee
Unhappy Battery light coming on and off.slow acceleration.

I have a Cherokee 1999 2wd Automatic.
Last monday while driving in the night the gauges started acting weird,fuel and mph gauge going to 0 randomly. Then the lights started dimming and the battery light came up. The Cherokee seemed to be losing power and only runs in flat places. Little slopes are a no-go for it.After that it takes around for tries to start and the symptoms return.
The check engine codes are P0340 -CAMSHAFT ( Part I bought and replaced) and ignition malfuction. We checked the ignition and the parts and wire seem not damaged. Crankshaft sensor was clean and verified. No wet sparks plugs,all wires seem ok. What could be happening?? Mechanic told me it could be either Bad Ignition (like the code says) or last Bad Computer??

Any help or thoughts ? Thanks guys! (first time posting!)
Faraonico is offline   Reply With Quote
Join Cherokee Forum

Join CherokeeForum.com Today - It's Totally Free!

Do you love your Jeep? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Jeep Fans to meet online.
Once you join you'll be able to post messages, upload pictures of your jeep, and have a great time with other Jeep Cherokee fans.. Whether your an old timer or just bought your Jeep you'll find that CherokeeForum.com is a great community to join. Best of all it's totally free!

Join CherokeeForum.com Today! - Click Here JOIN FOR FREE


-->
Old 07-07-2010, 05:16 PM   #2
Seasoned Member
 
ColoradoXJ88's Avatar
 
Join Date: Sep 2009
Posts: 361

View ColoradoXJ88's Photo Album My Photos
1988 Cherokee
Default

Only thing I can think of, as i'm not much of an electrical guy, is to make sure all of your grounds are good.
ColoradoXJ88 is offline   Reply With Quote
Old 07-07-2010, 05:31 PM   #3
Newbie
 
Join Date: May 2010
Location: US
Posts: 26

View Faraonico's Photo Album My Photos
1999 Cherokee
Default

The last repair done before the problem was replacing the Air Conditioner Evaporator . 2 days later the rough starting and cranking began,and then it became the already mentioned electrical problem. Already spent $97 on a New Battery and $58 on the Ignition Pick-up coil.
Faraonico is offline   Reply With Quote
 
 
 
Reply


Tags
battery, cherokee, computer, ignition
Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 08:14 AM.


This site is in no way affiliated with Jeep or Chrysler.

Emails Backup