Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech
Register Forgot Password?
Register Photos FAQ Members List Social Groups Search Today's Posts Mark Forums Read GarageVendor DirectoryvBLive
Search

Welcome to Cherokee Forum!
Welcome to Cherokee Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 07-07-2010, 05:12 PM   #1
Newbie
 
Join Date: May 2010
Location: US
Posts: 26

View Faraonico's Photo Album My Photos
1999 Cherokee
Unhappy Battery light coming on and off.slow acceleration.

I have a Cherokee 1999 2wd Automatic.
Last monday while driving in the night the gauges started acting weird,fuel and mph gauge going to 0 randomly. Then the lights started dimming and the battery light came up. The Cherokee seemed to be losing power and only runs in flat places. Little slopes are a no-go for it.After that it takes around for tries to start and the symptoms return.
The check engine codes are P0340 -CAMSHAFT ( Part I bought and replaced) and ignition malfuction. We checked the ignition and the parts and wire seem not damaged. Crankshaft sensor was clean and verified. No wet sparks plugs,all wires seem ok. What could be happening?? Mechanic told me it could be either Bad Ignition (like the code says) or last Bad Computer??

Any help or thoughts ? Thanks guys! (first time posting!)
Faraonico is offline   Reply With Quote
Old 07-07-2010, 05:16 PM   #2
Seasoned Member
 
ColoradoXJ88's Avatar
 
Join Date: Sep 2009
Posts: 361

View ColoradoXJ88's Photo Album My Photos
1988 Cherokee
Default

Only thing I can think of, as i'm not much of an electrical guy, is to make sure all of your grounds are good.
ColoradoXJ88 is offline   Reply With Quote
Old 07-07-2010, 05:31 PM   #3
Newbie
 
Join Date: May 2010
Location: US
Posts: 26

View Faraonico's Photo Album My Photos
1999 Cherokee
Default

The last repair done before the problem was replacing the Air Conditioner Evaporator . 2 days later the rough starting and cranking began,and then it became the already mentioned electrical problem. Already spent $97 on a New Battery and $58 on the Ignition Pick-up coil.
Faraonico is offline   Reply With Quote
Old 07-07-2010, 05:31 PM
 
 
 
submit to reddit
Reply

Tags
battery, cherokee, computer, ignition
Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SLOW acceleration in drive... bigwheel15 OEM Cherokee Tech 7 06-14-2010 09:38 PM
88 cherokee aw4, slow acceleration zdav28 OEM Cherokee Tech 0 02-08-2010 01:41 PM
Will extra light drain battery buck-jeep69 OEM Cherokee Tech 1 12-09-2009 09:07 PM
Check Guages Light and Low Battery??? MistressLaLa OEM Cherokee Tech 7 06-04-2009 04:32 PM
battery light problems elzey829 OEM Cherokee Tech 1 09-22-2008 01:50 PM


All times are GMT -5. The time now is 02:25 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.5.2
This site is in no way affiliated with Jeep or Chrysler.

Emails Backup