Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech
Register Forgot Password?
Search

Welcome to Cherokee Forum!
Welcome to Cherokee Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 09-27-2010, 04:04 PM   #1
Newbie
 
Join Date: Sep 2010
Posts: 4

View Ejboyce1313's Photo Album My Photos
Cherokee
Default 98 Sport Loss of power/power surge problems

i have a 98 XJ sport. I've been having an annoying loss of power when i press the gas pedal followed by a sudden surge of power sometimes....if i punch it it respondes better but... from a stop boggs alot doesn't stall but really boggy and i can here what sounds like a pop or loud tap from up front almost like a backfire...someone told me that it may have been my cat converter since it was already rattlin it may have been clogged. changed it and exhaust from there back ...same problem occuring...ne incite from u xj guys would be appriciated.....i love both my XJs.. b ut im new to workin around em bought both mine this year...thanks for the help
Ejboyce1313 is offline   Reply With Quote
Old 12-15-2010, 08:29 AM   #2
Newbie
 
Join Date: Aug 2010
Location: Northeast Ohio
Posts: 3

View milliontom's Photo Album My Photos
98 Cherokee
Default

I'm having the exact same problem with my 98 cherokee. Mine will fall to 100-200 rpms when I stop at lights and sometimes stall, soymetimes surge back up to normal idle. To get it to move after stopping, I basically have to floor it until I get to around 40mph or it will jerk and surge me all over the place! I know exactly what you mean with the popping sound but sometimes mine will slam and start moving normally after as if I revved it up and dropped it into gear. I've replaced the crank shaft sensor, map sensor and idle air control valve and none have helped. I also had the fuel pressure checked which was normal. Did you find a solution to your problem? I've read something about backing screws out on the ECM and will try that tonight to see if that works.
milliontom is offline   Reply With Quote
Old 12-15-2010, 12:20 PM   #3
Member
 
Join Date: Dec 2010
Location: South Georgia
Posts: 224

View Jeepability's Photo Album My Photos
1998 Cherokee
Default

let me know what happens when you back the screws out. i have a 98 sport with 170 on the dash. mine hasnt done this yet but i wanna be prepared
Jeepability is offline   Reply With Quote
Old 12-15-2010, 12:46 PM   #4
Member
 
Topjimmyk's Avatar
 
Join Date: Mar 2010
Location: Lapeer, MI
Posts: 145

View Topjimmyk's Photo Album My Photos
1998 Cherokee
Default

my 98 does the same thing but only after start up. But after it runs normal. I had a fuse blown for the o2 sensors that i just replaced so, ill see if that helps but you guys problem seems worse.
__________________

Just
Empty
Every
Pocket
Topjimmyk is offline   Reply With Quote
Old 12-20-2010, 11:20 AM   #5
Newbie
 
Join Date: Aug 2010
Location: Northeast Ohio
Posts: 3

View milliontom's Photo Album My Photos
98 Cherokee
Default

Well no luck on the screw backing trick. It ran fantastic for about ten minutes right after I did it, got my hopes up them crushed them just as fast. I'm at a loss...
milliontom is offline   Reply With Quote
Old 12-20-2010, 05:10 PM   #6
Member
 
black_police_xj's Avatar
 
Join Date: Dec 2010
Location: Ionia, MI
Posts: 110

View black_police_xj's Photo Album My Photos
1997 Cherokee
Send a message via Skype™ to black_police_xj
Default

guy's this is not helping me at all! sounds like I have the same problem. ran fine yesterday, replaced the Holy muffler with a glass-pack. wasn't till after i had it installed that i noticed the rattle from the cat. mines also sucking air like a super vacuum, spits and sputters idles like crap, but then it will rev up all by itself for a few seconds and then run fine for a while! What the *&^%????
__________________
_______.00000.
//_|__l__,\__\,__
l_--\__\☆_l----[]llllll[]
~~~~~~~~~~~~~~
black_police_xj is offline   Reply With Quote
Old 12-20-2010, 06:54 PM   #7
CF Veteran
 
Join Date: Nov 2010
Location: In the middle of Minnesota!
Posts: 4,718

View tjwalker's Photo Album My Photos
1999 Cherokee
Default

1. Ensure tuneup hardware is fresh. That includes fresh spark plugs (gapped to .035) new plug wires, distributor cap and rotor.

2. Any check engine light EVER? Pull stored codes for clues.

3. Checking fuel pressure for your symptoms is easy and something that should be ruled in or out early in the troubleshooting process. If this were in my garage, I would have a gauge on it pronto. For a 98, you should have 49 psi at idle, plus or minus 5 psi.

4. The throttle position sensor is responsible for a smooth "tip-in" of throttle. It can be tested with a manual with the procedure and a meter (analog best).

Good luck!
__________________
Without data, all you have is an OPINION!

Past Jeeps: '49 Willys, '81 Scrambler, '88 Comanche

Current Jeep: 1999 XJ Sport, bone stock, daily driver.

I work on Jeeps!!
tjwalker is online now   Reply With Quote
Old 12-21-2010, 05:04 PM   #8
Member
 
black_police_xj's Avatar
 
Join Date: Dec 2010
Location: Ionia, MI
Posts: 110

View black_police_xj's Photo Album My Photos
1997 Cherokee
Send a message via Skype™ to black_police_xj
Default

it stopped! I'm thinking that the catalytic converter is breaking up(probably cause I was smacking it with a hammer trying to get the old muffler off) and clogging the exhaust creating tons of back pressure???
__________________
_______.00000.
//_|__l__,\__\,__
l_--\__\☆_l----[]llllll[]
~~~~~~~~~~~~~~
black_police_xj is offline   Reply With Quote
Old 12-21-2010, 05:25 PM   #9
CF Veteran
 
Join Date: Nov 2010
Location: In the middle of Minnesota!
Posts: 4,718

View tjwalker's Photo Album My Photos
1999 Cherokee
Default

Quote:
Originally Posted by black_police_xj View Post
it stopped! I'm thinking that the catalytic converter is breaking up(probably cause I was smacking it with a hammer trying to get the old muffler off) and clogging the exhaust creating tons of back pressure???
You can test for exhaust restriction (clogged cat) quite easily with a vacuum gauge and the ability to use it. SEARCH for the specifics.
__________________
Without data, all you have is an OPINION!

Past Jeeps: '49 Willys, '81 Scrambler, '88 Comanche

Current Jeep: 1999 XJ Sport, bone stock, daily driver.

I work on Jeeps!!
tjwalker is online now   Reply With Quote
Old 12-22-2010, 04:24 PM   #10
Newbie
 
Join Date: Aug 2010
Location: Northeast Ohio
Posts: 3

View milliontom's Photo Album My Photos
98 Cherokee
Default

@tjwalker

1. Tune-up hardware looked fairly new when I got jeep 5 months ago.

2. Check engine light IS on...but there is no power going to the plug that reads codes therefore no code clues.

3. Fuel pressure was 50 psi

4. New TPS

@black_police_xj

Mine sucks air like a jet engine too, sometimes, but I have no catalytic converter installed (just straight pipe where it once was)
milliontom is offline   Reply With Quote
Old 04-30-2011, 05:52 PM   #11
Junior Member
 
badger7182's Avatar
 
Join Date: Jan 2011
Location: Converse, TX
Posts: 83

View badger7182's Photo Album My Photos
1999 Cherokee
Default

I just post a new thread, but mine seems like it is just like this - I have done all the things you guys have done, and no luck - I actually kjust replaced both exhaust O2 sensors and got rid of the code, and that is when my issues started.
__________________
'99 XJ, CAI, high flow fuel inj and bored out TB, 8" Iron Rock Off Road lift and 35" KM2s.
badger7182 is offline   Reply With Quote
Old 11-18-2013, 12:23 AM   #12
Newbie
 
Join Date: Feb 2013
Location: Ohio
Posts: 10

View aaron99xj's Photo Album My Photos
1999 Cherokee
Default

Quote:
Originally Posted by black_police_xj View Post
guy's this is not helping me at all! sounds like I have the same problem. ran fine yesterday, replaced the Holy muffler with a glass-pack. wasn't till after i had it installed that i noticed the rattle from the cat. mines also sucking air like a super vacuum, spits and sputters idles like crap, but then it will rev up all by itself for a few seconds and then run fine for a while! What the *&^%????
My precious xj started doing this too, I have no cat w/ recent new flowmaster ex., plugs wires cap and coil are all new Accel, new BBK throttle body, cold air intake, deleted O2 sensors (the only code I'm getting btw), 4 hole injectors, I have put about 4,000 miles on her after the mods before I started having trouble and it has only done it a few times, the last time I took her out of the toy barn she ran fine (made a nice white cloud w/o brake torqueing) oh yeah fuel pressure was good too, if any1 figures this out please contact me and vice versa, just check out the picks and you can tell this rig is my baby most of the time I'm
but sometimes she makes me
aaron99xj is offline   Reply With Quote
Old 11-18-2013, 12:23 AM
 
 
 
submit to reddit
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical Problems... Power windows, power locks, power mirrors, Gauge Lights xj91 OEM Cherokee Tech 3 06-03-2010 08:06 PM
power loss magub OEM Cherokee Tech 6 03-29-2010 01:00 PM
loss of power big daddy b Grand Cherokee Tech 1 03-07-2010 02:24 PM
loss of power fix MoparAinge4.0 OEM Cherokee Tech 0 03-01-2010 03:45 PM
Power Loss 94kee OEM Cherokee Tech 0 10-31-2009 11:40 AM

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 07:00 PM.


This site is in no way affiliated with Jeep or Chrysler.

Emails Backup