Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech
Register Forgot Password?
Search

Welcome to Cherokee Forum!
Welcome to Cherokee Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 05-25-2009, 08:02 PM   #1
Newbie
 
Join Date: May 2009
Posts: 3

View Waveraider's Photo Album My Photos
Cherokee
Default '98 Cherokee 4.0 running rough

Hello everyone. This is my first post. I have a '98 Cheokee w/4.0 that intermittintly runs rough. Lately it has been missing out in reverse, like it is hitting a rev limiter. The other day, I had a hard time starting it, but eventually got it going. They hooked up a meter at Auto Zone and said to replace the MAP sensor and coil. I also performer a tune up. The problem is still there. Any ideas? Thank you in advance.
Waveraider is offline   Reply With Quote
Old 05-25-2009, 09:43 PM   #2
Seasoned Member
 
blkcherokee's Avatar
 
Join Date: Mar 2009
Location: Space Coast, Fl
Posts: 308

View blkcherokee's Photo Album My Photos
1998 Cherokee
Send a message via AIM to blkcherokee
Default

does it do it when you touch the stering wheel an has your horn started to act up
blkcherokee is offline   Reply With Quote
Old 05-26-2009, 12:00 AM   #3
Newbie
 
Join Date: May 2009
Posts: 12

View pittbulldracer's Photo Album My Photos
Cherokee
Default

Hay mine was doing this before it quit running Now no horn.
pittbulldracer is offline   Reply With Quote
Old 05-26-2009, 03:38 AM   #4
Newbie
 
Join Date: Mar 2009
Posts: 4

View JustSomeGuy's Photo Album My Photos
1998 Cherokee
Default possible

i have the same jeep and also near the same issue with the engine. i traced my down during a tune-up. mine turned out to be the #3 spark plug the Porcelain had cracked and was messing everything up. just a thought not sure if you checked that in the tune up.
JustSomeGuy is offline   Reply With Quote
Old 05-26-2009, 06:37 AM   #5
Newbie
 
Join Date: May 2009
Posts: 3

View Waveraider's Photo Album My Photos
Cherokee
Default

No horn problem. I did a tune up already and still have the same problem.
Waveraider is offline   Reply With Quote
Old 05-28-2009, 04:07 AM   #6
Junior Member
 
coldfusion73's Avatar
 
Join Date: May 2009
Location: Northern Ontario, Canada
Posts: 35

View coldfusion73's Photo Album My Photos
1994 Grand Cherokee
Send a message via MSN to coldfusion73
Default

my 98 cherokee was running rough and had trouble starting after an oil change...I pulled off some of the electrical plugs that go into the intake manifold and plugged them back in and it ran normal again...worked for mine...yours might be something different but it never hurts to try
coldfusion73 is offline   Reply With Quote
Old 05-28-2009, 09:23 AM   #7
Member
 
Join Date: Apr 2009
Location: South Jersey
Posts: 150

View loligator's Photo Album My Photos
1995 Cherokee
Default

did you replace the oxygen sensor during the tune up or recently?
loligator is offline   Reply With Quote
Old 06-01-2009, 07:40 PM   #8
Newbie
 
Join Date: May 2009
Posts: 3

View Waveraider's Photo Album My Photos
Cherokee
Default Long story short...

Quote:
Originally Posted by loligator View Post
did you replace the oxygen sensor during the tune up or recently?
Yes. Actually some Meth Addict stole the cat off the exhaust and I ran with a through pipe for a few thousand miles. Since, I've replaced the cat, O2 sensor, and MAP sensor. It seems to be doing a little better now, but not quite there.
Waveraider is offline   Reply With Quote
Old 06-01-2009, 07:40 PM
 
 
 
submit to reddit
Reply
Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
92 Jeep Cherokee Running Rough! SnowMachine OEM Cherokee Tech 4 12-22-2009 04:50 PM
Running Rough forbyer OEM Cherokee Tech 2 06-13-2009 01:46 PM
Fuel Filter Replacement/Rough Running spencersausser OEM Cherokee Tech 8 10-22-2008 09:01 AM
motor running rough? kmanxj5050 OEM Cherokee Tech 9 05-12-2008 09:35 PM
Jeep Cherokee Cuts off after running nelsonkn Grand Cherokee Tech 9 03-15-2008 01:06 AM


All times are GMT -5. The time now is 03:05 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site is in no way affiliated with Jeep or Chrysler.

Emails Backup