Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech
Register Forgot Password?
Search

Welcome to Cherokee Forum!
Welcome to Cherokee Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 06-14-2013, 09:37 PM   #1
Member
 
Join Date: Sep 2009
Posts: 144

View seven's Photo Album My Photos
1990 , 1997 ,1997, 2000 Cherokee
Default 97 cherokee sport 4.0 auto shift problems??

Hi ,Bill here trying to figure out what is happening with the shift on this 97 sport..4.0 auto., I hit the pedal from a stand still and it feels like it is under-powered and very unresponsive ? Almost like it is taking off in a higher gear?? If you drive slow it will shift on its own (1,2,3,od) but if you hit the pedal and drop it into passing gear it is like it goes into neutral? It rev`s but doesnt not really go ?? It would normally take off pretty quickly when you would do that it seemed to start doing this on it`s own. I have tried adjusting the t.v. cable seems fine and is defitnetly hooked onto trans., I also dropped the pan and changed the filter and fluid which really did not appear that dirty and did not smell burnt ., I thought maybe the filter was clogged but that seemed good also , installed new one and added new fluid but is exactly the same?? The jeep has 150,00 on it I am thinking it is just broken in LOL any advice suggestions would be appreciated., Thanks Bill
seven is offline   Reply With Quote
Old 06-15-2013, 01:30 AM   #2
CF Veteran
 
Join Date: Apr 2012
Location: Wisconsin
Posts: 4,491

View Radi's Photo Album My Photos
Cherokee
Default

Does it accelerate normally if you shift by hand? Where (what rpm) does your torque converter stall out if you hold the brake and give it gas in gear?
Radi is offline   Reply With Quote
Old 06-15-2013, 06:28 AM   #3
Member
 
Join Date: Sep 2009
Posts: 144

View seven's Photo Album My Photos
1990 , 1997 ,1997, 2000 Cherokee
Default shifting problem

Thanks for the reply, It will shift normally if you do it by hand moving the shifter ., not sure what you mean by stalling out if you hit the gas pedal hard or make it go into passing gear that is when it feels like it neutralizes?? The tack will shoot up it will still pull the car but not like it did before??
seven is offline   Reply With Quote
Old 06-15-2013, 08:05 AM   #4
Senior Member
 
Demonoid369's Avatar
 
Join Date: Mar 2013
Location: salem, OR
Posts: 913

View Demonoid369's Photo Album My Photos
1997 Cherokee
Default

any mods? like bigger tires? when you are in 1st, does it accelerate like normal? or does it also feel funky? do you get any noises? if its doing funky things when in D and in 1st I'd say maybe the solenoid?
Demonoid369 is offline   Reply With Quote
Old 06-15-2013, 09:06 AM   #5
Member
 
Join Date: Sep 2009
Posts: 144

View seven's Photo Album My Photos
1990 , 1997 ,1997, 2000 Cherokee
Default trans shifting

It does have a 3 inch lift and 30 inch tires but that is it as far as mods it almost feels like the cat is clogged but that is only two months old?? It is very sluggish?? We have owned it with the mods., lift and tires and it was never like that before this just started ??
seven is offline   Reply With Quote
Old 06-15-2013, 09:25 AM   #6
Member
 
Join Date: Sep 2009
Posts: 144

View seven's Photo Album My Photos
1990 , 1997 ,1997, 2000 Cherokee
Default trans shifting?

I meant to say we have owned it for 3 years and never had this problem?? Don`t hear any noise sounds pretty quiet ., It almost feels like you are pulling a trailer uphill with a lot of weight on it, and then when you hit the pedal hard it feels like it goes into passing gear but just high rev`s /? and doesn`t really move?? It will not stall it just slow`s down , . The throttle body has been cleaned the tps changed the iac changed and a new dist.,cap rotor, plugs , battery and exhaust system The truck starts right up and run`s really well, idles perfect. I have a code reader and no codes present or pending?? ..Was wondering if it could be the gov solenoid not giving correct pressure??
seven is offline   Reply With Quote
Old 06-16-2013, 09:26 AM   #7
Member
 
Join Date: Sep 2009
Posts: 144

View seven's Photo Album My Photos
1990 , 1997 ,1997, 2000 Cherokee
Default trans shifting?

I ended up changing all the solenoids still no difference.. Another question is would I get a cel with this type of trans problem?? I have not had a cel or any codes present but trans is still not good it did seem to shift better but as soon as you hit the gas hard or if you were trying to get onto a parkway or highway it will neutrilize? I am thinking it is just worn any ideas? And a Happy Fathers Day to all!!
seven is offline   Reply With Quote
Old 06-16-2013, 11:34 PM   #8
CF Veteran
 
Join Date: Apr 2012
Location: Wisconsin
Posts: 4,491

View Radi's Photo Album My Photos
Cherokee
Default

At this point I'd find someone with a trans pressure gauge and see what your line pressure is doing. You did adjust the TV cable, sure it isn't set too loose?
If I'm reading your posts right, the trans operates mostly right, until you step on the gas hard at which point it slips and the engine revs way up? If so, check the trans pressure and perhaps the torque converter. I've had them break internally and still work normally until they're loaded down, at which point the broken fins bend and the trans slips.
Radi is offline   Reply With Quote
Old 06-17-2013, 12:22 AM   #9
Newbie
 
Join Date: Jun 2013
Posts: 12

View KDs93's Photo Album My Photos
Cherokee
Default

FWIW: have you checked the catalytic converter? Could be coming apart internaly causing a prob.... I know its a stretch and 99.9% not it but hey Im tryin lol

KD
KDs93 is offline   Reply With Quote
Old 06-17-2013, 07:59 AM   #10
Member
 
Join Date: Sep 2009
Posts: 144

View seven's Photo Album My Photos
1990 , 1997 ,1997, 2000 Cherokee
Default trans shifting ??

Hey Thanks for the reply`s The exhaust including the cat is about 2 months old?? I am pretty sure it is not the cat. , I did have that problem in the past with another jeep and it feels a little different... I am thinking it is, as suggested a problem with the converter or line pressure ?? When you take off slow it will shift fine it will even go into od. but as soon as you hit the pedal hard it does not want to move ,like it takes itself out of gear, or neutralizes?? let off the gas and it will start to operate normally again?? The problem is their are really no reputable shops around here .. I took a jeep about 4 years ago to our local ammoco shop in Hicksville, n.y. and they said it needed a new trans? totally shot .. I changed the shift solenoids and have put 75,000 miles on it with no problems, still going with the same trans? So tough to find an honest trans shop..I am pretty sure this is a converter problem..
seven is offline   Reply With Quote
Old 06-17-2013, 08:23 AM   #11
CF Veteran
 
HS00XJ's Avatar
 
Join Date: Apr 2012
Location: Ross Vegas, Ga
Posts: 1,018

View HS00XJ's Photo Album My Photos
2000 Cherokee
Default

Mine does kinda the same
When i stab it it feels like it slips abit but drives normal the rest of the time.keep us posted if ya find a fix
HS00XJ is offline   Reply With Quote
Old 06-18-2013, 06:51 AM   #12
Member
 
Join Date: Sep 2009
Posts: 144

View seven's Photo Album My Photos
1990 , 1997 ,1997, 2000 Cherokee
Default 97 trans shifting problems..

Ok, What I learned is that it is not holding line pressure?? It will work fine as long as you do not hit the pedal hard ., it is only when you try to engage the passing gear or accelerate fast.. I called the owner Robert Gaul Sr. of www.cascadetransmissionparts.com who really gave me a lot of help.. I have spoken to him in the past and also purchased some parts and he is alway`s a pleasure to deal with and really know`s what he is talking about.. He suggested the problem was in the valve body ., Their are several check ball`s inside and he felt that they were causing the shift problem .. I dropped the valve body as he said and it seems he is right on the money!! Time and hard use cause the check ball`s to oblong the steel gasket and case that they sit it and it does not allow pressure to build up in trans and will cause the shift problems I am having.. You can get another valve body or in my case I am swapping out the trans with one that I took out of a wreck several years ago and is supposed to be a rebuilt unit.. I am pretty sure the valve body alone would work but The trans has 160,000 hard miles on it and it needs to go another 160,000. I will keep you posted on how it goes..
seven is offline   Reply With Quote
Old 06-20-2013, 07:20 AM   #13
Member
 
Join Date: Sep 2009
Posts: 144

View seven's Photo Album My Photos
1990 , 1997 ,1997, 2000 Cherokee
Default trans swap??

Well, I finished the trans swap , can not believe I have the same exact problem?? So I am guessing it was not the trans in the first place?? I know the trans I swapped in was a good working low mileage trans?? It came out of a friends wreck and I was in the car two days before and it drove fine.. I am really unsure as to what it could be at this point?? I am pretty sure it is not in the trans ., The only thing I can think of is that I installed the solenoids in the wrong position ?? Their are three solenoids one is for o.d and the other two controll the shifts one solenoind can only fit in one position as it has a shorter install bracket that one is closest to the flexplate or the most forward in the trans ., The middle one looks the same as the rear one and has the same bracket for installing I missed something here I can not believe the two trans, have the same problem they both neutrilize when you hit hit the gas hard?? Anybody have any ideas?? it is a 97 cherokee 4.0 auto.. at a loss
seven is offline   Reply With Quote
Old 06-20-2013, 07:20 AM
 
 
 
submit to reddit
Reply
Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 04:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site is in no way affiliated with Jeep or Chrysler.

Emails Backup