Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech
Register Forgot Password?
Search

Welcome to Cherokee Forum!
Welcome to Cherokee Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 02-16-2009, 12:20 PM   #1
Newbie
 
Join Date: Feb 2009
Posts: 1

View wgvfc166's Photo Album My Photos
1996 Cherokee
Default 96 Cherokee: Another speedometer problem

Hi all, looking around it appears a LOT of other Cherokee's have had similar problems to mine, but mine has its own unique twist. About two years ago I suffered the misfortune of having my state inspection stickers stolen, so I had to get reinspected. Right after the unjust reinspection, my speedometer jumped for a brief moment, then stopped. I thought nothing of it and never went back to the shop. BIG mistake--a thousand miles down the road the speedometer and gas gauges both started going haywire (FYI all the warning lights in the dash work fine). I took it back to the shop, where I had the computer and speed sensors replaced. Everything seemed fine. I drove it very little over the next few months, since I was seriously considering selling and didn't want to add any more to the 187,000 miles already on the odometer.

I eventually moved back to the burbs and started driving it more again, especially when I joined the local fire company. Unfortunately, the same thing started happening again rather suddenly, and far more severely this time. I barely got it through last year's state inspection, both gauges going dead 30 miles later. I'm having a hard time believing that the computer or sensor died so suddenly after being replaced. I have virtually no mechanical aptitude, but I'm a computer guy, and this almost looks like I'm losing ground or something. Since I'm currently unemployed thanks to our tanking economy, I'd have a very hard time ponying up $500 to have the mess (maybe) fixed again, but I'd really like to keep the car past March. Trust me when I say having to drive a minivan the size of a bus full time, especially to fire calls, @#$%s!

My question is, is there a chance the dash cluster is grounded separately from other parts of the electrical system? If so, where approximately do I need to look? Or might I need to look further back towards the fuel tank, since the fuel gauge is involved too? The fact it started right after reinspection makes me wonder if a cable got nicked while it was on the lift or something. I took the dash apart and confirmed the data cables are securely connected to the dash cluster. Other than the fact I have to use a TomTom to verify my speed (well, after 180,000, I sort of know the speed just by feel, but you know, just in case...) and track my mileage on paper (nearly 2000 miles added since the odometer stopped working), it still drives perfectly, hence, why I really don't want to give up on an old friend. We've been through a lot! Any answers you can give me, including details about the approxiate location of where I need to look under the hood, etc, would be greatly appreciated.
wgvfc166 is offline   Reply With Quote
Old 02-16-2009, 02:45 PM   #2
Newbie
 
Join Date: Feb 2009
Posts: 3

View rob kuhn's Photo Album My Photos
Cherokee
Default

just started having same problem,
rob kuhn is offline   Reply With Quote
Old 07-30-2009, 01:14 AM   #3
Newbie
 
Join Date: Jul 2009
Posts: 3

View Wolfie's Photo Album My Photos
Cherokee
Default i have a 92 cherokee

i have a 92 Cherokee Laredo that i just got, the speedometer seems to work sine some times, but then it will Twitch around normally it's +5 up to + 45 mph from what I'm driving
it just jumps up and back for 1/2 second or so, some times it twitches around a bit for a few seconds then it'll go back to the correct speed any one else figured this out? i don't think it's a ground, any ideas?
Wolfie is offline   Reply With Quote
Old 07-30-2009, 08:38 AM   #4
Junior Member
 
Join Date: Oct 2008
Posts: 72

View jstewart1960's Photo Album My Photos
Cherokee
Default

It's the sensor for the speedometer, it is going bad and will only get worse and stop working, I've been through 2 of them on my 92.
jstewart1960 is offline   Reply With Quote
Old 07-30-2009, 11:28 AM   #5
Newbie
 
Join Date: Jul 2009
Posts: 3

View Wolfie's Photo Album My Photos
Cherokee
Default

as long as it's just the sensor i'm okay. I'll pickup a new sensor. My mom's 88 did that.... then the problem moved to the tach to then the gas gauge would go past full... shortly after the wiring harness in the steering collum melted down. i didn't want that to happen to mine.
Wolfie is offline   Reply With Quote
Old 07-30-2009, 11:46 AM   #6
Junior Member
 
Derrtydave's Avatar
 
Join Date: Jan 2009
Posts: 53

View Derrtydave's Photo Album My Photos
1998 Cherokee
Default Related Issue?

I noticed that, on occasion, my cluster RPM and Speedometer guages will go out (reading Zero) and my Airbag light pops on. This will last for a varying amount of time and them POOF! I get them back. My suspicion is that the sensor connection to the cluster is loose or the contacts need to be cleaned. The roads in my region are really in bad shape- lots of potholes and heaves-- and I suspect it's causing a lot of stuff to get jarred loose after a while.

I was having the same issue with my coolant temp guage this winter, and I fixed it by a) unplugging the sensor connector b) blowing it out with canned air c) firmly re-seating the connector. Problem fixed. If I can just find the danged instrument cluster connection, I expect I can do the same trick.
__________________
98 4.0L Classic
Derrtydave is offline   Reply With Quote
Old 08-01-2010, 12:20 PM   #7
Newbie
 
Join Date: Aug 2010
Location: Asheboro NC.
Posts: 1

View dprevatte's Photo Album My Photos
1998 Cherokee
Default Fuel gauge and speedo problems

I have just purchased a 1998 cherokee se 2 door from a buddy of mine and the fuel gauge and speedometer work sometimes and sometimes they don't. One may work and the other may not. No set pattern. My airbag light stays on most of the time. It will flash off and back on every now and again. What do I need to do to fix these problems? I will be giving this vehicle to my son in a few months for his first vehicle. Don't have lots of money to spend.
dprevatte is offline   Reply With Quote
Old 08-01-2010, 01:36 PM   #8
Newbie
 
Join Date: Aug 2010
Location: North Carolina
Posts: 5

View 98SheepCherokee's Photo Album My Photos
1998 Cherokee
Default

My 98 XJ does the same thing sometims
98SheepCherokee is offline   Reply With Quote
Old 08-01-2010, 02:50 PM   #9
Seasoned Member
 
Zackqb2's Avatar
 
Join Date: Mar 2009
Location: Kentucky
Posts: 392

View Zackqb2's Photo Album My Photos
2000 Cherokee
Default

I had the same prob out of my 96 Cherokee
__________________

Zackqb2 is offline   Reply With Quote
Old 08-01-2010, 02:57 PM   #10
CF Veteran
 
truckntractorhick's Avatar
 
Join Date: Dec 2009
Location: Harleysville, PA
Posts: 2,053

View truckntractorhick's Photo Album My Photos
1998 Cherokee
Send a message via AIM to truckntractorhick
Default

well i say check you dash connections 2 your instrument panel!
__________________
Git Er Done!!! []|||||||[]
the greatest tip of all......... get a repair manual!!!!
1998 Sport in progress
1998 Sport R.I.P. stupid old man who cant drive... (http://www.cherokeeforum.com/f46/98-...drainer-34916/)
1986 Wagoneer, my trail rig (http://www.cherokeeforum.com/f46/86-chop-topper-86442/)
truckntractorhick is offline   Reply With Quote
Old 08-02-2010, 05:12 AM   #11
Junior Member
 
Derrtydave's Avatar
 
Join Date: Jan 2009
Posts: 53

View Derrtydave's Photo Album My Photos
1998 Cherokee
Default check one thing first

Clean the terminals to your pos and neg battery. If theyre corroded even a little it can compromise the amount of juice the car is pulling from the battery, and weak electrical can cause a number of wierd things to happen while youre driving, one of which can be loss of signal to less-important functions (such as powering the instrument cluster). Cleaning my battery terminals got rid of this issue for me for a very long time.

That being said, it sounds as if youve got the usual failing instrument cluster connector. It can be replaced DIY with a $30 part from Chrysler, and you can probably find the detailed instructions on how to do it right on the internet (b/c this is a common issue with Cherokees).

Short term: when your gauges go dead and the Airbag light pops on, push the trip odometer reset button, this will sometimes restore your gauges. You can also bang the dashboard under the steering column.
__________________
98 4.0L Classic
Derrtydave is offline   Reply With Quote
Old 08-02-2010, 05:12 AM
 
 
 
submit to reddit
Reply

Tags
1996, cherokee, fuel, gauge, speedometer
Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My 1991 Cherokee Gas Gauge/Speedometer/Odometer Dead sws123 OEM Cherokee Tech 4 09-10-2011 07:31 PM
Speedometer Off Tkitt21 OEM Cherokee Tech 7 02-15-2009 04:55 PM
speedometer difference dollypup OEM Cherokee Tech 4 11-10-2008 04:56 PM
Speedometer erratic Andrew_1122 OEM Cherokee Tech 0 09-27-2008 10:20 AM
Speedometer problem?? GHOSTRACER Grand Cherokee Tech 3 01-22-2008 06:13 AM


All times are GMT -5. The time now is 12:20 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
This site is in no way affiliated with Jeep or Chrysler.

Emails Backup