Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech
Register Forgot Password?
Search


Welcome to Cherokee Forum!
Welcome to Cherokee Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 09-17-2009, 09:32 AM   #16
Newbie
 
lex1125's Avatar
 
Join Date: Jan 2009
Posts: 12

View lex1125's Photo Album My Photos
Cherokee
Default

I'm curious too.

...maybe he means a barbecue SKEWER?
__________________
1999 XJ 116,00 Desert Sand.

RIP: 1995 Jeep Cherokee Scrapped at 176,000
lex1125 is offline   Reply With Quote
Old 07-03-2010, 11:14 AM   #17
Newbie
 
Join Date: Jul 2010
Posts: 3

View jkentwe's Photo Album My Photos
Cherokee
Default Selector Defaults to Defrost

Followed all the answers and indeed it turned out that the vacuum hose was detached from the eng block, but took me some to locate, but now I have pics to help others.Name:  IMG_1610.JPG
Views: 554
Size:  96.1 KB

1999 Sport vacuum diagram-img_1612.jpg

Name:  IMG_1611.JPG
Views: 611
Size:  96.6 KB
jkentwe is offline   Reply With Quote
Old 07-03-2010, 12:37 PM   #18
Member
 
kbad's Avatar
 
Join Date: May 2010
Location: southlake, TX
Posts: 155

View kbad's Photo Album My Photos
1996 Sport Cherokee
Default

if that nipple gets bogged down, it'll stall out anytime you start it up, so make sure it and the vacuum hoses are clean inside.....that nipple is a good place to spray in some tb cleaner or seafoam to clean out your intake (use a couple feet of 1/4" hose and connect to the nipple)....just a little at a time so as not to choke it up!....good idea to follow that tube to the other end, to the egr (i think it's called the egr!?!? it's on the firewall in front of the passenger, has some kind of diaphragm inside) and spray some from that end...it'll clean out your "egr" vacuum.

Last edited by kbad; 07-03-2010 at 12:41 PM.
kbad is offline   Reply With Quote
Old 07-30-2010, 06:15 PM   #19
Junior Member
 
Autonomous's Avatar
 
Join Date: Jan 2010
Location: Houston
Posts: 63

View Autonomous's Photo Album My Photos
1999 Cherokee
Default

That pic saved my day. I searched vacuum diagrams for an hour and there was no good picture. I started at the bumper ball and traced the lines all the way back to the engine where it was dangling off but too dark to see where it was missing from.

Hurray for working AC Vents and Cruise Control!
Autonomous is offline   Reply With Quote
Old 01-09-2011, 12:11 AM   #20
Newbie
 
Join Date: Jan 2011
Posts: 5

View rocknrolla's Photo Album My Photos
Cherokee
Default

Well that almost fixed it. Just bought a 2001 Xj and found out heater only works on defrost. I checked the vacuum lines on engine block and sprayed with throttle body cleaner. Now I have warm air comin out of dash as well but still nothing on the floor. Any suggestions?
rocknrolla is offline   Reply With Quote
Old 01-26-2011, 12:29 AM   #21
Newbie
 
Join Date: Jan 2011
Posts: 1

View daddy rabbit's Photo Album My Photos
Cherokee
Default 1999 cherokee sport vacum

[QUOTE=monnieh;101440]OK, so I can not get the air to come out of anywhere but the defroster. Read all the posts about finding a vacuum leak. CAN NOT find a leak anywhere! Started tearing my console/dash apart but not enough room to really see anything.

Does anyone have a XJ vacuum diagram for the HVAC system they could send me????

I am very frustrated by not being able to fix this

i have a 1999 cherokee sport, i had the same problem and also my cruise would not work right. I found the vacum line that goes out of the front of the cruise control, between the battery and the fender well on the passenger side broken. The same line goes on threw the opening for the head light, but i don't know were it goes from there ? I sharpen off a piece of stick and plugged the line and every thing started working fine.
hope this helped
Daddy Rabbit
daddy rabbit is offline   Reply With Quote
Old 05-27-2011, 07:38 AM   #22
CF Veteran
 
CoffeeCommando's Avatar
 
Join Date: Apr 2010
Location: Afghanistan
Posts: 1,232

View CoffeeCommando's Photo Album My Photos
1998 Cherokee
Default

[quote=daddy rabbit;829790]
Quote:
Originally Posted by monnieh View Post
OK, so I can not get the air to come out of anywhere but the defroster. Read all the posts about finding a vacuum leak. CAN NOT find a leak anywhere! Started tearing my console/dash apart but not enough room to really see anything.

Does anyone have a XJ vacuum diagram for the HVAC system they could send me????

I am very frustrated by not being able to fix this

i have a 1999 cherokee sport, i had the same problem and also my cruise would not work right. I found the vacum line that goes out of the front of the cruise control, between the battery and the fender well on the passenger side broken. The same line goes on threw the opening for the head light, but i don't know were it goes from there ? I sharpen off a piece of stick and plugged the line and every thing started working fine.
hope this helped
Daddy Rabbit
That line going through the headlamp is supposed to go down under the bumper where that plastic ball of vacuum is. It's bigger than your hand so you can't miss it.
CoffeeCommando is offline   Reply With Quote
Old 09-19-2011, 02:52 PM   #23
Junior Member
 
cherokee104's Avatar
 
Join Date: Dec 2010
Location: SOMERTON ARIZONA
Posts: 58

View cherokee104's Photo Album My Photos
2000 Cherokee
Default

I have the same problem i replaced the line that is next to the battery that goes down the the vacuum ball thinking this was it but it wasn't. so i checked all my vacuum lines that are around my engine and all of them were fine, I also checked the vacuum ball to see if it had any cracks but no cracks. ANY HELP!!!
cherokee104 is offline   Reply With Quote
Old 09-20-2011, 01:42 AM   #24
Newbie
 
Join Date: Jul 2010
Posts: 3

View jkentwe's Photo Album My Photos
Cherokee
Default De-frost Only

See photo I posted a while a go. This hose was off or loose, as soon as I reconnected all returned to normal. The air provides pressure to change air flow.
Attached Images
 
jkentwe is offline   Reply With Quote
Old 10-02-2011, 02:49 PM   #25
Junior Member
 
cherokee104's Avatar
 
Join Date: Dec 2010
Location: SOMERTON ARIZONA
Posts: 58

View cherokee104's Photo Album My Photos
2000 Cherokee
Default

I checked the line but all was good dont know what can be it any help
cherokee104 is offline   Reply With Quote
Old 01-24-2012, 10:09 PM   #26
Newbie
 
Join Date: Dec 2010
Posts: 1

View diamondwash's Photo Album My Photos
Cherokee
Default

I am too having that same problem all lines seem OK no leaks could it be those vacuum valves the lines have connected to them?
diamondwash is offline   Reply With Quote
Old 03-03-2012, 09:50 PM   #27
Newbie
 
Join Date: Mar 2012
Posts: 1

View xjthad_au's Photo Album My Photos
Cherokee
Default

Quote:
Originally Posted by jkentwe View Post
See photo I posted a while a go. This hose was off or loose, as soon as I reconnected all returned to normal. The air provides pressure to change air flow.
Thanks for posting this jkentwe, saved me loads of time sorting out my '01 XJ over here in Oz!
xjthad_au is offline   Reply With Quote
Old 03-06-2012, 02:01 AM   #28
Newbie
 
Join Date: Jul 2010
Posts: 3

View jkentwe's Photo Album My Photos
Cherokee
Default Vacuum hose detached causes only deforst mode

Look for the vacuum hose detached from the block..see pic.
Click the image to open in full size.
jkentwe is offline   Reply With Quote
Old 03-06-2012, 11:00 AM   #29
Senior Member
 
413maxwedge's Avatar
 
Join Date: Jan 2011
Location: Upstate N.Y
Posts: 689

View 413maxwedge's Photo Album My Photos
2000.1999,1996 Cherokee
Send a message via Yahoo to 413maxwedge
Default

Quote:
Originally Posted by monnieh View Post
OK, so I can not get the air to come out of anywhere but the defroster. Read all the posts about finding a vacuum leak. CAN NOT find a leak anywhere! Started tearing my console/dash apart but not enough room to really see anything.

Does anyone have a XJ vacuum diagram for the HVAC system they could send me????

I am very frustrated by not being able to fix this!!!!
I got one in my HAYNES MANUAL doesn't your have it?
__________________
YOU CAN'T CURE STUPID, AND BOY DO WE HAVE ALOT IN THE GENERATION OF THE 80'S & 90'S--------------------------------------------------------(MILLWRIGHT LOCAL #1163)
413maxwedge is offline   Reply With Quote
Old 03-06-2012, 09:21 PM   #30
Junior Member
 
cherokee104's Avatar
 
Join Date: Dec 2010
Location: SOMERTON ARIZONA
Posts: 58

View cherokee104's Photo Album My Photos
2000 Cherokee
Default

I found my problem to my ac malfunction it was my crack pipe on my cherokee
cherokee104 is offline   Reply With Quote
Old 03-06-2012, 09:21 PM
 
 
 
submit to reddit
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuse diagram anyone? Nito OEM Cherokee Tech 17 10-02-2011 01:12 PM
1999 Cherokee Sport won't start after crash rstone OEM Cherokee Tech 12 08-25-2009 02:25 PM
1999 Jeep Cheroke Sport 4x4 monnieh OEM Cherokee Tech 6 12-24-2008 08:56 PM
vacuum diagram goodoleboyz250 OEM Cherokee Tech 0 09-30-2008 10:47 AM
Diagram Lowrange2 OEM Cherokee Tech 3 08-06-2008 02:43 PM

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 02:43 AM.


This site is in no way affiliated with Jeep or Chrysler.

Emails Backup