1996 Cherokee idle surge/die nightmare. Help..... - Jeep Cherokee Forum
Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech
Log In 
Search


1996 Cherokee idle surge/die nightmare. Help.....

Reply
 
 
 
 
Thread Tools Search this Thread
Old 10-02-2009, 09:20 AM   #1
Newbie
 
Join Date: Sep 2009
Posts: 5

View Julian1221's Photo Album My Photos
Cherokee
Default 1996 Cherokee idle surge/die nightmare. Help.....

Hey guys,

I've searched through several different threads trying to diagnose the problem of a Cherokee I picked up about a month and half ago. The car starts up almost right away but the idle will go from around 600rpm to 1100 and keep bouncing up and down until it dies. First thing I did was replace both O2 sensors and ran some seafoam through the car. As we started pouring the Seafoam in there was a pop as if a gasket had popped open and a little bit of smoke came as if some oil spit out on the exhaust manifold as if the Intake Manifold gasket had popped. Car still drove the same and no oil was leaking. Next I replaced the CPS and the fuel filter and still no luck. The TPS looks like it is reading normal and the car is not throwing any codes execpt when the car dies in drive it throws the Park/Neutral P1899 code. My next guess is to replace that gasket but I wanted everyones thoughts on here first. I also heard the possibility of the clockspring causing this and the cruise doesnt work on the car.

Last edited by Julian1221; 10-02-2009 at 09:27 AM.
Julian1221 is offline   Reply With Quote
Join Cherokee Forum

Join CherokeeForum.com Today - It's Totally Free!

Do you love your Jeep? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Jeep Fans to meet online.
Once you join you'll be able to post messages, upload pictures of your jeep, and have a great time with other Jeep Cherokee fans.. Whether your an old timer or just bought your Jeep you'll find that CherokeeForum.com is a great community to join. Best of all it's totally free!

Join CherokeeForum.com Today! - Click Here JOIN FOR FREE


-->
Old 10-02-2009, 12:57 PM   #2
CF Veteran
 
troy fritz's Avatar
 
Join Date: Jul 2009
Posts: 2,447

View troy fritz's Photo Album My Photos
Send a message via AIM to troy fritz
Default

Are you sure the popping wasnt backfire through the throttle body? I would check the tps again. Take it off and adjust it , see if that does anything If it does but not for the good then adjust it the opposite way .If it chages again then I would replace it.
troy fritz is offline   Reply With Quote
Old 10-02-2009, 01:24 PM   #3
Newbie
 
Join Date: Sep 2009
Posts: 5

View Julian1221's Photo Album My Photos
Cherokee
Default

Quote:
Originally Posted by troy fritz View Post
Are you sure the popping wasnt backfire through the throttle body? I would check the tps again. Take it off and adjust it , see if that does anything If it does but not for the good then adjust it the opposite way .If it chages again then I would replace it.
It read out like .73 and 4.02 under WOT


Im having a pretty much identical problem as this guy.
http://www.cherokeeforum.com/f2/idle...g-issue-25178/
Julian1221 is offline   Reply With Quote
Old 10-06-2009, 06:11 PM   #4
Newbie
 
Join Date: Sep 2009
Posts: 5

View Julian1221's Photo Album My Photos
Cherokee
Default

The motor in the car is out of a 89. Is it possible the 96 ecu isnt adjusting the timing right?
Julian1221 is offline   Reply With Quote
Old 10-07-2009, 09:33 AM   #5
Newbie
 
Join Date: Sep 2009
Posts: 5

View Julian1221's Photo Album My Photos
Cherokee
Default

Any other ideas?
Julian1221 is offline   Reply With Quote
Old 10-07-2009, 05:11 PM   #6
Member
 
Join Date: Feb 2009
Location: Conroe, Tx
Posts: 147

View McRay's Photo Album My Photos
1996 & 2001 Cherokee
Default

Did you use all electrical, like old disturber, manifold, tps sensor map sensor, might try cleaning throttle body, I have had dirty manifold cause idle problems or if its old engine that been setting valves may be sticking - spraying wd 40 around intake manifold check for leaking.
__________________
1996 Jeep Cherokee 2 WD Engine 4.0
Transmission Aisin AW 30-43LE
2001 Jeep Cherokee Sport
Conroe, Tx
McRay is offline   Reply With Quote
Old 10-09-2009, 09:41 AM   #7
Newbie
 
Join Date: Sep 2009
Posts: 5

View Julian1221's Photo Album My Photos
Cherokee
Default

Quote:
Originally Posted by McRay View Post
Did you use all electrical, like old disturber, manifold, tps sensor map sensor, might try cleaning throttle body, I have had dirty manifold cause idle problems or if its old engine that been setting valves may be sticking - spraying wd 40 around intake manifold check for leaking.

Whats hard is I purchased the car and don't really know exactly what he did.
Julian1221 is offline   Reply With Quote
 
 
 
Reply

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 06:08 PM.


This site is in no way affiliated with Jeep or Chrysler.

Emails Backup