Jeep Cherokee Forum

Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech
Register Forgot Password?
Register Photos FAQ Members List Social Groups Search Today's Posts Mark Forums Read GarageVendor DirectoryvBLive
Search

Welcome to Cherokee Forum!
Welcome to Cherokee Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread Display Modes
Old 06-01-2012, 05:12 PM   #1
Newbie
 
Join Date: May 2012
Location: Mill City, Oregon
Posts: 7

View krissmis33's Photo Album My Photos
1996 Cherokee
Default 1996 Cherokee, crank, no start???

I have a 1996 Cherokee Sport, 2 Door, 4x4, Straight 6, thats deciding to not start.

This has happened to me before. Ive been doing hard wheeling and the motor will just shut off but all the electrical stays on. I was able to start the Jeep right after that happened and drive off fine.

I went out again a month later drove out of some water than the motor shut off again. This time I couldnt start it after. It sat in my driveway after trying all the reccomended things. Three weeks later I tried it and it started right up after doing NOTHING!

Next im driving in the hills and it does it AGAIN! Tow it home and check to see whats going on. Getting NO SPARK at all. Ive tried replacing the coil, crankshaft sensor, distributor, and I have no idea what to do. Ive read about the NSS, Oxygen sensor, and Igniton switch. Forgot to mention that the Cherokee has always had starting problems whether it involved me wiggling the wires to the battery or dropping it down in Neutral or wiggling the shifter.

Please help so I can stop spending money on this dang thing.
Thank You!!!
krissmis33 is offline   Reply With Quote
Old 06-01-2012, 05:15 PM   #2
CF Veteran

 
ZINGGG's Avatar
 
Join Date: Oct 2011
Location: Seal Beach, CA
Posts: 4,388

View ZINGGG's Photo Album My Photos
1996 Cherokee
Default

Clean all your grounds and both battery terminals, get your battery load tested and get your alternator tested while you're there, which can be done for free.

Where did you get the crankshaft position sensor from?
__________________
Formerly 1996sportXJ

If needed to replace, UPGRADE!!

'96 XJ 4-door Sport 4.0L, AW4, NP231, HP D30, 8.25
w/ 4" Teraflex lift, 33" BFG K/Os on Black Rock Soft 8s, 4.56 gears (thank you RWKHausSupply), APN header, Precision Auto Injectors, bored throttle body (thank you Thexjfiles), Spectre Intake, 2.5" Magnaflow catback (thank you mudfrog), Optima red top, Kelley's WiP 4 gauge battery cables (thank you 5-90), 10" cubby subwoofer (thank you KFXHellRaiser), 1-ton steering (thank you SeriousOffroad), front Crusader prerunner bumper (thank you JCR Offroad), sliders and rear bumper/tire carrier (thank you Ares Fab), Hyline Hood Vents, Truck Lite LEDs and more
ZINGGG is offline   Reply With Quote
Old 06-01-2012, 05:52 PM   #3
Newbie
 
Join Date: May 2012
Location: Mill City, Oregon
Posts: 7

View krissmis33's Photo Album My Photos
1996 Cherokee
Default

I got it from Napa. But it wasnt the High Mileage or whatever it was. I got the higher end one. I shoulda mentioned that when I try to start it, it just cranks and cranks and all the electrical comes on and i can hear the fuel pump. The check engine light was always on as well.
krissmis33 is offline   Reply With Quote
Old 06-01-2012, 06:05 PM   #4
CF Veteran

 
ZINGGG's Avatar
 
Join Date: Oct 2011
Location: Seal Beach, CA
Posts: 4,388

View ZINGGG's Photo Album My Photos
1996 Cherokee
Default

Did you get the codes read? Take it to your auto parts store to get it read so you can see what's really going on.

And the crank sensor is something that you want to get directly from the dealer. Any aftermarket CPS has a tendency to not work up to par in our XJs
__________________
Formerly 1996sportXJ

If needed to replace, UPGRADE!!

'96 XJ 4-door Sport 4.0L, AW4, NP231, HP D30, 8.25
w/ 4" Teraflex lift, 33" BFG K/Os on Black Rock Soft 8s, 4.56 gears (thank you RWKHausSupply), APN header, Precision Auto Injectors, bored throttle body (thank you Thexjfiles), Spectre Intake, 2.5" Magnaflow catback (thank you mudfrog), Optima red top, Kelley's WiP 4 gauge battery cables (thank you 5-90), 10" cubby subwoofer (thank you KFXHellRaiser), 1-ton steering (thank you SeriousOffroad), front Crusader prerunner bumper (thank you JCR Offroad), sliders and rear bumper/tire carrier (thank you Ares Fab), Hyline Hood Vents, Truck Lite LEDs and more
ZINGGG is offline   Reply With Quote
Old 06-01-2012, 06:09 PM   #5
Newbie
 
Join Date: Oct 2010
Location: Santa Maria, Ca
Posts: 8

View crazyangels's Photo Album My Photos
97' Cherokee
Default

I had the same issue with mine some time ago and it ended up being that due to winter, the coil wire harness was wet inside where it connects to the coil. I dried it out and added some silicone lube, the kind you use on spark plugs and never had that issue again. HTH

Jorge
crazyangels is offline   Reply With Quote
Old 06-01-2012, 06:26 PM   #6
Newbie
 
Join Date: May 2012
Location: Mill City, Oregon
Posts: 7

View krissmis33's Photo Album My Photos
1996 Cherokee
Default

@1996sportxj the first time I did the codes it didnt come up with any. I dont think its the CPS though because the first time this happened I put a new one on and it didnt change a thing, but it suddenly started. Everytime this happens is when the motors hot, or im in wet conditions?
krissmis33 is offline   Reply With Quote
Old 06-01-2012, 06:26 PM
 
 
 
submit to reddit
Reply

Tags
cherokee, coil, crankshaft position, ignition control module, spark
Go Back   Jeep Cherokee Forum > Technical Discussion > OEM Cherokee Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 06:16 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.5.2
This site is in no way affiliated with Jeep or Chrysler.

Emails Backup